No audio after update from FC33 to FC34

After update from FC33 to FC34 , I no longer have audio output . The only device for shown is “dummy” .System is dual boot and under WIN , the audio is fine . Additionally, after update finished, the usual restart was done, but the system is still asking for restart , even though multiple restarts have been done . Message box is titled Plasma Workspace . Network connections were also removed, but with nmcli I got the network ethernet back up . Not sure if these are all connected but wanted to give as much info as possible . System is Dell latitude with Xeon and 32 GB RAM . I am guessing something in Pulse audio but not sure where to start . Thank you

I would suggest that you do

sudo dnf distro-sync

then after that is complete reboot and see if there is any difference.

It may be related to the change from alsa to pipewire for audio.

Just to confirm, since F35 is just out now — are you now on F35 or did you decide to stay one release back? (Nothing wrong with that, since it’s still supported… just checking!)

On FC34, update was just done a few days ago .

1 Like

Tried the distro -sync , but insufficient space in /boot . I assume I should remove oldest kernel , as I have done before . (with YUM )

If /boot is small enough that a normal update says insufficient space then the first step I would recommend is fix the file system space. This can be done usually using gparted when booted to either gparted live or a fedora live image and then using gparted.

It is quite likely that insufficient space in one or more file systems will interfere with a proper update and/or subsequent operation.

Can you give us the output of

df -Th


Here is output –

$ df -Th
Filesystem Type Size Used Avail Use% Mounted on
devtmpfs devtmpfs 16G 0 16G 0% /dev
tmpfs tmpfs 16G 0 16G 0% /dev/shm
tmpfs tmpfs 6.3G 1.8M 6.3G 1% /run
/dev/mapper/hd-root ext4 50G 23G 24G 50% /
tmpfs tmpfs 16G 12K 16G 1% /tmp
/dev/nvme0n1p7 ext3 283M 255M 14M 96% /boot
/dev/nvme0n1p1 vfat 496M 55M 442M 12% /boot/efi
/dev/mapper/hd-home ext4 757G 30G 689G 5% /home
tmpfs tmpfs 3.2G 924K 3.2G 1% /run/user/1002

here is the kernel listing
rpm -qa|grep kernel


That tells me you have /boot (283 MB) at 96% full with 255 MB used.

My system has this

$ df -Th 
Filesystem                   Type  Size  Used Avail Use% Mounted on
/dev/mapper/fedora-root      ext4   98G   71G   22G  77% /
/dev/sda2                    ext4  2.9G  181M  2.6G   7% /boot
/dev/mapper/fedora_raid-home ext4  4.0T  3.4T  348G  91% /home
/dev/sda1                    vfat  250M   19M  231M   8% /boot/efi

$ ls -l /boot
total 167385
-rw-r--r--. 1 root root   236667 Oct 18 08:10 config-5.14.13-200.fc34.x86_64
-rw-r--r--. 1 root root   236656 Oct 20 11:32 config-5.14.14-200.fc34.x86_64
-rw-r--r--. 1 root root   236656 Oct 27 11:09 config-5.14.15-200.fc34.x86_64
drwx------. 4 root root    16384 Dec 31  1969 efi
-rw-r--r--. 1 root root   155544 Jan 27  2021 elf-memtest86+-5.31
drwxr-xr-x. 2 root root     3072 Jul  8 00:36 extlinux
drwxr-xr-x. 2 root root     1024 Oct 16 02:20 flask
drwx------. 4 root root     1024 Nov  2 22:41 grub2
-rw-------. 1 root root 87772106 Dec 10  2020 initramfs-0-rescue-730854f859414ee8ab2aff2cbe878557.img
-rw-------. 1 root root 35877631 Oct 22 02:20 initramfs-5.14.13-200.fc34.x86_64.img
-rw-------. 1 root root 36029520 Oct 29 02:21 initramfs-5.14.14-200.fc34.x86_64.img
-rw-------. 1 root root 35983507 Nov  4 02:20 initramfs-5.14.15-200.fc34.x86_64.img
drwxr-xr-x. 3 root root     1024 Dec 10  2020 loader
drwx------. 2 root root    12288 Dec 10  2020 lost+found
-rw-r--r--. 1 root root   153868 Jan 27  2021 memtest86+-5.31
-rw-------. 1 root root  5850164 Oct 18 08:10
-rw-------. 1 root root  5850222 Oct 20 11:32
-rw-------. 1 root root  5850417 Oct 27 11:09
-rwxr-xr-x. 1 root root 10782824 Dec 10  2020 vmlinuz-0-rescue-730854f859414ee8ab2aff2cbe878557
-rwxr-xr-x. 1 root root 10965904 Oct 18 08:10 vmlinuz-5.14.13-200.fc34.x86_64
-rwxr-xr-x. 1 root root 10967056 Oct 20 11:32 vmlinuz-5.14.14-200.fc34.x86_64
-rwxr-xr-x. 1 root root 10968656 Oct 27 11:09 vmlinuz-5.14.15-200.fc34.x86_64
-rw-r--r--. 1 root root     1917 Oct  6 14:42 xen-4.14.3.config
-rw-r--r--. 1 root root  1183128 Oct  6 14:43 xen-4.14.3.gz
lrwxrwxrwx. 1 root root       13 Oct  6 14:43 xen-4.14.gz -> xen-4.14.3.gz
lrwxrwxrwx. 1 root root       13 Oct  6 14:43 xen.gz -> xen-4.14.3.gz

While my /boot partition is larger, you can see I only have 181 MB used with 3 kernels installed while you have 255 MB with only 2 kernels.

  1. What is taking up the extra space in /boot?
  2. Can you remove unneeded stuff from /boot?
  3. Is it possible to make /boot (/dev/nvme0n1p7) larger? If you were to reduce the size of the /home LV slightly then reduce the VG (hd) slightly that would leave plenty of room to make /boot larger so you have room to do updates. Gparted could be used to handle the moving of partitions and resizing once the LVM config is finished.

To me it seems the simplest would be resizing /boot but it is up to you how you fix the space issue.

There is a rescue img in boot 700 MB .+ there are 3 kernels, not2

I will clear out the oldest kernel and see what happens . Will advise.


IME it is generally a good idea to have /boot of at least 500 MB or larger.

Check man dnf.conf

`> installonly_limit

          Number of installonly packages allowed to be  installed  concur‐
          rently.  Defaults  to 3. The minimal number of installonly pack‐
          ages is 2. Value 0 means unlimited number of  installonly  pack‐
          ages.  Value  1  is explicitely not allowed since it complicates
          kernel upgrades due to protection of the running kernel from re‐


You probably have the default … you can decrease to number 2 then you have just 2 Kernels.

I did not want to resize /boot at this time , since backup computer very old and I need to have this one functioning for business . Will try in future , though .
I removed the oldest kernel and the distro-sync worked without complaints. However, I am still getting "Restart is Required " notification . System has been restarted several times and from a shutdown also. The sound does still not work . Only "dummy output " So, 2 issues, may or maynot be related.

  1. the restart notice- I can ignore but concerning
  2. no sound- problematic- not sure where to start to analyze-

Question is “are they related ?”
Suggestions ?


Thanks for the suggestion to lower limit from 3 to 2 . I have done that . I will check after next update to see that I have space , now with only 2 kernels, rather than 3 .

Still have the nag screen that I need to restart , although I have several times . Only comes on with boot and can be turned off on screen, but the machine thinks it needs a restart . Any thoughts ?

Could not recall if I answered this, apologies, but I am on FC34, not 35 . Still no audio, but am reviewing files on manpages for pipewire . Haven’t yet figured them out . Suggestions ?? Still only shows output to dummy .


Releases/34/ChangeSet - Fedora Project Wiki
Check out point 1.3 follow the links