No apps after upgrading to F35

I also have the same problem. I can’t even launch the terminal to do the steps. tried alt+f2 but it also didn’t work after writing gnome-terminal. What should I do?


This never happened in Fedora 34 but now I have updated to 35 this is happening.

1 Like

Can You use gnome-software?
Just re install Fedora?

1 Like

Can you share a screenshot please? I understand what’s going on, but we need more information to figure out what’s causing it.

  • did the upgrade go correctly?
  • are you able to get to a tty? ctrl alt f3? Can you use it to check on the logs to see what errors there are?

Also, was the upgrade using dnf or gnome-software? Were you able to run the cleanup steps?

PS: I don’t think we need to re-install just yet, we can use that option if nothing else works :slight_smile:


I can’t use gnome-software. I first upgraded with dnf from f34 after updating it didn’t boot up (I can only see a blinking cursor).

I made a clean installation (Dualbooting with windows)from latest iso using pendrive. At first boot it was completely fine then I updated the os from gnome software and it was also file on the first boot but after that this error is happening.

that’s odd. Are you able to get to a tty using ctrl alt f3?

1 Like

Yes, I am able to get “tty3”. I logged to my account wrote a command and nothing works just says package sudo is not available do you want to install it N/y? I type y then it says Waiting in queue and at last says package sudo is already installed. And nothing works also in tty2

can you please see if you can access your journal to see if there’s anything there that may give us a hint?

in tty3, can you please also run:

rpm -qa | wc -l

and tell us what it says?

It’s very odd that sudo isn’t found—have you tinkered with your .bashrc etc. to change various environment variables and so on?

Another thing to test: can you create a new user to see what happens? (If you get the same issue, then it’s a system wide problem, otherwise it’ll be a user account specific issue)

The tool that automatically installs missing commands is not super-smart. It is fooled by something happening to your PATH environment variable, which tells your shell where to find the executable files for commands. If PATH is wrong (or non-standard) it will think things are gone when they’re not.

I’m not sure why it’s missing, but, as a first step, in that try, type:

export PATH=/bin:/sbin
sudo -v

I hope that will get you to a place from which we can figure out and fix what’s going on.

I am Sorry to contact late. But it’s still not working.

I used PATH variable only to set my java installation and next line JAVA_HOME

Can you please show the current value of PATH? My guess is that it is set to only the Java location, not the standard locations plus Java.

1 Like

I have found the solution and the log file of java. I made a fedora bootable usb then I used gedit to edit the environment variables file then I removed all the content of java and it booted after I booted fedora and it was successful.


Here is the log of java.

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f76a5c349d0, pid=21839, tid=0x00007f76981ce640
# JRE version: Java(TM) SE Runtime Environment (8.0_202-b08) (build 1.8.0_202-b08)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.202-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  []  XInternAtom+0x40
# Core dump written. Default location: /home/sj/core or core.21839
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

Environment Variables: