No applications theme option in gnome tweaks

I recently installed a theme on Fedora 36, but I cannot find an option to change ‘Application theme’ in tweaks, which was there earlier as far as I remember. How can I change the theme now, I can only change shell theme and icon pack.

I don’t know if I understand exactly what you mean, but in the ‘Tweaks’ app, the fifth option lets me choose a theme for ‘Legacy Applications’. Is this the setting what you’re looking for?


I have applied the theme for legacy applications but it does not apply to the settings, calculator etc apps

Did you reboot your computer? I’ve read that a reboot might be necessary.

Other posts mentioned that changing to the light theme/dark theme applied the legacy themes. I never change the theme, I didn’t know it was this buggy.

I hope one of these options solves your problem.

If your looking for the light dark settings in gnome42 it’s in settings now where you change the background.

Fedora 36 uses Gnome 42 which uses GTK4/libadwaita.
Not all of the applications have switched to GTK4.
Legacy applications covers those.
I had the best luck using the advice from here [Partialy solved] Gnome 42, I don't understand how theming works now. / Applications & Desktop Environments / Arch Linux Forums

I ended up adding export GTK_THEME="Arc:dark" to my bashrc.

1 Like

No. Changes if any are immediately effective. Fedora 36. At worst logout login, no reboot.