New to Linux and Fedora 36, would appreciate help on some questions and why things don't work

Hello, I’m new here.

After breaking my Windows 10 OS with scripts, I finally decided that it's time that I switch to Linux and force myself to learn it. I've settled on Fedora, because I felt that it wouldn't be too streamlined like deb/ubuntu/mint derivatives, while not being as time-consuming as arch, therefore being the perfect balance. Plenty of others have also vouched for it as a search-ending distro for those who like to distro-hop.

Unfortunately my experience with Fedora 36 so far has been at best, interesting, and at worst, just broken, and I'm not quite sure as to why. I have a list of issues, and would appreciate any advice on how to rectify any of them. I really hope that I won't have to go to a different distro, or worse, back to Windows. I did end up using this list, as well if it helps,

Please note, I am not Linux proficient. I grew up on Windows, since XP for ~15 years of my life, and It took me at least an entire day to learn that:

  • Fedora 36 doesn't natively install .deb package files, (.rpm instead)
  • Packages aren't what I thought they were, (some kind of software to install the software? not as simple as window's executable, maybe more like a .msi)
  • "sudo" (means superuser do, administrator equivalent)
  • "sudo apt" doesn't work on fedora (dnf package manager is used instead)
  • That I don't know any terminology or commands, like what is cli/terminal or repo, or distro, etc. (Command Line Interface/terminal, is like command prompt, repo = repository, which can hold files to download or use, distro = distribution or types of linux), plenty more things I don't know
  • etc. etc., so any pointers for additional resources would be great.

Here are some of my specs that I got from neofetch, (Is this best?)
I don't believe my machine to be slow, but not modern either:

OS: Fedora Linux 36 (Workstation Edition)
Host: AB350-Gaming 3
Kernel: 5.18.5-200.fc36.x86_64
Packages: 2032 (rpm), 13 (flatpak)
Shell: bash 5.1.16
Resolution: 2560x1440
DE: GNOME 42.2
CPU: AMD Ryzen 5 1600 (12) @ 3.200GHz
Memory: 3510MiB / 15800MiB (16gb)

I can provide any other information from inxi -Fzx, like I see from some users post if needed.
And now onto the questions:

  1. Why do some software from certain repositories work, while others don't?
  2. This was a really strange phenomenon that I noticed while downloading software. So, in the beginning I had no idea how to install software onto Linux.

    After some googling, I came on this article,, after looking up "how to install discord on fedora". They recommended initially using the rpmfusion repository, and after installing and running it, i ended up with a black box. I thought that this was the best way since logically, the terminal is your best friend. However, I found that no matter how much I installed and uninstalled it, Discord would always continue to be a black box, and not load correctly.

    I then noticed that there is the Software Center. I looked up Discord in it, and found it there, with a repository in the top right called flatpaks from flathub, and opted to try and install discord that way instead. It worked perfectly fine. What. Well except for that fact that I can't screenshare.

    After using the Software Center and it working so well, I've opted to use it to install Steam. This installation proved to be much more straightforward and clean, as there were 3 different installations offered, 2 from rpmfusion and 1 from flatpaks. I found the rpmfusion one to be more cleaned up, as the flatpak was larger, slightly slower, and less refined, like for example the connecting to Steam Account: username window had a default background. All 3 worked fine though.

    Hoo boy, there are issues. VLC is my usual go to player for videos. I tried the rpmfusion and flatpak releases from VLC, and suffered from video quality constantly stuttering. Audio was fine though. I know VLC cannot handle .mkv without tinkering, such as changing thread counts, but nothing I did worked, and it had issues running standard mp4 as well. No go.

    Gnome's Default Video Player:
    This worked perfectly fine, except for some reason subtitles are displayed all the way on the left for some reason. This isn't acceptable for me, since I really like to use subtitles, and I was unable to change the position of the subtitles. I don't know if the option exists, but I really hope it does as it's a minor grip for a video player that does work.

    Looking for an alternative to VLC, I found that some users of Linux swore by MPV. Unfortunately, the flatpak version, installed through the Software Center didn't work. When launched, it would only display a black window, once again. In order to even try and install mpv from the rpmfusion repo, I had to do it through the terminal, and that also resulted in the same black window.

    I downloaded Kate, since I hear that a lot of Linux users on KDE liked to use it for text editing. I didn't know what a DE was at this point, but I figured that Kate would probably be good to learn. It's strange, because it did install well, (from Fedora repo (rpm) through terminal), and I could use it. However, every time I clicked on settings, it crashed. I found this deal breaking, since I really wanted Kate's dark mode and some other things, so I gave up on it.

    Works fine, installed through terminal (believe it was fedora repo), and was able to get dark mode. I'll stick with this, since it feels more customizable and light than sublime text 3. I uninstalled Text Editor after installing this, thinking that I hopefully won't need to use this.

    Out of all these applications that I REALLY needed to work, it was Zoom for college. And this had to just not work I guess. I installed it from flatpak through Software Center, and when I attempt to open it, I get a transparent box, and nothing else.

    I can't install it from the terminal, so I'm guessing there isn't any hope from those repos either. I had gotten a prompt on first-time startup that said something about turning on "EnableWaylandShare", which when I checked, was on. Afterwards, nothing else happened on recurrent launches.

  3. Why do I sometimes very occasionally get stutters?
  4. Initially, I followed this guide to get my NVIDIA drivers installed. It was relatively painless, and easy to do so. However, I noticed that Fedora sometimes gets stuck and hangs/becomes unresponsive. It happened when browsing steam, when watching YouTube on Firefox, using VLC (though this might be a VLC issue), and even when I was writing this post. I just wanted to ask if this is normal behavior.

  5. How do you setup QEMU/KVM virtual machines?
  6. After seeing a video on why dual booting isn't better than vms,, I decided to go all in on Fedora. However, I know that I do in fact need Windows to do things like gaming, (specifically 3rd party modding), so I want to set up qemu to utilize the GPU pass through. However, I can't find a solid guide on how to do this, and I'm confused with what exactly is KVM, and what is QEMU, or if there is any difference.

  7. Why does my hard drives keep unmounting?
  8. Every time I log out or shutdown my computer and come back, I get a popup stating that my folders from other drives cannot be displayed, and when I check it's unmounted. Is there a way to make it so that they are always mounted?

Any help is greatly appreciated, and hopefully after this post my experience can go better, as I think I've learned a lot already, and am still excited, (albeit a little frustrated) to use Linux.

Yeah, it is a matter of different way of packaging things, where files should end up on the disk, some pre and post-install actions etc. Formats such as snap and flatpak and appimage even try to standardize that across the distributions. In that sense, if you install flatpak on Ubuntu or Fedora, you are using same command and get the same application.

Once you get used to the new workflow, I am confident you’ll be like “how did I even accept installing random things I downloaded from the internet” and “wow, I don’t need to update each app separately, and they don’t need to have separate update mechanism” :slight_smile:

I see you are really passionate and learn things quickly, keep going :muscle: Pain is the part of learning, and I guess you were very proficient with Windows, so you might have certain expectations about how things should work. Don’t let that discourage you when you stumble upon something new or find some issues which are misaligned with your expectations.

Technically, packages are different, they’re put together in a different way. Adding more to that is the fact that:

  • Discord is technically proprietary application tied to the server component provided by the third party.
  • RPM Fusion is the third-party repository for Fedora - it may not have same standards as the official repository and accepts packages that due to license perhaps could not be included in the main repository.

What I usually try to do when I install apps from RPM, I launch them from the terminal and then look at the errors that might come up. Those usually point into right direction when something is not working properly.

Well, this could be due to many reasons. First thing is that flatpak is sandbox for the application. So you might need to grant some additional permissions - I recommend flatseal as it has nice and simple GUI for managing permissions.

The other reason might be if you are in Wayland session (when logging in you can select session on the right bottom corner.

Some basic info about wayland server can be found here. Basically it is a new display server which is more secure. It is an broad topic, and confusing at times, especially for newcomers, but if you’re really interested into going a bit deeper, you can look at the architecture page of the Wayland project.

That is quite weird. Not really sure why this would happen. I have Nvidia 1060 and no matter if I use free/opensource drivers like Nouveau or use proprietary Nvidia drivers (provided by rpmfusion) VLC works perfectly for me. So not sure what that is about, but perhaps switching drivers or session in X11 might do the trick for you. Try to experiment a bit and see if it helps. My experience is that Nouveau drivers generally work more reliably, but are far less performant. So if I want to play games, I just need to have proprietary ones.

I will be that classic guy when something doesn’t work, he suggests something completely different :smiley: VSCode works fine, so if you’re using that now on windows, it is really nice on Linux too.

Up until recently, those two were basically the same thing. :smiley: Is there something you’re missing on Text Editor vs Gedit?

I know your pain mate. Zoom is such a horrendous application. It doesn’t work properly for me on other platforms (Mac or Windows) as well… Crashing, always some issues with it. More so on Linux…

But… It does work though. I download it directly from the Zoom webpage and install from terminal:

sudo dnf install ~/Downloads/zoom_x86_64.rpm

This might also be X11 vs Wayland thing. Try switching session and see what happens.

QEMU is an emulator which emulates all sorts of devices, while KVM is the kernel module which provides virtualization capabilities. They go hand in hand. VM can function without KVM just through QEMU, but it will be slow, as everything is emulated in software. With KVM, many things go straight into kernel so there’s less overhead. This explanation is semi-correct though, as you learn more about the whole thing, it will become clearer.

Official guide works just fine for me. virt-manager is a nice tool for administering VMs. If you have simple needs though, you might want to look at Gnome Boxes. It is simple, and does the job. Performance can be tweaked from virt-manager later on (changing settings of the VM and whatnot)

I am assuming that you have other hard drive which you manually mount by clicking in Files on it. Windows has a bit different concept than Linux regarding how drives are displayed to you. In Windows for example, everything is treated like separate drive, and you’re expected to know where your files are. Windows does have similar thing to how things are setup on Linux, and that’s those default “Pictures”, “Documents”, “Downloads” etc. locations.

By now I guess you are aware what mounting a drive is. There are basically different ways to do this. When you click in Files on disk, it gets automatically mounted on some /run location, and that is true for the duration of the system being up.

Main drives and partitions are mounted by the means of /etc/fstab entries. To read more in-depth about those look at An introduction to the Linux /etc/fstab file.

Beware that if something is added there, it gets mounted at the boot process. If it cannot be mounted, system will hang at bootup, and then you have the pain of using live usb or something to fix it :slight_smile:

There’s also a way to achieve this directly via systemd

  • systemd.mount - docs
  • systemd.automount - docs

There are always few ways to achieve one thing, and neither one is wrong, each has its own place and you’ll figure out what exactly you prefer and what is better for you with time and experimenting and breaking things.

Welcome to the wonderful world of Linux, plenty to explore, learn and much fun to be had. Good luck with your endeavors :slight_smile:

Thank you so much for responding! I really appreciate you going line by line answering most of the questions I had. The clarification on the package files/packages/everything else I mentioned are greatly appreciated as well.

The biggest takeaway I got from this is to just switch over to Xorg/X11. After doing this:

  • My screen share issue in discord was fixed. I'll still probably check out flatseal though.
  • Zoom magically just started working! There's no issues there as far as I can tell.
  • I'm getting no stutters in VLC, almost like everything was solved. I think I can now safely uninstall Gnome Videos in response, which also had it's subtitle location fixed.
  • MPV does work perfectly fine now. I've learned that I don't like MPV more than VLC.
  • Kate doesn't crash when I click on the settings either, but I think I'll just stick to text editor.

I didn't realize that gedit and text editor used to be the same, maybe I just happened to look at the customization in gedit, and not in text editor. Comparing the two, it seems that text editor is the way forward, so I went back to it in the end. However I hope I can find a better command cause summoning it in terminal is wordy, though I'll probably just use nano if I do use the terminal.

  • ex. gedit thing.txt vs gnome-text-editor thing.txt.

I still am having some issues though. I tried installing Flameshot from both flatpak and the main Fedora repo, as an alternative to snip and sketch, but it refuses to start. Hopefully I can find out whats happening there. On top of that, stutters and hangs are still common. I've just accepted these as things to expect with Linux.

Thanks for the recommendation of Gnome Boxes, but looking into it, it seems GPU passthrough isn't really supported, which I need for gaming.

I followed the guide to set up QEMU/KVM for a bit, got stuck until I realized that SVM was set as disabled on my BIOS. After that it was smooth sailing until I got to actually run it, and have been stuck for hours on an error saying that the Boot failed: not a bootable disk. I'll have to make a new post about that.

The guide on mounting hard drives took a bit to understand, as Windows handles drives differently, but I got there in the end. I didn't realize that a directory was a folder, so I didn't know I had to look in the /mnt directory to see the drives again. Thank you for the helpful guide, and for everything else!

1 Like

Glad things are now working better for you :muscle:

On X11 vs Wayland thing, I prefer wayland, it is newer, better, faster at least in my case etc. And it is going to be default in more and more distributions.

It can have various issues though, but not through its own fault, but the fact that not all apps are properly updated to work with it. Although, more and more things will be.

I remember first time Wayland became available in Gnome and Fedora. Oh maaaan, was it a mess… It came really long way, and I dare to say that most things just work. And those that don’t are usually the fault of those apps. Zoom being great offender here in working nicely :smiley: But that :poop: program crashes on my regardless. Latest update just broke few things for me. They’re not giving much attention to the Linux community unfortunately.

I tried installing it from the Flatpak and observed that when starting it, process is indeed running, but I had no visual indicators of any sort that it was in fact running or how to use it.

[ivan@tomica-main ~]$ ps auxw | grep flameshot
ivan     1961913  0.3  0.0   3632  1112 ?        S    06:22   0:00 bwrap --args 41 /app/bin/flameshot
ivan     1961926  0.6  0.0   3736  1348 ?        S    06:22   0:00 bwrap --args 41 /app/bin/flameshot
ivan     1961930  1.7  0.0 636752 55200 ?        Sl   06:22   0:00 /app/bin/flameshot
ivan     1962007  0.0  0.0 222164  2200 pts/1    S+   06:22   0:00 grep --color=auto flameshot

When I wanted to use it via terminal though, I could do so:

[ivan@tomica-main ~]$ flatpak run org.flameshot.Flameshot --help
Usage: flameshot [flameshot-options] [arguments]

Per default runs Flameshot in the background and adds a tray icon for configuration.

  -h, --help     Displays this help
  -v, --version  Displays version information

  gui            Start a manual capture in GUI mode.
  screen         Capture a single screen.
  full           Capture the entire desktop.
  launcher       Open the capture launcher.
  config         Configure flameshot.

[ivan@tomica-main ~]$ flatpak run org.flameshot.Flameshot config
Qt: Session management error: None of the authentication protocols specified are supported
[ivan@tomica-main ~]$ flatpak run org.flameshot.Flameshot gui
Qt: Session management error: None of the authentication protocols specified are supported
flameshot: error: Unable to capture screen
flameshot: error: Unable to capture screen
flameshot: info: Screenshot aborted.

Configuration and screenshot GUI also popped up when invoked. So not really sure to be honest how it should be used. I prefer using built-in utility though, so haven’t went too deep into it.

I wouldn’t really do so. I have pretty similar specs as you do (Ryzen 1700X + Nvidia 1060) and it is working flawlessly. No stutters or performance issues at all. I have been using open source nouveau drivers though, and haven’t even tried proprietary ones for like a year or so, mainly as I don’t play games on the PC. :person_shrugging:

In any case, stutters are not something you should expect or consider normal on Linux. There’s always some background issue and the question is how hard you want to dig to find out what it is and if you can affect it for the better.

Not by default. But any VM created, should be editable by virt-manager. Though, silly of me to recommend it perhaps as you’ll likely be using virt-manager mostly for configuring whole thing.