New installation freeze instantly after login Fedora 30

Hello, I was trying to give Fedora a whirl but can’t get it to boot. I have a Legion Y530 with Nvidia Optimus. I’ve tried disabling Nouveau before booting using rd.driver.blacklist=nouveau. I also tried logging in via Xorg and It just hangs with a cursor. I was able to boot in my first time but it froze shortly after. From what I’ve been reading Wayland and Nvidia don’t play nice. If anyone has any workarounds I’d be grateful, even if I can bypass the Nvidia card altogether and just use the intel graphics I’d be happy with that. I don’t plan on doing any gaming in Linux anyways, well at least for now.

Thanks for your time,


Welcome to Ask Fedora! Check out #start-here to learn your way around the community.

Your kernel command line option isn’t quite right:

  • In most cases, nomodeset is enough to resolve NVIDIA boot issues.
  • In your case, if you want to blacklist nouveau and rely solely on Intel, you should also pass modprobe.blacklist=nouveau. rd.driver.blacklist=nouveau will prevent it from being loaded by the initramfs during boot, but it can still be loaded post-boot. (Personally if you don’t need the NVIDIA card at all under Linux, I would recommend this route, since as you’ve already observed, it sidesteps many NVIDIA issues.)

All this being said, the proprietary NVIDIA drivers should now have official support for Optimus systems (this was just added in the last few months). If you want to try them, then: