NetworkManager Hotspot not activating

Hi everyone!

The other day I wanted to activate a WiFi hotspot via GNOME Wifi-Settings (as I already have done countless times) and as expected, the screen shows the hotspot coming up but when I tried to connect to it there was just … nothing. No WiFi visible. Neither for my Android phone nor for an ESP32 microcontroller.
iwconfig gives

wlp5s0    IEEE 802.11  Mode:Master  Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on

After reading the two or three first pages of google search on that topic and trying various “fixes” without success, I tried hostapd and successfully created a visible network BUT I couldn’t get dnsmasq to actually giving out an IP address.

I also tried F30 on a live-stick with the same result.

So in summary: Everything seems to be working fine but still there is not hotspot and I have no idea where to look for logs/errors or any hint of that sort to find the issue :man_shrugging: Where do I have to look?

Im using Fedora 29 with Kernel 5.0.16-200.fc29.x86_64 on a ThinkPad E580