Nemo crashes after update

Hello. I have a problem with the Nemo file manager in cinnamon.
After I updated my Fedora 33, nemo crashes immediately, when opened.

I tried running it from the terminal and it shows this error before the crash:
(nemo:134302): GLib-GIO-ERROR **: 06:48:04.137: Settings schema ‘’ does not contain a key named ‘selection-menu-favorite’

I tried reinstalling, but that didn’t help.
What can I do with that?
Thank you for your time.
I will provide any additional info needed.

1 Like

Check your package version:

rpm -q nemo

Test this update:

1 Like

I tried the update.
rpm -q nemo
The crash persists.

1 Like

Try to downgrade the package and check if the issue persists from another user.

1 Like

Hello Aurora, welcome to Fedora community! Upgrade all extensions and add-ons - their update process is separate from the rest of system.

There’s an update indicator for Cinnamon extensions, add it to a panel (right click on panel → Applets → Download → Spices Update) and you won’t miss another important upgrade:

1 Like

Updated the spices and tried another user. Sadly, still the same crash.
But thank you for the info, ozeszty. (Fellow Polish? :slight_smile:)

Was that a new user?
Does it crash if you try to open a newly created folder from desktop?
Do you have any reports in gnome-abrt?

Yes :smiley:

1 Like

Yes. It registered those crashes. What do I do with that?

Also, isn’t there a way to manually add the key it looks for and be done with it? Windows registry editor can do that. Why can’t dconf-editor?

Oh, I forgot! Not a new user, but one that never used cinnamon or nemo.
And desktop icons use nemo, so they are just gone.

Using gnome-abrt you can report issues to (login to bugzilla with FAS account or create a new one manually). Many useful details will be reported automatically by abrt and if similar problem has already been reported, you’ll be added to it.

Windows registry is a complete mess, while dconf is well structured. Besides, adding that key would probably lead to some other issue popping up. It has to be fixed by application/extension developer - bug report is necessary.

Try with a fresh user, but I’m afraid it might be related to different desktop environments being installed. I’ve successfully upgraded a couple of Cinnamon spins since ~F26.

Have you tried dnf downgrade nemo* like Vladislav suggested?

1 Like

I had no idea how to downgrade. I did that now. The previous version works. Guess I will stick to it.

Now, what’s a FAS account? Fedora Accounts System let’s you login to many Fedora systems, this site and bugzilla included.

dnf versionlock add nemo* will prevent nemo from upgrading, just don’t forget about reporting the bug, so that you didn’t have to use old version forever. More about dnf versionlock:

1 Like

Well, I went to report it.
I got this log --- Running report_uReport ---(„report_uReport” ukończono pomyślnie)--- Ru -
And it says the report was sent but wasn’t opened, because there’s not enough information.

I’m not sure why it failed (missing debuginfo files or not enough data in general). Try again later, if it fails, report it manually with info from Details window (reason, crash function, cmdline, executable, package, component, core_backtrace) and a summary of what we determined here. Log in to Red Hat Bugzilla
Here’s a list of reported nemo issues

1 Like

Hey, I reported the problem to bugzilla then. Nothing happened to it for a long while and then it disappeared… I updated again since then and it’s still the same issue. Seems like I’m stuck with the older version.

Your bug report disappeared from Bug List? You should have gotten some email notification…

Are you already on F34? F33 seems stuck on 4.x branch without updates since march and is about to reach EOL.
F34 has newer nemo and nemo-fileroller (5.x) that, according to undermentioned bug report (GLib-GIO-ERROR - 'org.nemo.preferences' does not contain a key named 'context-menus-show-all-actions' · Issue #2241 · linuxmint/nemo · GitHub), should have the fix.
dnf -C list installed nemo* will show installed versions, to be sure that versionlock hasn’t blocked the update.

In Fedora 34 it says
(nemo:26789): GLib-GIO-ERROR **: 18:48:18.438: Settings schema 'org.nemo.preferences' does not contain a key named 'sort-favorites-first'
Only the key name changed…

Weird, it’s been added with this commit in march
Try reinstalling all nemo related packages, if it doesn’t help, report another bug (if no one responded to last bug in bugzilla, you can try use
dnf reinstall nemo*