Need help with AMDGPU PRO driver 22.10.2/3

I need HIP in order to use GPU render in Blender. I’ve been fighting with AMD’s laughably bad RHEL and CentOS 8 repos. I can’t even get a single package installed. I get this error:

AMDGPU 22.10 Proprietary repository                                                                                           5.6 kB/s | 2.9 kB     00:00    
 Problem: package rocm-hip-runtime- requires hip-runtime-amd, but none of the providers can be installed
  - package hip-runtime-amd-5.1.20532.50103-66.el8.x86_64 requires rocm-llvm, but none of the providers can be installed
  - conflicting requests
  - nothing provides /usr/libexec/platform-python needed by rocm-llvm-
(try to add '--skip-broken' to skip uninstallable packages)

All the packages it complains about exist in the repos I have configured. I can DNF search it and there are newer versions available and so on. I’ve tried 22.10.2, 22.10.3, “latest”. Actually, “latest” doesn’t even have the latest packages, those are in 22.10.3. Also, the ROCM repo has an “rpm” folder, but it has outdated packages compared to the repos that have names… versions? Like, Index of /rocm/centos8/5.1.3/. It seems like either packages are too old, or too new, or some random file isn’t supplied by the repos. AMD’s pro drivers for Linux are a joke and they make me regret buying an AMD card every time I need to do professional 3D rendering.

I have an AMD Radeon RX 5700XT. Please help!! :joy:

1 Like

You may have seen this other thread:

Sounds like, if you need HIP, your choices are:

  1. Install RHEL8
  2. Wait for the rhel9 directory here ( to be populated and cross your fingers that the rhel9 packages work on fedora 36.

Also, you can let AMD know that you are interested in Fedora support for the AMD hardware you purchased. If they know there is demand, they might change their stance, especially since nvidia has recently taken a more open-source-friendly stance.

I hear you!

Short answer: I think we understand the issue, and I don’t know what to do about it. I agree those are the main options.

Long answer:

I don’t need HIP, and I’m not quite up-to-speed on the shift to HIP. But, I experienced the same problems when I tried to install it. I curse AMD a lot every time I have to go through it, too.

On the other hand, this decision to ignore Fedora is very old, and I don’t see any way to convince them to change. They’ll make Fedora change before they do, and I don’t see that as likely. This is still better Linux support than nVidia, if you are down with OSS. And, I’ll never buy their stuff, so, I’ll never be able to compare the experience.

If I could speculate, I think the problem is more that Fedora is ahead of other distributions, than AMD doesn’t want to support it. RHEL8 is ancient in Internet time, but they can afford to support it because it’s very stable. Fedora get new kernels fast; I like it. I use Ubuntu (not TLS, even) for about 2 years, but they were behind on lots of stuff. I think that stability is what attracts the support they have. And that’s why the issue with platform-python, which was deprecated years ago upstream; not Fedora’s fault. That’s what I’ve learned fighting with this for over 10 years.

Fedora is never going to be like Windows, where they support every version for 8 years or whatever. Now, maybe they should make an LTS spin, but that would be a big change. Or, maybe LSB will get finished, magically, and that will solve everything. :wink:

AMD announced more than 10 years ago they were going to be the leader in Linux support. I think they can claim to have made good on that promise, but Fedora has been excluded from some the benefits. If I knew who to complain to, or thought it would matter, I would. In fact, I have tried to take it up with AMD directly in the long past, during the early Catalyst days. If you have a new idea how to do that, I’d like to hear about it.

I tried following that guide. I also tried a bunch of my own mods. Couldn’t hack it. I somehow got the installer to work a couple months ago, but HIP didn’t work at all. Now it’s just busted.

I’m worried about AMD and Fedora. If you check the release notes on their proprietary drivers, you will see that RHEL support is reaching EOL and won’t be supported in the future. So either they will support Fedora instead, or we’re up shit’s creek.

AMD is a company, and development costs money. I think this is especially true when we’re talking about the work they’d need to put in to support a rolling distro like us or Arch. Plus, there’s diminishing returns as the majority of PC users are still on Windows. I think to convince them, we’d need to either have a majority market share of Linux users, and somehow prove how that’d be profitable for them. I’m not sure how. Perhaps Fedora and it’s community could offer up some development help and work with AMD to keep the drivers up-to-date and stable. Or… AMD could just open source it smh

AMD’s HIP tech supports Nvidia apparently, so I don’t know what they’d have to lose competition-wise by open sourcing it. If anything, contributions would enhance it more…

1 Like

I worry too. But, I don’t find any evidence that AMD isn’t supporting RHEL9. If Phoronix isn’t reporting it, then I doubt that. In fact, they have a recent article that talks about AMD support for RHEL 9.

Now, that doesn’t mention HIP, so, it’s still confusing why there isn’t anything in the RHEL9 repos for HIP yet. I agree, that is concerning. Maybe someone should ask Phoronix or the forums there.

Also, May 22 was the last Linux driver update, so they could be working on it. I mean, the AMD driver download page has RHEL9 listed on the supported systems. That page gives you amd-installer, which tries to install HIP. Since it doesn’t work on my system, I don’t know what it will do on RHEL9. Maybe someone can try that in a VM? Or we have to tear into the script and try to find out.

My bad. I misremembered, it was CentOS that they’re dropping support for. See CentOS Support Note section.

Ah, right, I remember that now, too. Should have put it together, sorry.

I gather we’ll know more soon. The next release of ROCm is supposed to be released soon and support RHEL9. But, I couldn’t find a commitment of that.

Also, I read in the docs that “non-LTS” OSes are officially NOT supported. That would be any Linux desktop, in my opinion. If you switch to Ubuntu, say, are you going to install LTS just to get AMD support? I mean, it’s an option, but not one I would consider for very long. So, again, I think it all comes down to stability of the distribution, not particular choices that depart from LSB or where lib64 lives and stuff like that.

What a shame. I am NOT going back to Ubuntu! :joy: It’s got its merit, but I’ve had my fill of outdated and buggy software. I suppose I’ll either find a fix to make it work on Fedora, or just deal with it until I get an Intel Arc or Nvidia GPU.