Need Help - Password to acess Partitions

I’ve downloaded Fedora on my main computer but when I’ve managed the partitions, creating the partition for Games and other for Files on the partition manager, I had the problem of needing to put a password everytime I am to acess something inside the partition.
When I’ve created the partition I have selected the option all users (Not the root only) but it looks like the partition needs the root password to acess. It sooo anoying and I am having zero results of trying to fix it.
Someone can help me on this? I am new on Linux and because of it I don’t know many of the terminal commands.
The option I select on Partition Manager:


How it appears on Dolphin:
Captura de imagem_20240605_065926-1
I want to make it acessible all the time, like the Fedora partition on the image. Anyone can help me on this?

I’ve tried to solve this in the partition manager. Then I’ve rebooted soon after because the partition manager was crashing. Now the computer don’t start anymore:


Is it really possible to use Fedora at all? I am almost giving up.

I suspect you broke fedora when you used partition manager, which is not the tool to fix the issue you had.

You may need to reinstall. Then we can help you setup fedora as you require.

I’ve reinstalled it. The Fedora boot wasn’t working so I had to download a Distro based on Fedora to remove this weird bug. I believe it wont change the commands because Nobara is really similar to Fedora.
Now that I got everything running again, could you help me create those separate partitions? I would be really thankful for any help.

What is the output of ’lsblk -f`?

Just so I know the requirements:

You want a partition for games.
Why not use a folder under /home?

You should be able to edit mount points in KDE Partition Manager. Doing that would create entries in /etc/fstab. We don’t know what you did before with the Partition Manager, but it could have been interesting to see what entries was actually added to /etc/fstab before the OS was re-installed.

As a side note off topic: I wish someone could fix sulogin, so emergency mode would actually work without a root password and still not compromise security.

when I put lsblk -f on terminal is appears this:

NAME        FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
zram0                                                                              [SWAP]
nvme0n1                                                                            
├─nvme0n1p1 vfat   FAT32       6A3B-A0EB                             581,5M     3% /boot/efi
├─nvme0n1p2 ext4   1.0         8a69391f-4324-42eb-a73e-f2a848fe25e1  535,4M    38% /boot
├─nvme0n1p3 btrfs              a4022646-94f1-424e-a2fc-06b038f71010  901,9G     2% /home
│                                                                                  /
└─nvme0n1p4 swap   1     swap  5cfdb1ea-c0b3-4fc1-80da-4ddb61f3c7d0                [SWAP]

About using Home for it, I wanted something more divided and organized but because of all the bugs that happens when using the partition manager I believe it will be the only answer.

I fixed your post to use preformatted text to make the lsblk output easier to read.

I think you have allocated all your disk space to partitions already.
But you are using btrfs so what you will want to do is create a btrfs sub volume for games and mount it at a suitable point in your exist file system.

But why do you think a partition is better the a folder to help organise your files? After all to mount the partition you need that folder to exist anyway.