Mystery of the unstable connection

my question here is how to troubleshoot an “unstable connection” which only occurs or is detectable during a VoIP call, a Zoom call, a Telegram Call.

when I’m on the call, it randomly freezes the video and sound for 1-2 seconds at a time. zoom will give me a “unstable connection” popup in the center of the screen, but on other calls, I can also experience the 1-2 sec freeze as well. I have no idea if it is the hardware, the wi-fi or ethernet, or my router. it is only perceivable on voip calls like zoom, not on youtube videos at all.

any insights would be welcomed, thank you.

The first thing to check is the internet connection speed. The freezes you note are indicative of pauses waiting for the data to be buffered as it is downloaded. It may also be a memory or processor speed issue but I would first check the internet connection speed.

If you are in the US then it is very easy to connect to and check the upload & download speed. I am sure that other locales have similar tools to test your network speed.

It has always been recommended to me that for any form of streaming service you should have at least 20 Mbps connection speeds for exactly the reason you seem to be having issues with.

I don’t know what speed connection you are paying for, but checking it out should be first on your list.

1 Like

hey thanks for quick response. it’s 160+Mbps up and down, and 65ms ping.
this is after running this over wifi to a router with vpn installed.

where do you think i could test next?

I had this issue for a long time, it turned out that the receiver end (customer/friend) had the issue and not me. They got theirs speed fixed through a network upgrade and it no longer happens.

On occasion this was my computer causing the issue, I often would shutdown many other applications using internet access on the computer and this helped a lot. High memory usage also exacerbating the issue as @computersavvy mentioned. So I closed down running apps.

Ask the other person to check their signal strength too.

What also helped was switching my router to a different frequency, i.e if running 2.4Ghz try 5Ghz, as some channels get very busy.

interesting benny, while i’d like to believe it wasn’t me. it must be me.

i believe this, because no matter if i’m on a zoom call, a telegram call, or a dialpad (voip) call, i get these “stutters in data”.

i switched routers and will keep posted on if it appears again during a call. currently my setup is eero satellites into a ddwrt router. instead of connecting to eeros, i’m connecting via wifi to ddwrt router now. let’s see if it changes anything.


Please keep me posted as this is an important fault to troubleshoot.

These are a few of the possible parts in the network (but not all)

Usually its not the Bandwidth (internet speed) and actually more about the latency (time it takes to transmit the data packets), surprisingly you dont need a very high bandwidth to use apps running Voip like zoom/video conference.

To troubleshoot this first you should ping your router to an IP which is reasonably close to where your app is being run from.

if your ping is low this says latency is an issue. How is the laptop/desktop connected is it connected via cable or wireless. Judging by your latest ping test its not too bad at all

Try this Ping tester and let us know what the “jitter” is

If wireless connection, I highly recommend a cable as this helps a lot with dead zones.

If you still want to be wireless it could be these issues

1- Deadzones.

Possible Solution run a repeater or extender) - depends on how far away your laptop is from the router


As mentioned earlier, caused by a channel being too busy. Like in my kneck of the woods, 80% of people use the 2.4GHz band. So Try switching to a different channel

To check whether the band is too busy, use a wireless network checker for your area.

To do this I use android app called “Wifi Analyser”. It will tell you how congested is your band (either 2.4 or 5Ghz usually)

You can see here

1 Like

when you connect your PC with the router using an ethernet cable, do you experience the same?

Wifi can be jammed (one sender at a time!) if you have various clients talking to one Wifi AP at a time.

Remember, a cable is often the best Wifi connection.

I need to move my setup closer to the router in order to test this. However, I did eliminate one scenario. It does not appear to be the problem between the Eero satellite routers (managing dhcp) and the laptop, because I connected via Wifi to the DDRT router, and have experienced a VOIP call this morning with a 1-2 sec stutter.

I will try wired idea, and also the channel changing idea as well. I am more hopeful that ethernet will solve the issue, but I’d have to really rearrange the home office to get that in place.

Could it be the hardware processor stuttering to managing the VOIP data? IF so, would this occur in the logs in my fedora instance somewhere?

Try the aforementioned steps first, i.e a thorough assessment of latency feedback for your device.

Do you have another device like a tablet or smartphone to test voip with. This could isolate the device. Some routers can only handle a certain amount of connected devices.

Once you have tried a cable and if the issue persists we can do more troubleshooting.

No it’s wouldn’t be the CPU of the device,

I will work the rest of the day on ethernet and let you guys/gals know how it goes. Merci!

So, I’m back to report.

The cable seems not to have eliminated the stutter. So, in an hour phone call on Zoom there were 3 instances of a 3 second delay in sound.

So I would have to assume it either a hardware/software issue (Zoom/Dialpad/etc) OR the stutter is originating from the DDWRT Expressvpn Router that the laptop is directly connected to.

Do you all think the next test is to expose the laptop directly to the modem traffic and see if there is still a stutter? If yes, then it would be the laptop’s issue maybe. If no, then it is the ExpressVPN router’s issue, maybe?

I’ve attached a screenshot of the wired connection jitter/speed report. This laptop is connected to an ExpressVPN Linksys modem with an active VPN connection to a nearby state in the U.S.

Any internet connection is likely to pass through multiple service providers in the path between you and the other end.

What you show above is more than 8 times faster data than I have on my connection, yet I seldom get any lag/stutter with zoom.

I think it likely that the unstable connection you see is not directly at your end, but may be at the other end, or anywhere in between since there could be millions of persons sharing a single pipeline at some point in the path between the endpoints. Even your VPN connection is not a single dedicated connection but is across shared links from you to the other end.

1 Like

Fair observation! How is it I don’t get any 3-second stutters when on meetings on my Mac, but since switching to Fedora, it’s been a consistent experience of stutters since?

Again, my gut tells me the software is trying to do something and is lagging on the Thinkpad X1 Carbon Gen 9. Anyway to check logs on the system while this is happening?

During the call and if the problem comes, would you like to check with systemctl --status pipewire and systemctl --status wireplumber?

I can try this. What is the equivalent of this command in fedora? “–status” seems not to work.

My bad should be systemctl --user status pipewire and systemctl --user status wireplumber.

1 Like

You can rule out latency and bandwidth it’s safe to say with those results. But do you experience any drop outs. You should try to run it a call without a vpn to see if this effects the quality. Does your router support QoS? This allows you to prioritise certain types of traffic, like zoom.

Is the issue only with zoom? Have you tried other video conference software?