MySQL Issue

:wave: Hello, everyone. I’ve installed MySQL, but it’s working on the terminal only. I’ve tried many MySQL GUI Clients (MySQL workbench , Beekeeper , DataGrip ) , but none of them are working

What is the problem?


Those images show that mysql is running.
Please post using text that you copy and paste from your screen using the preformatted text tags available with the </> buttton on the toolbar.

Images are much larger, sometimes difficult to read, cannot be searched, and cannot be directly quoted. Later users cannot find any information you may have provided in the image.

With that said, what is the real problem?

You appear to not have set up any user other than root (default) and the clients you mention probably will not work as the root user. Try following the config instructions and set up another user in mysql to use with the gui clients.

Thanks, Jeff, The problem was solved by commenting

–skip-grant-tables

in MySQL Configuration → /etc/my.cnf

and It’s working now with all GUI clients and all VS code MySQL Extensions.