My New User Experience :(

I wanted to share my new user experience, in the hopes that it will be improved in the future. The website first suggested filing bugs, but I’m not sure that’s the best place for this.

First off, I noticed the live media picked my middle monitor to display everything on. My middle monitor is neither my primary monitor (according to settings), or the first monitor on the system.

I tried to drag the installer on to my primary monitor, but it made the window much smaller and more difficult to use. I didn’t see an obvious way to make the window bigger again.

After I started the installation it immediately said it was 100% done installing software, which I find hard to believe.

After the installation completed, I rebooted my system and checked the boot devices. I now have “Fedora, Ubuntu, Fedora, …” even though there’s only 1 Fedora and no Ubuntu any more. I told the installer to reformat /boot/efi, which I thought would take care of the extra boot entries, but apparently not.

After booting in to the new installation and setting up a user, the mouse cursor was not drawn on the applications, which made the desktop nearly impossible to use. So, I installed KDE from terminal. After another reboot, I tried GNOME again, and this time I do have a cursor over other apps, but I’m being spammed with SELinux problems.

On the plus side, it actually installed on the first try, which is better than last time, and better than some other distros. So better is certainly good, and I hope it continues to get “betterer”. :slight_smile:


Helo! I don’t know why that happens, usually when I install a different distribution, I clean the hd and the gpt format.
I imagine that if I were more specific, I would receive some guidance.
Fedora appears twice in the boot menu, as does opensuse.
The Fedora community is very welcoming, from what I have seen so far … But if you want a very welcoming community, I would advise opensuse, there some moderator, or administrator, would have already answered you, understanding your frustration and asking to be more specific, to you can get help.


If your hope was to provide feedback on the distribution in the hopes it would lead to changes, this forum is probably not an effective place for that. The project isn’t really led around the forum.

Those are entries aren’t on your disk, they are stored in NVRAM. I have never seen an installer for any distro which cleans them up. You need to manually manage them with efibootmgr


Thanks for the info. Where do you think a better place to share this would be, so that it can be used constructively?

Thanks for the tip of using efibootmgr, I’ll look in to that!

Hey, thanks for your comment! Yeah, asking for help wasn’t my primary reason for posting this, but I appreciate the other comment about efibootmgr, maybe that will help you too?

Thanks for your opensuse recommendation, I made a note of that. I really like what you say about the community. I keep coming back to fedora because it’s based on red hat, and most of my linux experience is with red hat.

But if I feel the need to change distros again, I will certainly try out opensuse. :slight_smile:

certainly sad to hear this.

To me, the main thing on every desktop is that the “no seams” KDE plasma-style works nicely, and on Fedo34 it does. So while the FAS (fedo account syst.) gave me some “bad attitude” (silently dropping certain mail domains, reuse of old account e-mail gives wrong instruction etc.) , Fedo34 KDE is quite to like. More on Fedo in this fireside chat:

I do appreciate gnome40 technology as well, just there needs to be the “no seams” Plasma-style.

Thanks for your empathy! I’m also sorry to hear about your troubles with FAS. That kind of bad attitude (silently erroring) is completely unacceptable to me, and I really dislike that it’s happening more and more in software these days.

I find it interesting that you speak highly of KDE. It is beautiful, and promises a lot of great features, but in my experience it doesn’t work very well. I think I have about half a dozen bugs open on KDE right now.

I’d love to find a desktop environment that offers the beauty and features of KDE, but is also more reliable/stable, or at least notifies me when it has an error.

1 Like

do you know the place where we could report bugs?

1 Like

Fedora is a downstream Linux distribution (almost all distributions are “downstream”), which means we don’t develop the software. We take it from upstream developers and provide it all in an integrated OS. So, you can either file bugs at Fedora, where Fedora community volunteer package maintainers will take a look and see what can be done—they may file bugs upstream to inform the developers. Or, you can even file bugs directly upstream.

Here’s a document on filing bugs:


We’ve recently moved to a completely new account system (the old one was a decade or more old and could not be maintained easily), so we’re still seeing some issues. Have you filed an issue about the troubles you have been experiencing somewhere yet?

It’ll be best to split that out in a new topic.

1 Like

What settings are we referring to here please? Settings on your local installation do not apply to the live media installer, since it runs “off the disk”.

Can you tell us what installer you were using please? If this was the workstation, I’d think the gnome-shortcuts should maximise the window etc. So “Super + up” should maximise, or dragging the title bar to the top panel?

That’s perfectly fine. When you install from a live image, it copies the expanded file system to your local drive which can be quite quick, especially if you are using an SSD.

This is an odd one. If you did format all your partitions, it should not have any information to detect other OSes. We can look into this and clear out the bootloader options if you wish.

Is your system now up to date? If you are still seeing SELinux issues, can you please tell us specific messages so we can see what’s causing them.

It is not uncommon to see SELinux issues after a fresh installation but these should go away after an update. The way the release pipeline works is that the installer is “frozen” weeks before the actual release so that the frozen set of packages can be tested. Then, on the day of the release the “freeze” is complete and all the pending updates are pushed out. That’s why one gets a relatively large “0 day update” on release day.

1 Like

Thanks so much for all the info here! This is great! :slight_smile:

Monitor order has been a long time issue for me on Linux. On SDDM (login screen), the order is all wrong, and the primary is the middle monitor. AFAIK, there’s no way to fix this through the GUI, so I’ll have to look up how to edit the config files properly again. At least GNOME matched this, and didn’t output everything to the TV in my other room like some other desktop managers.

Settings is the application named “Settings” in GNOME.

Yes, Fedora Workstation installer. Thanks for the info about the shortcuts, but I didn’t know what they were at the time. Perhaps a maximize button would be a good idea on the installer. :slight_smile:

Yes, SSD are fast, but not that fast. It also shouldn’t have sat at “installing software: 100%” for a period of time. It was either not 100% installed, or doing something else. This one is fairly minor though!

Another commenter mentioned this is because the entries are in NVRAM as well as /boot/efi, which makes sense to me. I haven’t fixed it up yet, but I’ll look in to it.

Actually, things are not up to date yet. Which raises the question of how many times do I have to update before things are actually up to date? Anyway, I’ll keep updating, but in my past experience SELinux never shuts up. I’ll follow up if is still complaining about things.

Thanks again for the detailed reply.

1 Like

This is the default Gnome design. One can enable the maximise/minimise buttons on the top bar using gnome-tweak-tool, but that won’t be available on the installer. Did the “Gnome tour” run for you on the installer? It should give you an overview of the shortcuts etc. (but I haven’t used the installer in a while so this may have changed).

Ah, yes. I had noticed this too. I’m not sure what causes this, but I guess the progress being shown is progress from the copy process, which doesn’t include the actual write on disk progress (not sure if that’s obtainable). It’s like when you copy a large file to a pen drive. The app (nautilus or whatever you use) will show that it’s done but you will not be able to “safely remove” the drive because the actual write to disc operation has not completed. Take a look at this topic. It explains a similar issue when writing with the dd command:

I think one relatively large update after a fresh install should be sufficient. If you are still getting selinux errors, please open topics for them and we can look into them. You can also use setroubleshoot which will tell you what you can do to address these issues, or report them as bugs if necessary.

sudo dnf install setroubleshoot

1 Like