My fedora started breaking down, not booting, not waking up, crashing on login

I am happy to provide any information necessary apart from this.

I have noticed the problem today. I have been using fedora on my laptop for over a year now without any issues. Suddenly today when I suspended it is didn’t wake up. I was forced to kill it and restart but it didn’t go past decryption. After the 3rd time it worked but I was already alarmed.

Thorough the day I kept having some issues but usually a forced restart worked.
Unfortunately it started getting worst. It crashed on login in, sometimes it turns the scree black sometimes it just stays there. One time I just saw a cursor while booting but it didn’t move.

After several retries I usually managed to boot it and log in than it works just fine. The automatic bug detection didn’t detect anything. Fortunately (or not) I just managed to capture a crash window on boot and there seems to be some NULL pointer reference on a very small address which is something I encountered 1 week ago but that time the address was different and I didn’t have any issues so I ignored it.

Here are the pic of the error I managed to catch:
//I seem to be having issues posting the pictures so I will work on that while here are the key points
Starting initrd-switch-root.service - Switch Root…
BUG: kernel NULL pointer dereference address: 0000000000000052
#PE: error_code(0x0000)

  • not present page
    PGD 0 P4D 0
    Oops: 0000 [1#] PREEMPT SMP NOPTI
    CPU: 4PID: 1 CommL systeemd Not tainted 6.3.11-200.fc38.x86_64 #1
    node: systemd[1] exited with irqs disabled

I will try to upload more if I get to
Sorry if I have missed posting anything important. I’m still quite new so please just tell me if you need any further information. Thank you very much for any help :slight_smile:

So for now I decided that I fixed it to a point where it mostly works. It crashed on me while trying to login but restarting mostly works now. I have been reading about it a bit and I think it’s a kernel version issue. I will switch to older one for now and see if I get the same issues. For anyone trying to solve it I’m sorry but that’s the only solution I managed to find so far. I have exams coming and I don’t want to spend too much time on it. Since I didn’t do anything with the system myself kernel having some bug seems to be my best guess. I managed to find this System falls in to emergency mode due initrd-switch-root.service entered failed state - Red Hat Customer Portal
which is sth pretty similar but due to the fact it was 1 year ago it might be a different issue.
I wish you all best of luck and if anyone has any idea what caused the issue and how to debug I’m still happy to provide any logs. :slight_smile:

If the problem started immediately after updating your software then it could well be a bug, but if the problem wasn’t triggered by a software update it could be a hardware failure. In that case you should start with the current Memtest86+.

If you think the problem is related to software, it is probably triggered by the particular combination of hardware and software you have, so you should post (as text, using the </> button) the output from inxi -Fzx. Note that many such problems are fixed by recent updates, so if you have not updated both the vendor firmware (“BIOS”) and Fedora packages to current versions, you should do so. That way anyone with similar hardware can also have the same software.

Agree with needing to test your hardware. I think you have a hardware issue from the kernel output. Memory test as George suggested will be a first step.

If your laptop has memory that is plugged into sockets try removing the memory and reinstalling. I am assuming that may clean conttacts.

If laptop is designed to be opened up may be worthy checking for dust clogging any fans. And that fans work.

Thank you very much for all of your responses. I was afraid it might be memory but considering that’s it works most of the time now (after just backing up my documents etc.) I assumed it’s kernel problem. I will run Memtest86+ later in the day but hopefully if there is anything it will just require re-installation of RAM or sth.

Here is the output of inxi -Fzx :

  Kernel: 6.3.11-200.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.39-9.fc38 Desktop: GNOME v: 44.2 Distro: Fedora release 38 (Thirty
  Type: Laptop System: Acer product: Aspire A515-44 v: V1.11
    serial: <superuser required>
  Mobo: RO model: Calla_RN v: V1.11 serial: <superuser required>
    UEFI: INSYDE v: 1.11 date: 10/08/2020
  ID-1: BAT1 charge: 12.3 Wh (30.6%) condition: 40.2/53.0 Wh (75.9%)
    volts: 15.9 min: 15.4 model: PANASONIC AP19B5L status: charging
  Info: 6-core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64
    type: MCP arch: Zen 2 rev: 1 cache: L1: 384 KiB L2: 3 MiB L3: 8 MiB
  Speed (MHz): avg: 1416 high: 1505 min/max: 1400/2375 boost: enabled cores:
    1: 1397 2: 1398 3: 1397 4: 1400 5: 1505 6: 1400 bogomips: 28446
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu v: kernel
    arch: GCN-5 bus-ID: 05:00.0 temp: 42.0 C
  Device-2: Quanta HD User Facing driver: uvcvideo type: USB bus-ID: 3-4:2
  Display: wayland server: X.Org v: 22.1.9 with: Xwayland v: 22.1.9
    compositor: gnome-shell driver: dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon Graphics (renoir LLVM
    16.0.5 DRM 3.52 6.3.11-200.fc38.x86_64) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
    bus-ID: 05:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
    vendor: Acer Incorporated ALI driver: N/A bus-ID: 05:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus-ID: 05:00.6
  API: ALSA v: k6.3.11-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.73 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000
    bus-ID: 03:00.0
  IF: enp3s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Lite-On driver: ath10k_pci v: kernel bus-ID: 04:00.0 temp: 51.0 C
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Lite-On driver: btusb v: 0.8 type: USB bus-ID: 1-3:2
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 476.94 GiB used: 176.95 GiB (37.1%)
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM512GDJTNI-82A0A
    size: 476.94 GiB temp: 40.9 C
  ID-1: / size: 475.34 GiB used: 176.6 GiB (37.2%) fs: btrfs dev: /dev/dm-0
    mapped: luks-e01e9c18-7633-420f-ab40-b0734186e94f
  ID-2: /boot size: 973.4 MiB used: 336.6 MiB (34.6%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 475.34 GiB used: 176.6 GiB (37.2%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-e01e9c18-7633-420f-ab40-b0734186e94f
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 64.5 C mobo: N/A gpu: amdgpu temp: 44.0 C
  Fan Speeds (RPM): N/A
  Processes: 586 Uptime: 3m Memory: available: 14.98 GiB
  used: 4.92 GiB (32.8%) Init: systemd target: graphical (5) Compilers:
  gcc: 13.1.1 Packages: 27 note: see --rpm Shell: Bash v: 5.2.15 inxi: 3.3.27