My Fedora Crash after Kernel Update (6.3.6)

after 3 years using fedora finally I got stuck. I
I get used to with the problem after kernel upgrade. Since I use nvidia driver from NVIDIA which always failed during dkms process, so I have to reinstall nvidia driver manually.

Now, that way doesn’t work any more. it work for a while (in GUI Mode), after several try and error (Nvidia driver from NVIDIA keep removed). but after I install akmod-driver (I did 'dnf remove nvidia first and disable nvidia-driver) , it won’t go back to graphical mode !!.

I did dnf remove nvidia again (so I can go back to GUI mode like before) , now it go worse : beside can not go to GUI, and it also fail to go to the text mode !!. it just stuck !!

before that I used to be able to switch to text mode (after edit the grub during boot) and press alt+F1 pr F2 when it stuck. but now it keep stuck.

I attach 1 screen shot that show the grub (I used to replace the text ‘rhgb’ in linux line to ‘3’ to go to text mode) and 3 screen shot that shows stuck process during normal and text mode boot.

Appreciate for any help

Are you getting Nvidia drivers from rpmfusion-nofree or direct from Nvidia? Some older Nvidia GPU’s are on “life-support”. Looks like there is also an issue with your driver for an 8821cu wireless chip.

See: Wireless adapters with linux in kernel support

chipset - Realtek rtl8811cu - supported in-kernel since Linux kernel 6.2 (2023) (recommend kernel 6.4 oe later)

Warning: Do not buy adapters based on the rtl8821cu chipset. This is the version of the chipset that has bluetooth support turned on. I have seen countless problems reported by users of adapters that support bluetooth. I am listing the rtl8811cu for a reason, it is the version of the chipset that does not support bluetooth.

Warning: Numerous adapters with the rtl8811cu and rtl8821cu chipset are multi-state. You do not want a multi-state adapter.

Info: The adapters listed in this section are confirmed to be single-function (no bluetooth) and single-state (no onboard windows driver).

Note: While Linux kernel 6.2+ does contain an in-kernel driver for this chipset, performance in kernel 6.2 is not that good but should improve as time passes. Some users may decide to use the out-of kernel driver located here at this site for now as it is a good driver for an out-of-kernel driver:

Thanks George for the response.
last nvidia installed in my PC is got from rpmfusion-nonfree. but I already remove it. since after the installation, it won’t boot to GUI Mode.
Now, I can’t even get to text mode prompt. same thing when I try previous kernel, it just stuck and I have to hard reset just to reboot the machine.

now I’m preparing for the worst, boot from usb, get my working documents before wipe it all :frowning:

It is recommended to use the rpmfusion-nonfree-nvidia-driver repo (or the rpmfusion-nonfree repo) for the nvidia drivers so one does not have to perform the manual upgrade.

Before you do a full reinstall I suggest the following:

  1. Verify what is already installed.
    dnf list installed '*nvidia*'

  2. With that output one determines the next step.
    a. If you see the package nvidia-gpu-firmware listed in that but nothing else then the nvidia drivers may be installed from the rpmfusion-nonfree or rpmfusion-nonfree-nvidia-driver repos.
    dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda
    b. if the firmware package is not shown then add:
    dnf install nvidia-gpu-firmware to step “2.a.” before rebooting.
    c. if step 1 shows nvidia packages more than the firmware package noted in “2.a.” then remove all those packages before performing step “2.a.” & “2.b.”
    dnf remove <package names here>

  3. Verify that secure boot is not enabled with dmesg | grep secure or mokutil --sb-state. If it is enabled then it either must be disabled in bios or the modules must be signed before the drivers will load. (signing is another process – I assume secure boot is disabled here)

  4. If there were errors in performing step “2.a.” they must be resolved before continuing.

  5. If there were no errors to this point then after waiting about 5 minutes reboot. The drivers should properly load.

  6. Verify the drivers are loaded with lsmod | grep nvidia

It is possible that installing the drivers from rpmfusion may not properly configure the kernel options for your system. The gui may not work but one usually may log in at a text console with “ctrl-alt-F3”. If there are problems at this point let us know and that issue then can be addressed directly.

Thanks Jeff for the response.
as far as i remembered, I did the steps no. 1 but not 2a. Secure boot is already disabled. and I already wait for more than 5 mins before rebooting (but I didn’t verify it :frowning: as step no. 6)

I’ll repeat again once I can get to the system. Right now it just stuck during boot process. In progress creating Live USB to get to the system.

I suspect the 5-minute wait is too often neglected. It would be nice to have some more visible guidance to warn users that "now is not the time to reboot " with either “X in progress (may take N minutes)” or “N minutes to go”.

I agree.
However, akmods should pause the boot until the modules are fully built and installed. It seems intended to verify that all modules are properly built and available before the kernel loads them.

The timing on that may or may not happen correctly and the restart may or may not cause problems with a compile interrupted while actually running at shutdown then needing to restart during the startup.

Most of the problems I have noted seem to be related to users not waiting long enough after an update before rebooting, and it seems even worse with the automatic update during a restart.

Thanks Jeff, finally I’m able to install akmod-nvidia and cuda from repos (I use live USB then dnf install with root on the partition where my fedora installed).

but I forget to blacklist “nouveau” so after rebooted, the GUI come up but with nouveau.

after I put blacklist (both on modprobe.d/blaclist.conf and grub), I run dracut (is it necessary ?) to update initramfs. now sddm has a problem (but strange since gdm works).

any idea ?

add more screenshot that shows all nvidia required packages have been installed

YOu installed from rpmfusion using akmod-nvidia so the blacklist should have been done for you. cat /proc/cmdline should show this with
rd.driver.blacklist=nouveau modprobe.blacklist=nouveau

What is likely missing, and I had to add it for my RTX 3050 is this
nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init

if one were to edit /etc/default/grub and place the missing options into the line that begins with GRUB_CMDLINE_LINUX= then rebuild the grub.cfg file with grub2-mkconfig -o /boot/grub2/grub.cfg it puts those options into the grub boot menu for the next boot.

To test the effect before making it permanent one can ( from the grub menu during boot) press the e key to edit the command lines and insert those options into the line that begins with linux on that screen. This will only be effective for the current boot, while editing the file and rebuilding grub.cfg as noted above is permanent.

1 Like

Thanks Jeff !!

i think the problem with NVIDIA already solved (since I can run GUI Mode, nvidia-settings works, but only run on GDM).

anyway for new problem : SDDM : Failed to ready display number from pipe, I’ll create new in the different discussion.

again many thanks for your help !!