My computer freezes constantly without apparent reason

I have been experiencing this problem for a time now.
No necessarily restricted to Fedora 32 which is my current operating system on use.

The failure happens without notice and under no specific circumstance.
Use of no special program.
But, I have observed some possible constants.
Mouse displacement.
Use of some multimedia programs like YouTube, Rythmbox, Zoom.
When halting, sound enters in an infinite loop reproducing a fragment o audio.
When on other programs like LibreOffice or email the pointer simply stops.
Only solution is to hard reset.

1 Like

Are you seeing this on other OSes also? If yes, that indicates a hardware issue. If not, then we can try and narrow it down to Fedora related software.


The computer is run only under Fedora 32.
Or 31 and 30 for the matter.

1 Like

Maybe you’re using a nvidia driver?  (though for me, last time it was probably related to nVidia that was a 2016).

Dear @mackissack

It is possible that the driver is not working or there is a problem due to incomplete installation and compatibility of the distribution when upgrading the system.

I felt that part too, but if there is an incomplete part about the behavior already installed in each distribution, you can try again after performing a stability check in the existing stable state. If you need to do a fresh install, checking for new distribution compatibility, you may have to do a fresh install.

Please understand that there are difficulties in satisfying all hardware and software.

F31 tends to be more stable on my system, and other file servers have no problem with F32 behavior.
I just thought that.

1 Like

Well sure, this applies to all operating systems pretty much, but we can diagnose the issue to see exactly what it is, in the hope of finding a workaround/solution for @mackissack

So, @mackissack, let’s collect some information first:

  • this only happens on F32, not F31/F32, yes?
  • can you look at the journal to see if there’s any indication of what may be causing it? You should look for the boot where this occurred, and hopefully at the end of the log, there will some messages related to the hang:
1 Like

This seems more or less related to the display drivers. Do you by any chance use NVIDIA? If so, are you using the proprietary RUN file which can be found in their site?

I had a motherboard (2 of them actually) that are a-stable. They were MSI B450s. Replaced them with ASROCK B450Ms and problem went away – using same RAM, CPU, and video cards. Running SLED 12 SP3/SP4 and SLED 15. Random lockup and since we use Libre Office – we experienced the sudden stop responding problem the OP listed.

[Meanwhile, I am in the process of migrating to Fedora for other reasons.]

Sorry to intervene, but I have this same issue, both with F31 and now F32, on my wife’s workstation. Only a hard reset works. No Nvidia card involved. I suspect the AMD motherboard (I switched from Intel around a year ago). Issue seems to happen - according to my wife - always while using Evolution.

Everyone seeing this, please open different topics, since it isn’t necessary that you are all experiencing the same issue. In general, the first thing you should do is look at the logs to see if any messages are added to it when the system hangs:

If not, it could be related to the bfq disk scheduler. Please try to change the scheduler and see if the issue goes away:

Changing disc scheduler.

Posts in that thread also discuss how to make the change permanent.


I use AMD CPUs. My systems are generally stable. However, I have run into a specific MOBO that will NOT boot any Linux reliably. This is not an AMD CPU problem. It is a BIOS problem with UEFI support.

However, with the MSI board(s) I listed above, typically when using Office (Libre) my wife’s system would lock up. Mine started doing the same. So I switched as I listed (specifically to the ASRock B450M Steel Legend) and her system and mine are both stable now.

I did a lot of diagnostics trying to determine the problem. Diagnosing a hardware problem can be a real pain. The proof was the new boards with the same RAM sticks, CPUs, and Graphics cards and we did not have lockups (going on 6 months now). Had to be the MSI MOBOs.


1 Like

thank you for your support.
I finally solved the problem.

Found out the freezing mainly was due to memory.
Replaced it with new and sudden freeze stopped.

On the other hand, yes, there was a driver conflict.
Finally I cleaned wrong drivers.
Found the right ones for the PCIExpress GeForce 210 (GT218) GPU were properly installed.
Computer now runs seamlessly.


In the end I found out the 4 2 GB memory units were fine.

That’s an ancient GPU right there. This should suffice with the nouveau drivers basically so avoid any attempts of installing proprietary drivers and you should be fine. :slight_smile:

Yes, @t0xic0der.
I built that machine by 2008.
But let me tell you.
I don’t remember what was happening with the Noveau drivers.
But as soon as I handled to install the Nvidia ones, the GPU started operating seamlessly.
I am answering you from this computer and no more halting issues.

1 Like

Well, folks @FranciscoD, @t0xic0der, @wylbur, @simmon, @boricua, @vits95,
This topic became a multi-faceted issue which is demanding a lot of patience, study and intuition.
This is the thing.

Two machines, both with Athlon 64 X2 AMD processor and 8 GB DDR2 RAM
ASRock AM2-NFG6 VSTA mobo and 1.5 TB Barracuda Seagate SATAII HDD.
ASUS M2A-VM HDMI mobo and 2 TB Barracuda Seagate SATAII HDD.

ASRock presented some disk failure some years ago.
Two months ago I started revitalizing it.
So, I got a 1 TB 7200 rpm Barracuda Seagate disk, installed it and setup Fedora 32.
To my surprise, the new disk failed.
Claimed guarantee and got a replacement.

Meanwhile, ASUS was presenting the uncertain halts.
Thanks to your advises I was able to install NVIDIA drivers and solved the stallings.
So, then I gave it a try to the 1.5 TB disk and run a write-to-zero process and badblocks reported 0 errors.
Put it on ASRock.
I then installed Fedora 32 on it and was able to install the Nvidia drivers.
The computer worked fine…
until last Monday.

ASRock started a constant single beep.
Replaced 1.5 TB with new 1 TB disk.
And did all the setup process again.

To my surprise I was not able to finish properly.
Once Fedora 32 started I was not able to go install the NVIDIA drivers on newly setup ASRock.
HDD started a very slight click.

I am connected it to ASUS and am currently running badblocks.
At 80% is shows just 32 errors.

Meanwhile I tested ASRock PSU.
Yellow cables show a 11.3 V output.
A new Thermaltake PSU I have as backup shows 12.7 V output.

¿Can the PSU be causing the HDD’s errors?

I now will put the 1 TB disk to a low level write-to-zeroes format.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.