My audio is making horrible crackling sounds — what should I do?

My Fedora 29 system was working fine, but somewhere along the line I started getting distorted, crackling audio. Like, not just clicks or pops, but really bad. It seems like unplugging the speakers and re-plugging sometimes resets it, but not always, and only briefly. Plus, when I use the Test button in the sound control panel in GNOME, there’s a weird delay.

The hardware is Family 17h (Models 00h-0fh) HD Audio Controller (I think built-in to my AMD motherboard). I also tried the HDMI out and plugged headphones into my Dell monitor — so that’s using Vega 10 HDMI Audio [Radeon Vega 56/64]. Entirely different device and this rules out it being a problem with my 20 year old (yes, really) Cambridge Soundworks surround speakers.

I thought updating to the F30 beta might help, but it does not.

1 Like

I found a work-around, if not a solution. A upstream pulseaudio bug report describes the same issue and offers a workaround — adding a parameter tsched=0 to the pulseaudio config. To do this, I edited /etc/pulse/, and found the section

### Automatically load driver modules depending on the hardware available
load-module module-udev-detect
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect

We have udev support in Fedora, so it’s that first load-module line that needs editing. I changed it to

load-module module-udev-detect tsched=0

and ran pulseaudio --kill; pulseaudio --start to reload. Problem gone. (I could have also just rebooted at that point, of course.)

This is clearly just a workaround, not a fix, but it got me back to listening to music for now. I’ll follow the bug for a better, more permanent resolution. In the meantime, if you have a similar problem, hopefully this helps you too!


@not-mattdm-at-all should we lock topics that have been solved? I wonder if it can be done automagically :thinking:

I don’t think so. There’s always the possibility of a better solution or more information. Sometimes people mark something as solved really quickly, like as soon as they get any reply at all, and locking the thread prevents people from improving in that case.

1 Like

Sure, the mods can lock threads manually if needed then.

I am presenting this kind of crackling sounds on F32 too, kernel 5.6.15-300.fc32.x86_64. Tried @mattdm 's workaround but they are still present, when boot the system, when a mail arrives, on terminal some times, when open the sounds settings. I agree they are horrible sounds to hear. The hardware used is an AMD Lenovo ThinkPad E585.

Well, after commenting the following line:

/etc/pulse/ module-suspend-on-idle
/etc/pulse/ module-suspend-on-idle

The crackling occurs in the login screen but not later during the work session. It seems to be related to the transition between IDLE to SUSPENDED of the pulseaudio default sink.

The behavior was more or less the following: the first crackling occurs, the pulseaudio sink enters in IDLE for around 20 seconds in which period of time no other crackling is audible. When it enters in SUSPENDED mode a softer crackling is audible. Once in SUSPENDED mode a louder crackling is audible again and so on. The triggering seems to be actions that need to use the default pulseaudio sink (e.g., new mail arrives).

The PulseAudio/Troubleshooting page was helpful.

1 Like

Thanks for the tips! Using both of your suggestions in both and seems to have foxed the issue. I do hear a small click when starting and stopping audio, but nothing compared to the ear torture before. Also on an AMD MB.

2 posts were split to a new topic: Horrible crackling sounds – and no pulseaudio configuration files to try work-arounds?

Here we are in late 2023, I don’t even use Fedora, and my up to the minute Linux distro has this problem. Annoying thing about Linux is some thing just never get fixed. Anyway, thanks for the fix, now my sound works. Whew.