MultiWriter broken in Fedora 30?

I used gnome-multi-writer frequently in past Fedora versions but after the upgrade to Fedora 30, it won’t even launch.


(gnome-multi-writer:11304): GLib-GObject-CRITICAL **: 22:57:54.268: g_object_ref: assertion ‘old_val > 0’ failed
(gnome-multi-writer:11304): Gmw-CRITICAL **: 22:57:54.268: gmw_device_set_order_process: assertion ‘GMW_IS_DEVICE (self)’ failed
(gnome-multi-writer:11304): Gmw-CRITICAL **: 22:57:54.268: gmw_device_get_block_path: assertion ‘GMW_IS_DEVICE (self)’ failed
(gnome-multi-writer:11304): GLib-GObject-CRITICAL **: 22:57:54.268: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
Segmentation fault

I have a fresh install of Fedora 30 and installed the tool and it launched without issue. Have you tried reinstalling it?

Yes, I removed and installed it via gnome software previously - No Change.
I looked up the dnf commands and the following worked:

sudo dnf remove gnome-multi-writer
sudo dnf install gnome-multi-writer

On first start an error message was prompted about an unreachable file path and then it launched normally.
Guess, I have to use the terminal more often.

That’s weird… Could someone care to explain why? Thanks