Multiseat regression on Fedora workstation 31

Hi!

I upgraded my desktop computer last week to Fedora 31. The upgrade was nice and smooth as usual and most things seem to work. I have one problem though: multiseat.

The computer has two AMD GPUs so I have configured it for multiseating by assigning one GPU to seat-1 together with some USB devices. This setup has been working flawlessly since Fedora 28 or 29 (can’t remember exactly), but now it seems broken. :frowning: And I’m not really sure where to even look for errors. :confused:

This is what happens: During boot I see both monitors light up and show the boot animation. Then just when it should fade to the login screen (one on each monitor) one of them switches to the boot log (and just stays there) and the other shows the login screen. If I login, both monitors will be used by seat0 as if I didn’t have multiseating configured.

I have found a workaround that I’m using at the moment. I flush the configuration (loginctl flush-devices) and then make sure to login using “Gnome on Xorg”. Now when I configure multiseating the second monitor flashes and then displays the login screen, just as it should. If I reboot, I have to redo the “flush devices” dance again to get it to work.
Tt worked fine on both wayland and xorg before and I never had to flush devices or reapply the config.

The mutliseat configuration is very simple, I run three commands:

sudo loginctl attach seat-1 /sys/devices/pci0000:00/0000:00:03.2/0000:0a:00.0/drm/card0
sudo loginctl attach seat-1 /sys/devices/pci0000:00/0000:00:07.1/0000:0b:00.3/usb5/5-4
sudo loginctl attach seat-1 /sys/devices/pci0000:00/0000:00:07.1/0000:0b:00.3/usb6/6-4

I realize this may not be the most common setup but still hoping someone may have some helpful input. Thanks!