Moc doesn't work

There is an immediate error when invoking mocp:

FATAL_ERROR: TiMidity-Plugin: Error processing TiMidity-Configuration!
Configuration file is: <default>

moc from rpmfusion? free/moc | PkgDB

Seems to be an issue with the config file. Is it readable (file permission and selinux)?

A search for the error message found many answers.

Basically, you must specify the timidity config path explicitly in the moc config.

If you have not created a moc config, you can write the necessary line with this command:

$ echo "TiMidity_Config = /etc/timidity.cfg" >> ~/.moc/config

If you have an existing moc config or copied it from the example (/usr/share/doc/moc/config.example), then find and edit the line accordingly.

According to the current moc maintainer, the problem was caused by a change in timidity. But leaving moc users affected for more than 5 years makes it a moc problem. I would suggest (re)opening a bug report with moc upstream, to at least document the problem in the example config.

1 Like

From the moc example config:

# You can setup a TiMidity-Config-File here.
# Leave it unset to use library defaults (/etc/timidity.cfg mostly).
# Setting it to 'yes' also uses the library defaults.
# Set it to 'no' if you don't have any configuration file.
# Otherwise set it to the name of a specific file.

This sounds to me like TiMidity_Config = /etc/timidity.cfg is already the default, thus I didn’t try it before. However, I can confirm that setting this explicitely makes the problem go away.