Microphone just picks up static, after using microphone audio becomes stuttery

Acer Chromebook 14 running Fedora 37

When recording anything with my laptop’s internal microphone, only static is recorded. After the microphone is used, playing any sound becoming stuttery and alternates between working and silent quickly, which persists until I restart wireplumber.

If the internal mic is being used and active while the internal speakers are in use the system is likely picking up and cancelling feedback from the speakers. Thus the background noise cancellation may be causing the stuttering.

Have you tried playing audio with the mic disabled (muted)?

1 Like

To be clear, the stuttering isn’t while I record audio, it’s after. As in, if I try to record something, then it will start to stutter even after I stop recording, until I systemctl --user restart wireplumber

If I haven’t tried to record audio since last restarting pipewire, it doesn’t stutter.

Maybe I am misunderstanding. I thought you meant that the playback audio was stuttering and assumed you meant recording while listening to what was being recorded.

1 Like

No, any audio.

If I record something, restart pipewire and listen to what had been recorded, it’s still static, but does not stutter.

If I record something, then listen to something else like a YouTube video without restarting pipewire, it’s not static, but stutters