Method to use Fedora Basic Graphic Mode install on Laptop with NVIDIA GPU and Enable Intel Graphics Only

So not a question, so please let me know if I should post this elsewhere, but I didn’t see another post that walked you through this, and thought it might be useful to the community.

Context: NVIDIA (nonfree and nouveau) drivers seem to hang my system on boot, and when I need the NVIDIA GPU, I just boot into Windows. For Fedora, I just want to use the plain old Intel GPU included on my chipset. However, I can’t install Fedora unless I use the troubleshooting->“Basic Graphic Mode” install method because for some reason my laptop doesn’t like the normal fedora installer (just hangs every time). When I install using the basic graphic mode install, it just leaves me with a gnome install using software rendering and it is ugly.

How I solved the problem:

  1. Install Fedora using the troubleshooting->“Basic Graphic Mode” install method (menu is presented to you when you boot from the usb burned with the fedora live iso).
  2. Once you have fedora installed, sudo nano /etc/default/grub
  3. Remove nomodeset from the GRUB_CMDLINE_LINUX variable.
  4. add rd.driver.blacklist=nouveau and modprobe.blacklist=nouveau to the GRUB_CMDLINE_LINUX variable
  5. remake the grub2 config file: sudo grub2-mkconfig -o /boot/grub2/grub.cfg
  6. reboot.

Basic explanation: removing nomodeset gets you out of software rendering mode by allowing the kernel to load video drivers. However, if you do that, you’ll fallback to using the nouveau drivers. However, this just borks my system and I end up without being able to boot up without doing some recovery from the grub menu. Adding the blacklist lines prevents nouveau drivers from loading, so you end up with only the intel drivers, and you boot up fine.

If my explanation is wrong, please let me know, and i’ll update.
If I have any errors in the procedure, please let me know, and i’ll update.

Edit: I decided to just stick with the procedure above vice signing the NVIDIA drivers and installing them. The Intel drivers work great, and I haven’t had any issues with crashes or hangs. That being said, I still marked a solution below for those that want to give it a whirl.

You are forcing the system to use no driver for the nvidia card when blacklisting nouveau unless you also have installed the nvidia drivers.

What I do is similar (but different)
I install using the troubleshooting – basic graphics path as you did.
I then, during first boot enable the 3rd party repos.
Once that is done I open a test terminal and install the nvidia drivers with
sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda
After that completes I wait about 5 minutes and reboot.

The nvidia drivers will now load, the nouveau drivers are blacklisted, and all is good in the video world.

The only caveat there is that the user has to disable secure boot or sign the nvidia modules before the system is able to load and use them.

I just did a new clean install of F38 on a desktop where I installed a new drive for the OS and this is the process I used.

When the screen is flickering as it does when nouveau does not properly support it and before the nvidia drivers are installed, one may simply add the ‘nomodeset’ line into the kernel command line during boot to force it out of modeset, and the nouveau drivers will function well enough to do basic tasks like the terminal window I noted while installing the nvidia drivers.

There have been several reports of problems caused by totally disabling loading of the drivers for the nvidia card in an optimus configured laptop.

In fact, the nvidia card is not normally used when running apps in fedora/gnome unless the user selects to use the dedicated video card when launching app.

1 Like

Great info. Thank you! The nouveau drivers for some reason cause my system to crash at boot. When I installed the Nvidia drivers after the basic graphic install I was not signing the drivers (I use secure boot), which I’m assuming caused me to fallback to the nouveau drivers and I was right back at crashing at boot.

This is why I had to revert to the process I described in the first post.

Out of curiosity, any good links on Nvidia drivers and secure boot? I’m sure I’ll find them fast now that I know the issue.

rpm fusion nvidia installation guide
how to nvidia

rpm fusion guide to secure boot
how to secure boot nvidia

Simplest step by step method (with the nvidia drivers already installed).

  1. Read the file /usr/share/doc/akmods/README.secureboot and perform all the steps.

  2. Remove the locally built but unsigned nvidia modules with sudo dnf remove kmod-nvidia-\*

  3. Rebuild the kernel modules with sudo akmods --force which will build and sign the new modules.

  4. Wait until step 3 completes then wait another minute or so to be 100% certain the new modules are available. If the command dnf list installed \*nivdia\* shows the kmod-nvidia-6.5.X package for your current kernel then the modules are available and you need wait no longer.

  5. Reboot – enable secure boot during the boot if needed.

Note that if the dnf command in step 4 does NOT show the nvidia-gpu-firmware package then it must also be reinstalled with sudo dnf install nvidia-gpu-firmware before doing the reboot in step 5.

2 Likes

Thx! Will try this out tomorrow.

Thank you for the links!

Hi all, I am very new on Linux in general but I am trying my best reading this forums.

I want it to do the same but with AMD Radeon HP 6750 M Graphic card.

Any solutions for my graphic card? There is a post “AMD GPU not recognised”… but didn’t work for me… Can somebody helps please? Or send a link of where I can find a solution? Thank you in advance people!

create new topic explain issue and there will be someone providing more details and help since this topic is difrent issue and difrent cards

Ok thank you Marko