MegaSync Client Segfault

The official MegaSync client for Fedora (34) appears broke right now based on issues posted on their Github here and here; it appears to be related to the cryptopp-8.6.0-1.fc34.x86_64 package. One of the suggestions is to downgrade cryptopp-8.6.0-1.fc34.x86_64 to cryptopp-8.2.0-4.fc34.x86_64 and I’m just asking about how “wise” that is.

For the record, Mega says their repos have been updated with a fix, but no update has fixed this issue for me and the segfault continues.

Thanks for any help…

1 Like

Did you already try a reinstall with the new fixed package(s)?

dnf reinstall package-name

Yup… Based on suggestions at the Mega’s GitHub, I downgraded cryptopp to 8.4.0-2 and the sync successfully worked on a reboot; however, upgrading back to 8.6.0-1, which should have worked because of the “updated” package in the repo, still segfaulted with Segmentation fault (11) at address 0.

Any else have any luck?

The megasync- package (from RPM Fusion) will work with the (security fixed) cryptopp-8.6.0-1.fc34.

The RPM Fusion package would still segfault for me. Ultimately, I realized I don’t need that repo, so removed it and followed the advice of polmr on mega’s github; i.e.:
sudo dnf remove megasync nautilus-megasync && sudo dnf install --refresh --repo=MEGAsync megasync nautilus-megasync

The megasync- along with cryptopp-8.6.0-1.fc34.x86_64 from RPM Fusion nonfree are working perfectly fine. (tested by me).

Strange… the RPM Fusion repo version still won’t work for me…

Well, you need both cryptopp and megasync updated packages.

Is it possible that either of those 2 packages are being installed from some other location? Different repos sometimes have problems with packages not 100% compatible. If both are available from rpmfusion then both should be installed from there.

Both cryptopp and megasync were installed via RPM Fusion and won’t work; however, when I remove those and install the ones from MEGAsync repo, everything works as expected.

As I said, I don’t reproduce.
Cetainly another issue on your end.

Indeed, many people don’t understand that mixing unrelated repositories break system dependencies. As soon as you keep fedora + rpmfusion and few known good ones, it’s safe.

If you install any unsafe repositories replacing system libraries then you are seeking for problems.

Unfortunately, we cannot trust Bryan say unless there is a proper report. That’s how we expect to improve things not by changing provider without trying to understand things.

At least an output from a console command line running megasync would be a start…

As I understand it, the MEGAsync repo doesn’t install and/or replace any system libraries; however, this is moot now that I no longer have this segfault issue when using MEGA’s own repo.