Maximising on Fedora 39

I just upgraded to Fedora 39 and my maximise and minimise button on my window decorations have vanished. I can also no longer maximise a window by holding super and dragging it to the top, nor can I move or maximise windows using super + arrow keys. I used both of these features all the time but now I need to hunt for the one bit of the firefox bar that isn’t a button and double click it just to maximise.

Is there any way to turn these essential features back on?

Answer: Yes.

Use Tweaks to turn the maximise buttons back on
Go to keyboard shortcuts and re-enable the shortcuts that this upgrade for some reason disables?
Reinstall Tiling Assistant

You have now fixed the issues I listed that upgrading causes :upside_down_face:

1 Like

Those shortcuts are intentionally disabled by Tiling Assistant so its version can be used instead. That extension also broke for me on upgrade and had to be reinstalled. I think it may be a common problem: GNOME 45: The extension is incompatible with the current GNOME version · Issue #300 · Leleat/Tiling-Assistant · GitHub

I don’t know what could have reset your titlebar button layout though.