Many bugs in Firefox

Hello people. It is the first time that I write in a Linux group, I will try to be as clear as possible. I was hoping that for fedora 33 this would have been resolved but it was not. I don’t have much knowledge in Linux. And also, I dont know english. I have to use an dictionary and a transletor to write this …do not kill me in the comments, please.


As you can see in the video, when I try to open some menus, strange things happen, such as, for example, when I open the menu of some extension, placed somewhere in the browser, the menu appears elsewhere and also does not close if I press on the extension. I have to press another side of the browser so that it closes.

Where and when it happens?:

This happens in both FEDORA 32 and FEDORA 33. It only happens in Wayland. And the bug is from the installation. I mean, I haven’t touched anything for this to happen. I did a fresh installation and when opening firefox I find these errors.

This does not happen when installing from the official page of firefox or from flathub.

My computer:

Model: Dell Inspiron 14 3459

CPU: Intel i5-6200U (4) @ 2.800GHz

GPU: Intel Skylake GT2 [HD Graphics 520]

GPU: AMD ATI Radeon R5 M315

What i tried?:

I installed, from RPMFUSION, drivers, for example, amdgpu. I deleted my profile in case it was corrupt. And, I tried to get firefox to use xorg. Nothing works.

You checked the iso?:

I checked it just as the page says. I Download it from fedora media writer, from torrent and from the official website. In all I check the ISO.

Did it happen to you in another browser?:

I tried chromium and epiphany, and only in Firefox do these failures occur

Did it happen to you in another OS?

Previously I used Manjaro KDE, Linux Mint Cinamon, Debian with Gnome and KDE Neon. I never had these problems.

You checked bugzilla?:

Yes, I couldn’t find anithing similar


I think, obviously, the problem is with Wayland. Also, it may be that some libraries are missing in the firefox package26d3fb323c38bd99ab2a509e11908696023f8f83.gif

1 Like

Hi, welcome in Fedora community!
I remember reading about this issue being fixed or worked on.
I don’t think there’s anything in RPMFusion required by AMD GPUs. You might need xorg-x11-drv-amdgpu, but it’s in Fedora repos.

I see you’ve already done some extensive testing, before reporting this bug here I’d try two more things:

  • run Firefox on AMD GPU, in terminal: DRI_PRIME=1 firefox
  • compare how it behaves on xOrg session (choose it on login screen).

Thanks for your answer. I apologize for the delay in replying. I have tried what you tell me and it gives the same result. However, I must modify some things from the above. Using the firefox-x11 package seems to “fix” the problem. The problem was repeated in open-suce. But the problem did not recur in Debian and Ubuntu

So it’s Wayland related. Neither Debian nor Ubuntu use Wayland by default, hence you spotted this issue only on Fedora.
If you reported a bug or found one related, post it’s link here, so others could track it too.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.