Makeing Blu-Rays on fedora

OK give me a while and I will get it for you. Its after it processes the videos so it will take a while

OK here is 1 of 2

14:09:33: Failed to create a temporary file name (error 2: No such file or directory)
14:09:33: can't open user configuration file.

Here is 2/2

Error transcoding of /home/jon/Downloads/Xeno/1/Xenoblade Chronicles 2 - Episode 10- The Crane Game [gy6xD0pblWw].mp4

What’s the output of rpm -qa ffmpeg\* ?


You might try installing compat-ffmpeg4 if you don’t already have it, since it appears to add mp4a support in case your video might happen to have that audio encoding.

I just tried installing it and it was already installed

The temp file error (error 1) may be due to size. I got the same when it told me that it needed 50G temp space with only 16G of ram (/tmp is in ram by default)

1 Like

I set the tmp folder to /home/user/ and is still did not work(and yes their was a good size)

I did the same with the temp file. (dvdstyler-2:3.3-0.1.beta3.fc37.x86_64)
Was successful in creating an ~53GB ISO from 6 .mkv files.
There were a couple glitches in the menu, but the menu was created and all the videos could be played from the iso thus created.

I have MP4s. Could that be the problume?

Don’t know. Should not be a problem since an mkv is essentially an mp4 in a matroska container.

It takes a little time to transcode the files and create the separate audio & video tracks in the Audio_TS and Video_TS directories.

Failure to properly transcode could cause failure so having the proper codecs is important. I do have ffmpeg-devel installed and you did not show that above, but it should not be necessary.

I’m going to try something new. I’ll let you know how it goes but when downloading my videos they did work. Give me an hour and I’ll report back what happened.

OK that did not work. Let me try MVK format.

Sorry did not do it.

Well, I have been testing a little.

I have created disk isos in various ways.
I can use mpg, mp4 or mkv and all the videos play.
What does not work is switching format in the middle.
For example, if I use mp4 for the first few videos then mpg later on the mp4s will play fine, but the mpg do not.
Similar if I mix any of the formats. Whatever the first format is will work but switching to another format of the files seems not to work.

I guess dvdstyler is not flexible enough to switch encoding midstream, so the files selected all need to be in the same format.

Easy to use ffmpeg and make all the videos the same format before you start so that is not really a deal breaker for me.

Can you supply a link of how I would do that?

man ffmpeg for more detailed info, but I use
ffmpeg -i </path/to/input file.mpg> -c:a copy -c:v copy </path/to/output file.mp4>
which converts the input mpg file into an mp4 file without converting any of the data in the video or audio streams. Ffmpeg is capable of converting formats automatically based on the filename extensions for most of the standard formats.

If you have multiple files to convert it is easy to set up a script to do that for you as a loop and process all the files one at a time.

My thoughts are that I select the desired output format, then write a script to do the conversion. To separate those needing conversion from those not needing conversion (or already converted) I use different directories for input and output files based on the data formats.

1 Like

Just tried it and when It did convert it did not work on DVD styler

I’m not sure if DVD styler is going to work at this point. here are the logs from K3b. Let me know if you find anything wrong.

MATSHITA BD-MLT UJ240AF 1.01 (/dev/sr1, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, BD-ROM, BD-R, BD-RE, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW, BD-ROM, BD-R Sequential (SRM), BD-R Random (RRM), BD-RE] [SAO, TAO, RAW, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Random Recording, Sequential Recording, Sequential Recording + POW] [%7]

mkisofs print size result: 0 (0 bytes)

K3b Version: 22.8.3
KDE Version: 5.100.0
Qt Version:  5.15.7
Kernel:      6.0.15-300.fc37.x86_64

Used versions
mkisofs: 3.2

mkisofs: Warning: Cannot add inode hints with -no-cache-inodes.
mkisofs: No such file or directory. Failed to open '/tmp/k3bVideoDvdAJDciW//VIDEO_TS/VIDEO_TS.IFO'.
mkisofs: Can't open VMG info for '/tmp/k3bVideoDvdAJDciW/'.
mkisofs: Unable to parse DVD-Video structures.
mkisofs: Could not find correct 'VIDEO_TS' directory.

mkisofs calculate size command:
/usr/bin/mkisofs -gui -graft-points -print-size -quiet -volid K3b data project -volset  -appid K3B THE CD KREATOR (C) 1998-2018 SEBASTIAN TRUEG, MICHAL MALEK AND LESLIE ZHAI -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/k3b.CILTWi -no-cache-inodes -udf -iso-level 1 -path-list /tmp/k3b.mCjrid -dvd-video -f /tmp/k3bVideoDvdAJDciW