MacbookPro 14,1 Sound Troubleshooting

I’ve been attempting to dual-boot Linux on my Macbook Pro (14,1 2017) for the past month. I’ve tried several arch distros (endeavour, arco, manjaro, vanilla arch), but always ran into problems with Wifi, Audio, Bluetooth, or all three. Now I’m trying out Fedora and I’m astonished that Wifi and Bluetooth are both working flawlessly out of the box. Still haven’t been able to get sound working on any of these installations.

I’ve read the existing posts on this topic, including: and
Sound not working in Macbook Pro mid 2017

I’ve tried audio-intel.conf, neither of the following worked:
options snd-intel-dspcfg dsp_driver=1
options snd-intel-dspcfg dsp_driver=2

I’ve tried mac-sound.conf, neither of the following worked:
options snd_hda_intel model=intel-mac-auto
options snd_hda_intel model=mpb141

(mpdb141 isnt in the documentation, but it followed a similar syntax to macbook models that are in the kernel docs)

Here is my output for
hwinfo --sound

18: PCI 1f.3: 0403 Audio device                                 
  [Created at pci.386]
  Unique ID: nS1_.W+AMVqUgGp9
  SysFS ID: /devices/pci0000:00/0000:00:1f.3
  SysFS BusID: 0000:00:1f.3
  Hardware Class: sound
  Model: "Intel Sunrise Point-LP HD Audio"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x9d71 "Sunrise Point-LP HD Audio"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x7270 
  Revision: 0x21
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0x92820000-0x92823fff (rw,non-prefetchable)
  Memory Range: 0x4000000000-0x400000ffff (rw,non-prefetchable)
  IRQ: 58 (510 events)
  Module Alias: "pci:v00008086d00009D71sv00008086sd00007270bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Driver Info #1:
    Driver Status: snd_soc_skl is active
    Driver Activation Cmd: "modprobe snd_soc_skl"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

aplay -lL

    Discard all samples (playback) or generate zero samples (capture)
    PipeWire Sound Server
    Default ALSA Output (currently PipeWire Media Server)
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
    HDA Intel PCH, HDMI 1
    HDMI Audio Output
    HDA Intel PCH, HDMI 2
    HDMI Audio Output
    HDA Intel PCH, HDMI 3
    HDMI Audio Output
    HDA Intel PCH, HDMI 4
    HDMI Audio Output
** List of PLAYBACK Hardware Devices **
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

None of the above “solutions” made any changes to hwinfo or aplay

I would greatly appreciate some help with this, it’s the only dealbreaker issue I’ve had, and I otherwise love f36, especially given how much worked right away.

I spoke too soon. suspending the system managed to disable my wifi device. This ALSO managed to break wifi within MacOS somehow, I only got things working by booting MacOS in Safe Mode. Wifi still won’t reactivate in Fedora, though.

This behavior is really strange, Wifi worked just fine out of the box, but suddenly the wifi device doesn’t even show up in nmcli d.