Luks2 Password Entry

Ever since upgrading to kernel 6.2.X after a warm and cold reboot the LUKS2 password entry promt will fail to appear and after a while dracut-initqeueue will start to spam screen. And then land at recovery prompt system will boot fine on 6.1.8-200 any ideas? I have tried completely regenerating initramfs with dracut but no change.


luks-6fb8e34c-374e-490e-a1fe-9553fb3164cc /dev/nvme0n1p3 none discard,fido2-device=auto
luks-faed2787-424c-4a1f-9469-e71efb5472c6 /dev/nvme1n1p1 none discard,fido2-device=auto


# /etc/fstab
# Created by anaconda on Wed Feb 22 10:39:06 2023
# Accessible filesystems, by reference, are maintained under '/dev/disk/'.
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info.
# After editing this file, run 'systemctl daemon-reload' to update systemd
# units generated from this file.
/dev/mapper/luks-6fb8e34c-374e-490e-a1fe-9553fb3164cc /                       ext4    defaults,x-systemd.device-timeout=0 1 1
UUID=d18e9c71-e1be-49d4-9058-700737a633d6 /boot                   ext4    defaults        1 2
UUID=6A40-48C2          /boot/efi               vfat    umask=0077,shortname=winnt 0 2
/dev/mapper/luks-faed2787-424c-4a1f-9469-e71efb5472c6 /home                   ext4    defaults,x-systemd.device-timeout=0 1 2


GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="rd.luks.uuid=luks-6fb8e34c-374e-490e-a1fe-9553fb3164cc amdgpu.ppfeaturemask=0xffffffff"

Have you tried reinstalling the 6.2 kernel after booting into the 6.1 kernel?

There’s currently a bug triggering on an attempt to reinstall the kernel-modules-core package with DNF, which is relevant for all 6.2.* kernels:
Depmod warning, missing files in /lib/modules/kernel* when running dracut

1 Like

Yes nothing changes

Is there any update on the status of solving this. I have tried installing the kernel and kernel modules manually via rpm and absolutely nothing changes

Any help is greatly appreciated