I’ve been using a program that depends in Lua 5.3 library files, but they don’t seem to be included in the latest lua-libs release, which is 5.4.4-7 . Are there any possible workarounds?
Specifically which files are you missing. The logs should show the missing files so we can identify the fix.
liblua-5.3.so, which should be in
One of Fedora’s foundations is to be First; thus it tries to ship the latest versions of software. Lua in Fedora is 5.4; there is no 5.3.
However, it appears that for some time, there were 5.3 libraries shipped. But this was an accident because the package was being bootstrapped (i.e., using previous Lua to help build current Lua):
So you should try to avoid using things that require Lua 5.3. If you really must though, you may want to look into using a container or distrobox for older Fedora/Debian/etc. that might still have Lua 5.3
Thank you so much for your reply!
You also might be able to temporarily enable your app by ‘faking’ the lua 5.3 with a link such as
sudo ln -s /usr/lib64/liblua-5.4.so /usr/lib64/liblua-5.3.so to create a symlink to the existing lib.
I do not know if lua 5.4 is compatible with an app using lua 5.3 but it may work as a temporary workaround.
Upgrading the app seems a better choice if possible.
I’ve already tried doing that, but the program complained it wasn’t the right Lua version. Thank you anyways.