Low Battery life on Asus ROG Strix 731

Hello community, I have a problem with the duration of my battery, I detail a little the context of consumption:
The autonomy of my battery in Win 10 is approximately 2h30m with Fedora it is 1h. Only in 16 min in sleep state it consumed 3%.

Attached some consumption metrics.

Thanks for the info. The pic for gkrellm is fine. The rest of the info should be copied and pasted into the post as text. Screenshots are sometimes hard to read and always impossible to reference specific lines in follow on texts.

The text should be posted in the </> preformatted text tags available on the top bar of your screen when entering the data for the post so it retains the exact same formatting as you see on your screen. Copy by highlighting with the mouse then a right click to select copy and the same for paste.

With that said, having a 3% drop in battery in 16 minutes when “sleeping” tells me it is not actually sleeping.

We need to work out why it is not sleeping properly for you as part of the issue with power.

I do not see any info about fans or CPU temp. Did you run sudo sensors-detect -a after installing lm_sensors? I have the same exact system as you but mine is about 3 months older according to the date in inxi.

I see this in inxi so I wonder if sensors_detect was properly run.

  System Temperatures: cpu: 74.0 C pch: 57.0 C mobo: N/A gpu: nvidia temp: 51 C
  Fan Speeds (RPM): cpu: 5400

BTW, your system is not a Dell which is what this thread was started for, so I am moving this discussion to a new thread

@isudoajl you do not have to make you the work for a partial print screen shot. If you copy and paste the output as </> Preformatted text, it is perfectly readable for us and you save a lot of work.

1 Like

Thanks for teaching me regarding the screenshots.

inxi output:

[isudoajl@rog ~]$ inxi -Fzxx
  Kernel: 5.16.18-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc
    v: 2.37-10.fc35 Desktop: GNOME 41.4 tk: GTK 3.24.31 wm: gnome-shell dm: GDM
    Distro: Fedora release 35 (Thirty Five)
  Type: Laptop System: ASUSTeK product: ROG Strix G731GU_G731GU v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: G731GU v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: G731GU.312 date: 02/19/2021
  ID-1: BAT0 charge: 24.7 Wh (54.4%) condition: 45.4/66.0 Wh (68.8%)
    volts: 15.7 min: 15.7 model: ASUSTeK ASUS Battery serial: N/A
    status: Charging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse B330/M330/M331
    serial: <filter> charge: 55% (should be ignored) status: Discharging
  Info: 6-core model: Intel Core i7-9750H bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 800 min/max: 800/4500 cores: 1: 800 2: 800 3: 800
    4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
    bogomips: 62399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel ports: active: eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:3e9b
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK
    driver: nvidia v: 510.60.02 pcie: speed: 2.5 GT/s lanes: 8 ports:
    active: none empty: DP-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:2191
  Display: x11 server: X.Org v: 1.20.14 compositor: gnome-shell driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa alternate: nv
    gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 model: AU Optronics res: 1920x1080 dpi: 128
    diag: 438mm (17.3")
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 21.3.8 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a348
  Device-2: NVIDIA TU116 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 2.5 GT/s lanes: 8
    bus-ID: 01:00.1 chip-ID: 10de:1aeb
  Sound Server-1: ALSA v: k5.16.18-200.fc35.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
  IF: eno2 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-14:4 chip-ID: 8087:0aaa
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 1.14 TiB used: 10.88 GiB (0.9%)
  ID-1: /dev/nvme0n1 vendor: Western Digital
    model: PC SN520 SDAPNUW-256G-1002 size: 238.47 GiB speed: 15.8 Gb/s
    lanes: 2 serial: <filter> temp: 31.9 C
  ID-2: /dev/sda vendor: Seagate model: ST1000LX015-1U7172 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 54.65 GiB used: 10.84 GiB (19.8%) fs: btrfs
    dev: /dev/nvme0n1p6
  ID-2: /boot/efi size: 96 MiB used: 39.6 MiB (41.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 22 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p5
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 43.0 C pch: 49.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2300
  Processes: 363 Uptime: 43m Memory: 15.47 GiB used: 3.76 GiB (24.3%)
  Init: systemd v: 249 runlevel: 5 target: graphical.target Compilers:
  gcc: 11.2.1 Packages: note: see --pkg flatpak: 2 Shell: Bash v: 5.1.8
  running-in: gnome-terminal inxi: 3.3.13

sensor ouput:

[isudoajl@rog ~]$ sensors
Adapter: ISA adapter
Package id 0:  +40.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +38.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +39.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +37.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +39.0°C  (high = +100.0°C, crit = +100.0°C)
Core 4:        +38.0°C  (high = +100.0°C, crit = +100.0°C)
Core 5:        +38.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: Virtual device
temp1:        +48.0°C  

Adapter: ACPI interface
in0:          15.68 V  

Adapter: Virtual device
temp1:        +32.0°C  

Adapter: ISA adapter
cpu_fan:     2300 RPM

Adapter: PCI adapter
Composite:    +31.9°C  (low  =  -0.1°C, high = +81.8°C)
                       (crit = +85.8°C)

Adapter: ACPI interface
temp1:        +39.0°C  (crit = +103.0°C)
1 Like

Hello @isudoajl,
I thought that recent Fedora Linux installs were managed by powerprofiles daemon, ie you use powerprofiles-adm or similar to administer it. The power management would be the battery manager for your laptop I would think.

Hello @jakfrost , indeed, it does come with a power profile, but it’s no use, I put Power Saver and there are no changes in battery performance.

Yeah, I found with my Asus MoBo which has wifi but is a desktop, the powerprofiles daemon was getting in the way since it saw my desktop as a laptop and would only allow balanced or power saver mode, plus it is Intel oriented so didn’t seem to care about my AMD as anything but a generic cpu. I uninstalled it and installed tuned instead for my purposes, but in your case perhaps the asusctl utility would be better suited since it’s a laptop. I think it is a part of the fedora repo already. Fedora’s power management guide (though a bit dated) is here Power Management Guide.

1 Like
sudo powertop

and… Increase battery life by turning off your dGPU. https://discussion.fedoraproject.org/t/how-does-wayland-chooses-which-driver-to-use-is-it-possible-to-install-nvidia-drivers-but-to-only-use-intel-nouveau/70874

I have to disagree with this suggestion.
I have exactly the same laptop and while running boinc using the dGPU at about 50% CPU load across the board (12 threads) I get about 1 hour on the battery. When in normal laptop mode and not running boinc to deliberately load the CPU but still using the dGPU full time (about 1% load) I get 3 to 4 hours. My system is set to use the nvidia dGPU as primary and never uses the intel IGP

The OP claims to only get 1 to 1.5 hours so I have to believe it is related to how much CPU load he has and not related to the use of the nvidia GPU. Heavy gaming would do that. After all the laptop is a gaming laptop. The OP has yet to tell us what he does when he gets that little battery life, though his posts of inxi show very little load and the CPU is clocked at minimum speed on both those posts.

Hello @computersavvy I have been doing some tests, I installed TLP and changed the autonomy of the battery from heaven to earth. Right now I have installed F35 from scratch again to do some evaluations, I am doing the setup on my laptop and at the same time I am looking at powertop utility to see the discharge rate, at the moment I have a discharge rate of 16W iddle: 4 tabs in firefox and 4 tabs terminal open.

I am going to proceed to install dGPU nvidia driver, I ask, is this link the correct procedure? https://docs.fedoraproject.org/en-US/quick-docs/how-to-set-nvidia-as-primary-gpu-on-optimus-based-laptops/

I hope you can shed some light on the correct way to install my nvidia drivers.

Until now I have NOT installed TLP and the autonomy of the battery is excellent, I went out to do some things and the suspension state work perfectly! In fact I realized that in the old instalation the nvidia service unit is in failed state, could this have to do with the wear of my previous battery drain?

Jeff do you use TLP?

I do not use TLP and never have.

Install the nvidia drivers from the rpmfusion-nonfree-drivers-nvidia repo which is available through enabling the third party repo through the gnome-software app. Once that repo is enabled then doing sudo dnf install akmod-nvidia*510* will install all the minimally necessary drivers.

The link you posted is correct in some areas but has not been updated for a couple years.
Steps 1-4 are good (but remember you are on fedora 35, not 32)
Steps 5-7 should only include the sudo dnf install akmods-nvidia*510* step. The installation takes care of everything else in those steps.

Step 8 is important but needs clarification.

  1. You should copy the file sudo cp -p /usr/share/X11/xorg.conf.d/nvidia.conf /etc/X11/xorg.conf.d/nvidia.conf
  2. Then IF you want to make the nvidia gpu primary and ignore the intel IGP (I did and run that way constantly) then do the edit step.

This is what I have

$ ls /etc/X11/xorg.conf.d/
00-keyboard.conf  nvidia.conf

$ cat /etc/X11/xorg.conf.d/nvidia.conf 
#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "OutputClass"
	Identifier "nvidia"
	MatchDriver "nvidia-drm"
	Driver "nvidia"
	Option "AllowEmptyInitialConfiguration"
	Option "SLI" "Auto"
	Option "BaseMosaic" "on"
	Option "Primary" "yes"

Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"
	Option "Primary" "yes"

You will note that I copied the file as directed, then edited it and added the Option "Primary" "yes" to both stanzas in that file. I don’t know that it is necessary in the “ServerLayout” stanza but certainly does not hurt.

That nvidia.conf file also serves to allow the nvidia GPU to control both the laptop screen and an external monitor. Without that file there are some issues when 2 monitors are in use since in some cases fedora tries to use the IGP for the laptop screen and the dGPU for the external monitor at the same time. The config in that file allows the dGPU to control both screens.

1 Like

Just for a comparison here are my powertop outputs, first at normal load then at minimal load. The second has the battery at 85% when it was done.

This one with the battery at 85%. The only difference is I suspended all projects running under boinc for this output.

1 Like

@computersavvy Thanks for your assistance and super quick response.

Something happen with my nvidia service unit.

Status: Failed

[isudoajl@rog ~]$ systemctl status nvidia-powerd
× nvidia-powerd.service - nvidia-powerd service
     Loaded: loaded (/usr/lib/systemd/system/nvidia-powerd.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Fri 2022-04-08 17:49:39 WEST; 17min ago
    Process: 943 ExecStart=/usr/bin/nvidia-powerd (code=exited, status=1/FAILURE)
   Main PID: 943 (code=exited, status=1/FAILURE)
        CPU: 6ms

Apr 08 17:49:39 rog systemd[1]: Starting nvidia-powerd service...
Apr 08 17:49:39 rog /usr/bin/nvidia-powerd[943]: nvidia-powerd version:1.0(build 1)
Apr 08 17:49:39 rog /usr/bin/nvidia-powerd[943]: SBIOS support not found for NVPCF GET_SUPPORTED func>
Apr 08 17:49:39 rog /usr/bin/nvidia-powerd[943]: No matching GPU found
Apr 08 17:49:39 rog /usr/bin/nvidia-powerd[943]: Failed to initialize RM Client
Apr 08 17:49:39 rog systemd[1]: nvidia-powerd.service: Main process exited, code=exited, status=1/FAI>
Apr 08 17:49:39 rog systemd[1]: nvidia-powerd.service: Failed with result 'exit-code'.
Apr 08 17:49:39 rog systemd[1]: Failed to start nvidia-powerd service.

journalctl output:

Apr 08 17:48:27 rog kernel: nvidia: module verification failed: signature and/or required key missing - tainting kernel
Apr 08 17:48:27 rog systemd-udevd[56069]: nvidia: Process '/usr/bin/bash -c '/usr/bin/mknod -Z -m 666 /dev/nvidiactl c 195 255'' failed with exit code 1.
Apr 08 17:48:27 rog systemd-udevd[56070]: nvidia: Process '/usr/bin/bash -c '/usr/bin/mknod -Z -m 666 /dev/nvidiactl c 195 255'' failed with exit code 1.
Apr 08 17:48:27 rog systemd-udevd[56069]: nvidia: Process '/usr/bin/bash -c '/usr/bin/mknod -Z -m 666 /dev/nvidiactl c 195 255'' failed with exit code 1.
Apr 08 17:49:37 rog kernel: nvidia: module verification failed: signature and/or required key missing - tainting kernel
Apr 08 17:49:38 rog systemd-udevd[695]: nvidia: Process '/usr/bin/bash -c '/usr/bin/mknod -Z -m 666 /dev/nvidiactl c 195 255'' failed with exit code 1.
Apr 08 17:49:38 rog systemd-udevd[690]: nvidia: Process '/usr/bin/bash -c 'for i in $(cat /proc/driver/nvidia/gpus/*/information | grep Minor | cut -d \  -f 4); do /usr/bin/mknod -Z -m 666 /dev/nvidia${i} c 195 ${i}; done'' failed with exit code 1.
Apr 08 17:49:39 rog audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=nvidia-powerd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'

I just run this command sudo dnf install akmods-nvidia*510*

That is nvidia-powerd and it has been failing for quite some time. It does not impact function, though it may be a factor in power usage for the GPU. I have seen that error since I started using fedora 35, though it did not happen on fedora 34 until the 5.16 kernel was installed. Nvidia-powerd.service is installed with the xorg-x11-drv-nvidia-power package.

Several others have noted the same error as well in posts here.

I have tried to file a bug with rpmfusion about that error but they have seen fit to block access to all with gmail.com email addresses so I cannot. Maybe you can if you do not use gmail for your email.

Someone really needs to file the bug report so that particular bug that has hung around since F35 (the 5.16 kernel) was released can be squashed.

Oh no, sorry, me too… @gmail.com but I’m about to shitch to Protronmail by the way…

In the other hand, I think I’m going to install again TLP beacause before de intallation everything was running good, good battery live, right now is poor. Maybe that failed service is the source as you have stated.

Hardware Requirements

Dynamic Boost is supported only on platforms that meet all of the following requirements:

    Notebook form factor.

    Ampere or newer GPUs.

    Intel CometLake or newer Intel chipsets.

    SBIOS support for Dynamic Boost

    Run the following command to check if the SBIOS supports Dynamic Boost:

    nvidia-settings -q DynamicBoostSupport


Hello @grumpey. This is my output:

[isudoajl@rog Documents]$ nvidia-settings -q DynamicBoostSupport

  Attribute 'DynamicBoostSupport' (rog:1[gpu:0]): 0.
    'DynamicBoostSupport' is a boolean attribute; valid values are: 1 (on/true) and 0 (off/false).
    'DynamicBoostSupport' is a read-only attribute.
    'DynamicBoostSupport' can use the following target types: GPU.

Hi @computersavvy I uninstalled my nvidia drivers and I notice the power consumption slow down from 24W to 12-13W (same Win 10 discharge rate) wow! Definitly we have a big problem with that nvidia driver.

Win 10

I don’t know mate, your energy consumption values don’t look abnormal, they are not any different from mine, an idle powered on dGPU will be wasting around 20-30W, while the APU alone will be wasting 10-15W, that’s on par with the battery time, about half on nvidia.

Windows can effectively power-off the dGPUs under nvidia proprietary driver while Linux can’t due to the way their firmware is built and how Linux loads driver, all they do is get to a lower energy state and stay on.

However, Nvidia made some changes to their power management firmware since Turing architecture, and newer cards can indeed shut off completely but you have to set this in the driver since it’s disable by default except for Ampere architecture.

Maybe you could try enabling Runtime D3 and then setting PRIME offloading so that you can use the dGPU only when needed. You can check if Runtime D3 it’s disabled on this command bellow.

cat /proc/driver/nvidia/gpus/0000:01:00.0/power

Just follow RPMFusion HowTo on enabling PRIME Support and setting Prime Off-Loading, specially loading the driver with the "NVreg_DynamicPowerManagement=0x02" option, maybe that will bring you closer to Windows behavior, not sure how close though, probably better but not great.

I guess powerd sevice also needs Runtime D3 enabled to work properly.

Other than that, the only way to effectively save power is to not touch the card until needed, which is the nvidia-xrun approach, blacklisting the nvidia driver, running on the APU and only enabling it to start a Xorg session when wanting to run something on the dGPU.

But that’s an ugly solution and there’s nothing wrong by running on the dGPU if you can.


Thank you very much for your time bro.