Lost network after most recent update

I just went through a round of updates on my Fedora 34 workstation (with latest updates) and rebooted. My laptop is a Dell Latitude E6520 w/ Intel 82579LM Ethernet, and Intel Centrino Advanced-N 6205 wireless. Neither of them are working. I can’t ssh to my laptop to get the details of what was updated.

If I run rfkill list my phy0 is set to Software block: no Hardware block: yes. I have disabled the hardware switch in the BIOS.

NetworkManager keeps trying to reconnect with nothing but failure. I can’t enable the Wireless for some reason. It is enabled in the BIOS btw.


1 Like

Can you clarify why you need to ssh to the laptop to see details? You don’t have local access to it?

To get you output for troubleshooting. It makes it easier to copy and paste…

1 Like

So I am still unable to get layer 2 or 3 when booted to the desktop. It is showing layer 1 and keeps disconnecting.

What happens when you boot to an earlier kernel?

Same thing.

I will try that in a bit. Also I do not dual boot.

Soooo I plugged into another port on my main switch and everything worked. I think I know where the problem lies. In my 8-port gigabit switch. I’ll will be setting up more ethernet runs this week/weekend.

1 Like

I would wager that the port on the switch is set to auto-negotiate speed. It is known that at times having both ends of a network connection set to auto-negotiate can cause issues as they do not always lock in the speed but can continually try to renegotiate the connection.

The fix I have often used is to configure the ports on the switch at one speed and allow the PC to connect at that speed.

I probably just reinstalled the OS.