[logs now available] Anaconda DBus modules fail to start on time


#41

Okay, so if it’s not power management, then my next best guess is that Fedora’s not using the new driver. Try creating a file in /etc/modprobe.d named blacklist-rtl8192.conf with the following contents:

install rtl8192cu /bin/true

Then reboot.


#42

Remember when I said this?

Well, it turns out I’m wrong…it works after all :man_facepalming:

I’m so sorry to make you go through all of this…I suppose I could still try editing /etc/modprobe.d/blacklist-rtl8192.conf if we want to get wifi working.


#43

Haha…

Well, I’d say to try it anyway, just to check. FWIW your card uses a Realtek chip, so the Broadcom drivers wouldn’t work anyway.


#44

Yayyy that fixed it! Wifi working fast now.

For future reference, would that fix work for other distros as well? I’m considering setting up a dual boot with Silverblue as my main distro and another distro for the stuff that I need Nvidia drivers for.

Edit: Also thank you very much for helping me for so long and putting up with me :smile:


#45

It should work! Basically, some distros will use the old Realtek driver (rtl8192cu) instead of the new one (rtl8xxxu). When you ran lsmod, I saw the new one but didn’t realize the old one was also being loaded. That fix should work on other distros, too.