Logout/Login Bugs in Plasma Wayland. Should I be using X11?

Are most people using Plasma (X11), or have many made the move to Wayland? I ask because I am experiencing some issues which I think are related to Wayland and I’d like to know if they’re widespread or just me.

I think I’ve found bugs related to the biggest issues I’ve found:



The kscreenlocker issue sounds like it will be fixed in Plasma 5.23, so I suspect this is still widespread?

The kwin crash issue is marked resolved as of Plasma 5.20, but I am getting the same crashing. Not sure if the root cause is related, so I don’t know if it’s widespread or just my system. When I choose Logout, I just get a black screen and the display output cuts out.

Haven’t used KDE in a while, and the last time I did Wayland wasn’t recommended. Is that still the case? Are most people using KDE on X11?

I’m not using Kinoite but I am using the KDE Plasma spin. I switched to Wayland when it became the default in F34. I haven’t seen the unlock bug (439096) but I do have the kwin crash (420077). On the other hand, I don’t generally log out—I either shut down or lock the screen.

By and large, Wayland has worked well for me. The biggest annoyance I have is that copy/paste isn’t always reliable (sometimes I have to copy twice).

1 Like

That’s interesting. The unlock bug (439096) seems like it’s affecting AMD GPUs, looking at the bug comments. And it also happens after the screen to go into off/low-power mode. So maybe you’re not affected because of one or both of those? I’m still hopeful that it’ll get resolved in 5.23, as it says.

The kwin crash (420077) is more concerning now, seeing as that bug has been closed for a while as ‘fixed’. Maybe there’s another bug being tracked out there that I missed that’s still open.

I’ve also experienced the copy/paste issue as well. Another minor issue has been during a mouse click-and-drag, the mouse button seems to release for a split second and ruins the drag. Though I’ve noticed that in GNOME as well, so I think that may be more a Wayland issue than a Plasma one.

I’ve been having varying degrees of difficulty with that as well. The degree of the problem seems to vary a bit from kernel version to kernel version. It has, at times, been extremely bad for me. But I suspect a contributing factor in my case might be that I’m using a very low-end AMD system. FWIW, I submitted a video recording of the problem when it was particularly bad to this bug report. In the video, I am holding the left mouse button down continuously as I try to highlight the lines of text.

I had been using XFCE for a very long time but really wanted to get started with Wayland so I installed F34 with KDE / Plasma but it was annoying so I switched to Sway - it was a bit of a culture shock but I am really liking it! I have had a few weird things happen but I have no idea if they reach down to the Wayland level or not - if I start noticing some reproducibility of the problems I will start asking questions about how to debug Wayland . .

I’m running Wayland Kinoite on my laptop (works great) and Wayland KDE Classic Spin on my workstation and I have the screenlocker crash as I have a “multiple input” monitor that cycles through the inputs and that triggers the crash. This does not happen on the laptop as it only has a single screen.

All of this should be fixed in 5.23 which should arrive just a bit after the F35 release. I also have the copy/paste between XWayland & Wayland apps bug which should also be resolved with 5.23.

I’m also getting really bad font rendering in GTK Flatpak applications that are using Wayland. For example, this is how Geany looks:

Seems like this is a long-standing bug. What’s everyone’s feeling about having this shipping as an open bug in Kinoite? Seems like a pretty bad user experience.

Edit: Going into Flatseal and disabling the wayland socket, and enabling x11 , fixes the font rendering and also the theming:

This might be the reason this is happening - from the comments section of this Reddit post:

Ok, I think I know what it is. xdg-desktop-portal-gtk was upgraded to 1.10, and the settings portal was disabled along the way. No wonder the settings are not available inside the sandbox (the theme does not work either), and the fallback is terrible as you can see. This should not be Kinoite-specific, but rather Fedora 35+Wayland+Gtk flatpak+non-GNOME desktop specific.

Overlaying the package xdg-desktop-portal-gnome fixes this issue. Not sure if Kinoite include this as part of the base OS image, or Fedora should build xdg-desktop-portal-gtk with the --enable-settings option going forward.

See Issue #120: Fedora 35 KDE should ship with xdg-desktop-portal-gnome to avoid ugly fonts in GTK flatpak applications on wayland - SIG - Pagure.io. Mostly will add it to Kinoite by default soon.

1 Like

Another Kinoite F35 beta tester reporting in. I rebased from the F34 Silverblue, without much issue.

If you have rpmfusion installed, you should uninstall those as part of the rebase process, then reinstall them after.

Also I had to remove the akmod-nvidia and xorg-x11-drv-nvidia-cuda packages because otherwise I was getting a dnf error that the rebase would result in the removal of systemd.

In the end I ran something like:
sudo rpm-ostree rebase fedora:fedora/35/x86_64/kinoite --uninstall rpmfusion-nonfree-release-34-1.noarch --uninstall rpmfusion-free-release-34-1.noarch --uninstall akmod-nvidia --uninstall xorg-x11-drv-nvidia-cuda

I still can’t install the nvidia driver… someone probably knows why that is?

As for the experience:

  • Lots of copy/paste bugs. Copy/paste works reliably <50% of the time, maybe <40%. I don’t know if its because of the combination xwayland/wayland apps. My bread and butter is konsole (host), firefox (flatpak), keepassxc (flatpak), intellij (toolbox), and emacs (toolbox). It’s by far the most annoying issue at the moment.

  • KDE System Settings hangs. If I change any setting in the System Settings application, nearly every single time I press Apply, the system hangs. The mouse cursor still moves around (and changes from arrow to text caret), but the windows are completely no responsive and clicking and typing appears to do nothing. Because if this issue I haven’t tweaked the setup at all, this is the second most annoying issue.

  • Monitor issues. I have a laptop plugged into an external monitor. I have plasma configured to turn off the laptop monitor and only use the external monitor. This works fine, but this configuration only takes effect after I login. At the login screen (is it kdm?) both monitors are active and I have severe stability issues. About half the time I boot my computer something freezes or crashes before I can login and I have to reboot.

  • Ugly text rendering. Screenshot_20211021_115613

If any of these aren’t known bugs, I’d be happy to help troubleshoot them, but I’d need some more guidance on how to get logs/debug info.

I love KDE and Plasma. Back in the '00s I was even a KDE developer. I was so excited to try this release out, I’ve been pining for a KDE workstation for years, I think Plasma is a far better for “getting things done”. But yikes, some of these bugs are dealbreakers. My workstation has to be rock solid and dependable (hence why I’m running an ostree based system). Anyways I’ll keep toughing it out for a month or so, maybe 5.23 will bring some fixes.

General known Wayland bugs are in Plasma/Wayland Showstoppers - KDE Community Wiki.

Thanks @siosm for all the work to make Kinoite a reality!

Do you have any suggestions on how I can trouble shoot some of these hangs/crashes? Where are the log files? Are there logging knobs I can turn?

1 Like

I am experiencing something very similar to this as well. But for me, the entire System Settings application crashes and exits when I press Apply. It happens very often, but not always, so it’s hard to tell what might be triggering it. I can get it to occur 100% of the time when I change Workspace Behavior > Screen Edges > change any hot corner action > click Apply. Settings crashes and triggers DrKonqi.

I can’t reproduce it in a new VM environment with Kinoite 35. So it’s something to do with my setup in particular, I haven’t been able to trace it though. Thankfully the settings do apply themselves before crashing out, so I’m still able to make settings changes; it’s just annoying.

1 Like

For the ugly fonts, you’re probably missing some fonts. Otherwise I don’t have any specific recommendations and you should probably look at upstream KDE debugging guides or report the bug upstream. We are close to upstream and things should improve with the 5.23 release that is coming soon after the 35 release.

1 Like

I was able to reproduce the “pressing apply in system settings causes entire system to hang” bug in a fresh bare-metal install of Kinoite. I’m running a Dell XPS 15 9560 from ~2017 with the nouveau driver.