Logitech trackball config not working on F32 beta?

I did try to edit /etc/X11/xorg.conf in order to make trackball act as mousewheel. But the trick does not work. I do use Logitech Marble Mouse - ArchWiki as a guide. Did something change in Gnome or in Fedora that makes this not work?

Did you double check that you’re running X11?

  1. Open your preferred terminal
  2. echo “$XDG_SESSION_TYPE”
    It will say wayland if you’re not running X11.
    If it’s running wayland try,


Thank you for your answer.
echo should not have a Capital.
And the gsettings set org.gnome.desktop.peripherals.trackball scroll-wheel-emulation-button <button_id>
should be done as root
sudo gsettings set org.gnome.desktop.peripherals.trackball scroll-wheel-emulation-button <button_id>

Problems solved thanks again.

1 Like

But after the latest update no scrolling whatsoever. So I did install dconf-editor and edit org / gnome/ desktop/peripherals/trackball with that editor.
That did the trick.
Thank you

But after restart of computer it does not work again.
My Guess is that https://bugzilla.redhat.com/show_bug.cgi?id=1650051 is the cause??
After restart change settings in dconf org.gnome.desktop.peripherals.trackball Custom value 8 . 9 and back again.
Unplug marble mouse and plugin again.

When it stops working does it reset the settings value or is it something else?

If you haven’t already, can you double check if the same happens if you do gsettings set org.gnome.desktop.peripherals.trackball scroll-wheel-emulation-button <button_id>
as the user, log out and log back in. Than reboot and see if it sticks

You could try setting a default value. As referenced here and here

Providing the below as an example
Create a file under /etc/dconf/db/local.d
01-mousewheel with the following contents

# GSettings key names and their corresponding values

afterwards do sudo dconf update.

If it’s limited to firefox there’s a workaround here


On new boot, settings in dconf are the same as yesterday. When I do disconnect mouse and reconnect mouse all works fine. (Plug, unplug). There should be a solution i Guess???
gsettings set org.gnome.desktop.peripherals.trackball scroll-wheel-emulation-button <button_id> do you mean that as a commandline command? Because that will not work.
I do try the /etc/dconf/db … file.
After reboot same situation, mouse only works with scroll aftet unplug/plugin.

Command line, yes. That should work without being root. I’m kind of at a loss for that.
From a terminal can you do:
gsettings get org.gnome.desktop.peripherals.trackball scroll-wheel-emulation-button

Before it works and then after?


Helps, but, but, I have to every boot to unplug my marble mouse and plug it in again to make it scroll.

Now (after update??) the trackball does its work. Thanks,
problem solved,

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.