Logins fail after update on Fedora 32


I did an update today (July 30th, 2020) and as soon as I logged out of my GNOME session in Fedora 32, I could no longer log back in (no reboot involved). I then typed CTRL-F2 to get to a console terminal and tried to log in. The login was successful but it immediately logged me back out. I also tried this with the root account with the same results.

Rebooting the computer didn’t make any difference. I believe the problem was with some very recent update since I tend to look for updates almost daily.

Booting to a Fedora 32 Live USB drive, I could see the logins as root and there were no obvious issues in the journalctl history (used journalctl --file to look at the journal file on the broken Fedora 32 installation). Pretty weird. :frowning:

Anyone else seeing similar problems after today’s package updates?

Looking at the dnf log on the drive with the broken version of Fedora 32, it looks like the following packages were updated:


Try this way:

You can also try to log in as a new user with default profile.

Good suggestions. When I was first trying to debug the problem, I thought I was something with X, Wayland, or a the desktop environment, which is often can be the problem. I also have KDE Plasma installed and I was using it at the time that the problem showed itself, so I tried to switch back to GNOME 3 and GNOME 3 Xorg without any difference.

In my case, though, even logging into the virtual terminal console (e.g., Ctrl-F2) fails to lead to a persisting login session. In working with the Fedora developers, they are suggesting that there might be something with systemd that is causing this. They had me update to the latest systemd packages, though, and that didn’t resolve the issue. The bug report is available at: https://bugzilla.redhat.com/show_bug.cgi?id=1862302 , for those that are interested in the details.

Thanks for the suggestions!

1 Like

I was able to track down the problem. Basically, I installed an RPM from my organization and it looks like it created a script in /etc/profile.d that was failing to run properly, which caused logins to fail. After using a Fedora Live USB device to uninstall the package (since normal logins weren’t working at all) and rebooting, I was able to login as usual.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.