Login screen is telling me my password is incorrect

After years of wanting to switch to Linux, I finally made the step up to doing so recently. After playing with Ubuntu years back with a live cd, I recently have the opportunity to upgrade my laptop and instead of just partitioning a single drive to Windows and Linux, I installed a second NVME drive and assigns the first drive as windows and then the second one as fedora. Upgraded my RAM to the max and upgraded my battery and life was great…

Knowing that this is going to be a massive learning experience, I’ve been trying to take it with a grain of salt and step by step. I am in no means a power user but I do have a good understanding of how windows runs and I’m trying to learn Linux so but be it as I may. I am a complete noob so please for lack of better terms explain it like I’m five. I still don’t understand running shell or basically everything I read about Linux just confuses the hell out of me. Anyways…

My first issue came up a week ago after I shut my computer down from updating windows and later that day went to go log into fedora and did so successfully but the internet wasn’t working at all. I was able to finally figure out that windows fast boot was interfering and found a way to disable that…

Well, a couple days ago I decided to try and make plasma KDE. I think it’s called look a little nicer and so I switched the appearance to a darker theme and I found a login screen that looked really cool and finally got that installed through discovery I think? And for a little back info when I installed Fedora I set it up to be encrypted and then my username has a password. So today when I went to go log in I got thru the encrypted Password just fine. And then it loaded this new login screen that I got from the discovery app I think? And it lists my username and I went to go enter my password which is six digits long and all numbers and of course the numlock didn’t activate it which I originally was trying to fix when I started the whole finding a new login screen. So I activated numblock and entered my six digit password which is all numbers and is correct as it’s the same one I’ve been using on my Windows for years and it’s telling me it’s incorrect.

It is not incorrect. I know for a fact it’s correct. I found some topic on here that said something about a broken keyboard. My keyboard works completely fine. I’ve unchecked or checked the view password box and verified. It’s the same set of digits and I can log into Windows just fine and type just fine…

The only somewhat relevant answers I found are saying something about launching a shell and entering Sudo and all this stuff. I still don’t understand and I’m pretty sure don’t apply to me.
Can someone please tell me wtf is going on, and help me get back into my laptop,

I’m sorry to bother anyone but I’m really trying to learn here dispite my dyslexia and memory issues I just can’t seem to grasp things like I used to, but I’m trying

I have a bunch of photos and documents in there and I really don’t want to lose them having to re install the os again. Any help would be appreciated, and in sorry in advance if I have no idea what the hell your talking about as I feel my answers are going to be a lot of “what’s that, how do I do that, I have no idea what you mean?”. So please be gentle in trying. Thank you, I appreciate it

One quick thing to check - do you have same keyboard layout now as it was set during installation ? I had similar issues myself because I used one layout during installation and another for post-install login. It took time for me to notice the difference and then I switched to proper layout.


Are you able to login using (at the login screen after encrypted password is entered) press and hold ctrl and alt keys then press F3 will get a login terminal. If you can login there, help will be easier for sure.


Keyboard hasent changed as far as I’m aware.

I Did the control alt f3 thing and put in my info first time it says it’s incorrect, (guessing due to capitalization), second time I got a dollar sign? Tried to type in login and other stuff hoping it would do something… but Did this mean it logged in?

It didn’t get a login incorrect message this time? If it worked I have no idea what to do now
Here is what I am seeing, don’t know what to do now or how to further fix this.

The dollar sign is the user prompt so yes you are logged in at that point.
So you’re running Fedora 37 I see. So you should run the following command in this login screen …

fpaste --sysinfo --printonly. This will give a long printout to the screen about information of your install and setup that you can paste here to further diagnostics. Don’t worry, it is human readable and does not include personal info at all, just system information.

Also, a word about encryption if it wasn’t clear when you were asked if you wanted it install time, it is LUKS encryption of your physical media (Hard Drive) that is unlocking it to be used. So this password would only be entered during the boot process then never again until next boot. This is not really connected to your user account or password, which you need to complete login. When you say you found a “login screen” you liked, what was it in particular you were referring to?

A ton of info (obviously) just flashes, more than I’m sure I can copy if I could even figure out how to scroll back to view it all., This is what I see now

Yeah I was hoping for a copy paste so I could see the whole printout, this unfortunately will not help as a pic. Can you do that?

Yeah what @jn64 is saying is likely best. Paste the link here then and we can progress.

You can temporarily disable the password to make troubleshooting easier:

sudo passwd -d ${USER}

Or change the password to a simple 1 digit to minimize keyboard/layout related issues:

sudo passwd -f ${USER}

Are you saying the encrypted login is different from the user system login? If so I understand that, that it’s meant to unlock the drive and open it for the user and system. And yes I have two different passwords, one for the disk encryption (which that lusk or whatever type encryption it uses, is that good? Or is there a better one or a way to use my yubikey?)

Anyways, I have the password for the encryption screen and then the login screen and they are two separate passwords

Before making this post I did try just using the numrow to enter the password (again it’s right, if the manual login Ctrl alt f3 is working)

I have no way to copy and paste, I’m not able to login (past this screen aforementioned) and can’t reboot to the windows drive and login there nor transfer text, and I tried the fpaste sysinfo sans print only and it’s saying temporarily failure in name resolution.,. Ctrl alt f1 is just giving me a flashing cursor

Removed password but still stuck at this screen or not knowing how to login or launch the gui/browser whatever you wish to call it.

You do the same key press [ctrl] [alt] [F1] will give the graphical login screen. Where you should now be able to login as your user with no password though.

Right, but I’m not getting that, just a flashing cursor

Or if I do the combo plus F3 it goes back to that login terminal

Okay so in the command line terminal where you can type systemctl reboot then proceed like normal for login.

Back to square one… it’s saying login failed when trying to login, can’t just hit enter despite I thought we just deleted the password. But typed in password and that’s what I got again

I also just changed the password to something all alpha based no numbers, with the same results. Can’t login at gui, Ctrl alt f1 is just a flashing cursor screen ect

1 Like

I’m going to let one person help you on this so to reduce confusion for you okay? I think @vgaetera is probably replying now. I’ll keep watch though okay?

Maybe it’s just a misinterpretation of the real problem?
I had a video driver related issue resulting in DM unable to start the DE session and couldn’t get past the login screen with no graphical error message.
The exact behavior likely depends on a specific DM, but I only have experience with GDM.
Analyzing the DM and session logs should help find the root of the issue.