LG Gram 2023 and alsa-sof-firmware sound issues

I’v got a new LG Gram 2023 and would like to use it with my favorite Linux Fedora 38. There is an issues that sound card is working only via headphones, HDMI and Bluetooth but not via internal speakers. I did some research and have seen that this issue still exists and a some people even give up selling this perfect laptop.

I also found that this issue was fixed in clearlinux:

They installed a new sof-bin v2.2.6

If I understand it correct it is alsa-sof-firmware that need to be updated. I installed v2.2.6 from rawhide repository:

sudo dnf install fedora-repos-rawhide -y
sudo dnf --disablerepo=* --enablerepo=rawhide update alsa-sof-firmware

The new alsa-sof-firmware v2.2.6 is there:

sudo dnf list alsa-sof-firmware
Installed Packages 
alsa-sof-firmware.noarch                                        2.2.6-1.fc40                                         @rawhide

sof-audio-pci-intel-tgl driver is used

lspci -nnk | grep -A2 audio
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Device [8086:51ca] (rev 01)
        Subsystem: LG Electronics, Inc. Device [1854:048a]
        Kernel driver in use: sof-audio-pci-intel-tgl
        Kernel modules: snd_hda_intel, snd_sof_pci_intel_tgl
00:1f.4 SMBus [0c05]: Intel Corporation Alder Lake PCH-P SMBus Host Controller [8086:51a3] (rev 01)

But there is still no sound from internal speakers. How can I fix this issue?

I tried alsa-sof-firmware-2.2.6-1 but it did nothing. However… I found a post by a Galaxy Book Pro user that had used the method of running Windows in a QEMU VM and capturing the verbs. He then created a script (necessary-verbs.sh) with most likely a lot more than is needed, but - it worked! I finally got my 2023 Gram 16" (16Z90R-A) to produce sound through the speakers.

I haven’t tested many scenarios other than system sounds work as well as running some multimedia apps. (script is run at startup via systemd unit file).

[Unit]
Description=Run internal speaker fix script at startup
After=getty.target

[Service]
Type=simple
ExecStart=/usr/local/sbin/necessary-verbs.sh
TimeoutStartSec=0

[Install]
WantedBy=default.target
2 Likes

This looks like something others may find of use.

Would you please post the content of the /usr/local/sbin/necessary-verbs.sh file so others having similar issues may find the assistance as well. Linking the source where you found that fix would be useful as well.

Sorry for the reply vs edit, but I am a level nothing so I can’t edit my own post after a day.
As suggested, the source of the fix is here. I don’t see a way to upload the actual script file and I don’t want to post it because it’s 3870 lines long - sorry - it’s very prominent at the linked site.

2 Likes

Thanks for the link. Others may find it useful as we have seen several posts concerning audio issues and speakers not working recently.
Please mark the post that shows the answer as the solution if you wish.

Thanks a lot!

The only problem I noticed is that the balance is about 20% more on the right side and needs to be rebalanced manually.

Hi, the solution above, also described in more detail here [SOLVED] Fixing ALC298 audio (no sound from speakers) worked on my LG gram laptop under Fedora 38. Probably would also work for other computers with a Realtek ALC298 sound card.

Any idea why we have to configure the soundcard with the hda-verb commands and why does the card not work on Fedora 38 right out of the box ? Is there some bug report to be filed for this ? Have not tested under Fedora 39 or later, but 38 is currently supported and there is no reason why the card should not work, as there is a simple fix. Would it be because of the mentioned problems that the setup has to be run on the system again after some events ? But the card continued to work after warm reboot without requiring reconfiguration, so the solution should be quite robust.