Lenovo silent mouse 600 device does not appear

Hello everyone.

I just switched from Windows to Fedora. Although it is not the first time I use Linux, I found it impossible to solve this problem.

I currently have dualbot windows 11 & Fedora Linux 39 (Workstation Edition). I normally used a Bluetooth keyboard and mouse to work, which are Logitech K380 and Lenovo Silent Mouse 600 respectively, which have worked perfectly for me in Windows 10,11, Android. However, in this installation of Fedora, it has been IMPOSSIBLE for me to pair the mouse, in fact it does not even appear in the list of Bluetooth devices (I already checked that it was not a problem with the mouse, connecting it to other devices and using it without problem in the partition Windows). I have reinstalled the bluetooth drivers, searched for the mouse drivers on the internet (they do not appear), guides or similar problems in vlogs, and I have not been able to solve the problem. Please if anyone can help me I would appreciate it a thousand times.

Please paste the results of this command :

systemctl status bluetooth

bluetoothctl devices

Make sure you have the drivers installed :

sudo dnf list installed | grep bluez

use </> preformatted text please.

First command output:

systemctl status bluetooth
● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset>
    Drop-In: /usr/lib/systemd/system/service.d
             └─10-timeout-abort.conf
     Active: active (running) since Tue 2024-01-16 16:35:12 -05; 2min 18s ago
       Docs: man:bluetoothd(8)
   Main PID: 1012 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 18767)
     Memory: 2.6M
        CPU: 55ms
     CGroup: /system.slice/bluetooth.service
             └─1012 /usr/libexec/bluetooth/bluetoothd

second:

bluetoothctl devices
Device F4:73:35:18:FB:B3 Keyboard K380

the last one:

bluez.x86_64                                         5.71-3.fc39                         @updates 
bluez-cups.x86_64                                    5.71-3.fc39                         @updates 
bluez-deprecated.x86_64                              5.71-3.fc39                         @updates 
bluez-libs.x86_64                                    5.71-3.fc39                         @updates 
bluez-obexd.x86_64                                   5.71-3.fc39                         @updates 

Cool, cool. . .Let’s try to “re-pair” the device.

Also, are you on Fedora Gnome Workstation? If so Check settings :


Yes, I have already tried everything, in fact a probe that will work with some other devices in Bluetooth 1 and 2 (it does) but it definitely does not appear when I search

Ok, If you hold down the pair button on the mouse, for like 10-20 seconds it does not show up?

Maybe try something else, Disconnect the keyboard from bluetooth, the try to pair the mouse see if it connects.

I might have other solutions here after with logs, maybe there is something more we can do.

Yes, I actually tried both solutions, but it didn’t work.
The problem I was thinking about initially is… on a website I read the Lenovo mouse feature for Windows only, but at this moment I tried to connect to my Android phone and it did.

I really don’t understand what the problem is. Android is practically a Linux system, that changes my first theory.

Before that I thought it was that I needed a driver signed by Microsoft to connect, but when I connected it to Android it also damaged this theory.

Lets try this :

bluetoothctl

that opens the bluetooth CLI :

power on
agent on
default-agent
scan on

After scanning, you should see your mouse in the list. Pair with it using :

pair XX:XX:XX:XX:XX:XX

There’s more to do, but let’s see what this returns. . .

Okey, let do this.

luetoothctl
Agent registeredct to bluetoothd...[bluetooth]#         Keyboard K380
[Keyboard K380]# hci0 new_settings: powered bondable ssp br/edr le secure-conn cis-central cis-peripheral 
[Keyboard K380]# [CHG] Controller E8:FB:1C:50:58:0A Pairable: yes
[Keyboard K380]# power on
[Keyboard K380]# Changing power on succeeded
[Keyboard K380]# agent on
Agent is already registered
[Keyboard K380]# default-agent
[Keyboard K380]# Default agent request successful
[Keyboard K380]# scan on
[Keyboard K380]# SetDiscoveryFilter success
[Keyboard K380]# Discovery started
[Keyboard K380]# [CHG] Controller E8:FB:1C:50:58:0A Discovering: yes
[Keyboard K380]# 

i’m start mouse paring. three times (5 minutes)

Discovery started
[Keyboard K380]# [CHG] Controller E8:FB:1C:50:58:0A Discovering: yes
[Keyboard K380]# [NEW] Device D8:F8:83:2E:F4:DB LAPTOP-C2TRI8JH
[Keyboard K380]# [DEL] Device D8:F8:83:2E:F4:DB LAPTOP-C2TRI8JH
[Keyboard K380]# [NEW] Device D8:F8:83:2E:F4:DB LAPTOP-C2TRI8JH
[Keyboard K380]# [DEL] Device D8:F8:83:2E:F4:DB LAPTOP-C2TRI8JH
[Keyboard K380]# 

My latest belief is that the Lenovo mouse has a low frequency, making it unidentifiable

That’s great info, but still no mouse. I must ask this question. . . “Is the battery good right now?” Just in case it’s low or dead.

Also, dmesg | grep Bluetooth and journalctl -xe | grep -i blue To see if any issues show up?

dmesg | grep Bluetooth
[    7.393284] Bluetooth: Core ver 2.22
[    7.393309] Bluetooth: HCI device and connection manager initialized
[    7.393312] Bluetooth: HCI socket layer initialized
[    7.393314] Bluetooth: L2CAP socket layer initialized
[    7.393319] Bluetooth: SCO socket layer initialized
[    7.562476] Bluetooth: hci0: HW/SW Version: 0x008a008a, Build Time: 20231109191416
[    7.701901] Bluetooth: hci0: Device setup in 178956 usecs
[    7.701906] Bluetooth: hci0: HCI Enhanced Setup Synchronous Connection command is advertised, but not supported.
[    7.985301] Bluetooth: hci0: AOSP extensions version v0.96
[    7.985305] Bluetooth: hci0: AOSP quality report is not supported
[    8.224650] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    8.224653] Bluetooth: BNEP filters: protocol multicast
[    8.224657] Bluetooth: BNEP socket layer initialized
[    8.225848] Bluetooth: MGMT ver 1.22
[   15.943143] Bluetooth: RFCOMM TTY layer initialized
[   15.943153] Bluetooth: RFCOMM socket layer initialized
[   15.943157] Bluetooth: RFCOMM ver 1.11
[   53.879830] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[   53.879839] Bluetooth: HIDP socket layer initialized
thechieft@fedora-fedora:~$ journalctl -xe | grep -i blue
ene 16 16:36:14 192.168.0.9 systemd[1328]: Stopped target bluetooth.target - Bluetooth.
ene 16 16:37:18 192.168.0.9 systemd[2016]: Starting obex.service - Bluetooth OBEX service...
ene 16 16:37:18 192.168.0.9 systemd[2016]: Started obex.service - Bluetooth OBEX service.
ene 16 17:05:46 fedora-fedora systemd[2016]: Started app-gnome-gnome\x2dbluetooth\x2dpanel-10033.scope - Application launched by gnome-shell.
                                                       Module libgnome-bluetooth-ui-3.0.so.13 from rpm gnome-bluetooth-42.7-1.fc39.x86_64

Yes the battery is good, i think it has more than 30%

Very strange. . . It doesn’t even recognize it.

I’m out of ideas for now. There are some more experienced people here that can help. I’ll keep looking for you to see if I come up with anything else.

1 Like

Thank you, seriously. I’m still trying to solve the problem, it’s not a cheap mouse to have these connectivity errors.

I tried a Miniso mouse and it works, of course it’s not Bluetooth at all, but it recognizes USB Bluetooth.

Is it possible that a mouse only works for certain operating systems?