Lenovo IdeaPad 5 14IIL05 not work touchpad

Hello. I have trouble with working touchpad on Lenovo IdeaPad 5 14IIL05.
First i install OS without UEFI - touchpad didn’t work
After i reinstall OS via UEFI - once touchpad work in live session
After complete install OS, touchpad work only on 5.6.6 (stock) kernel. Next i update BIOS and touchpad stopped working on any kernel. Downgrade BIOS on previous version not solved problem.

In Windows 10 this device detected:

As i inderstand this I2C HID device.
dmesg | grep i2c:
[ 1.434574] platform i2c_designware.0: failed to claim resource 0: [mem 0x00000000-0x000001ff]

Also when my laptop wake up after waiting mod. May be show logo disabled/enabled touchpad. But i not have Fn-key for this action.

How enabled this touchpad?

Is the driver for the touchpad installed?

You can also try this method:

The xinput return:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ xwayland-pointer:17 id=6 [slave pointer (2)]
⎜ ↳ xwayland-relative-pointer:17 id=7 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ xwayland-keyboard:17 id=8 [slave keyboard (3)]

Something incomprehensible and similar to a touchpad is
I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name=“Intel HID events”
P: Phys=
S: Sysfs=/devices/platform/INT33D5:00/input/input5
U: Uniq=
H: Handlers=kbd event5 rfkill
B: EV=13
B: KEY=81000300000000 5000004000 1e294000000020 0
B: MSC=10

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name=“Intel HID 5 button array”
P: Phys=
S: Sysfs=/devices/platform/INT33D5:00/input/input6
U: Uniq=
H: Handlers=kbd event6
B: EV=13
B: KEY=2000000000000 0 0 0 0 1000000000000 0 201c000000000000 0
B: MSC=10

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name=“Ideapad extra buttons”
P: Phys=ideapad/input0
S: Sysfs=/devices/pci0000:00/0000:00:1f.0/PNP0C09:00/VPC2004:00/input/input7
U: Uniq=
H: Handlers=kbd event7 rfkill
B: EV=13
B: KEY=81000800100c03 4400000000300000 0 2
B: MSC=10

There is no touchpad device as such. But the same results were obtained when it was working.

Tell me please, how downgrade libxinput?

Go into dnfdragora and search in the not-installed category for libinput, and download the version 1.15.4. It should then ask you that it will downgrade the current version, and do so.

Thank, but i try via terminal:
sudo dnf downgrade libinput

Current version is 1.15.4, but touchpad not work :-(. Load system in previous kernel - nothing.

After downgrade libinput i observe, sometimes after wake up from wating mode - system is freezing. I close laptop on couple of seconds then opened and freeze goes away.
Anybody have solution how make the touchpad work?

Thank you [vmike] :+1:

Sorry, but i not understand what driver is nedded.
I have libinput, but i not installed synaptics or elan drives becouse i not fully understand what the device i have.
I understand is I2C HID devices. libi2c i installed.

This is a well-lnown bug with the IdeaPad 5 in the Linux kernel. For more information see:

…and many other discussions.

It is supposed to be fixed in v5.9 of the Linux kernel, apparently.

I hope this fixed. In parallel i opened on redhat bugzilla this issue:

Thanks, but…

You are not authorized to access bug #1871793.

Hmm, why is this a private bug?

:joy: Seems it’s my mistake. When i create bug-report in field Public selected fedora_contrib_privat and didn’t pay attention on private.

It’s still private, so can’t you make it public again?

I’m afraid I don’t have rights to change groups. At the same time, there are 21 people in the mailing list.
I’ll try to request an opening.

It took a long time, but the problem was solved.
The solution turned out to be banal-reset the BIOS
or you can:
sudo grubby --update-kernel=ALL --args=“pci=nocrs”

Now bug report opened everyone: 1871793 – Not work touchpad on Lenovo IdeaPad 5 14IIL05

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.