Launching qBittorrent problem

OK, trying to launch qBittorrent gives the following error:

qbittorrent: error while loading shared libraries: /lib64/libtommath.so.1: file too short

It’s a fresh F31 install, KDE Plasma desktop, tried installing qBittorrent both from the GUI and command line, same error appears.

Any help will be highly appreciated…

I think it’s a bug, maybe it should be reported , Until the problem is solved try something else or try qBittorrent from flatpak/flathub .

1 Like

OK, I’ll try the flatpak/flathub option, will let you know the results…

1 Like

Yeah, the flatpak/flathub option works…

UPDATE:

Quarantine sucks big time so I decided to dig deep into this and found the following solution:

I removed the flatpak/flathub install, tried reinstalling from the command line and the problem was still there. I used Google to find where those errors belong and from there on tried the easy solutions. Now it works fine.

dnf reinstall libttommath

That solved the libtommath error. Next was the libboost_chrono.so error.

dnf reinstall boost-chrono

Solved it. Next up was the libboost_random.so error.

dnf reinstall boost-random

That fixed it. I guess something went wrong with the original install.
Anyway. qBittorrent works fine now.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.