Latest update breaks wifi/ethernet (iwlwifi / r8169)

New to the forum here, not really new to Fedora. However, I do need some help. This week, some update came through and has caused my wifi/ethernet to become unusable. I get a message saying no card installed. I checked by running from liveusb, and my network card is detected and works. I plugged in a usb wifi dongle, and F31 recognizes it, however it refuses to let me connect to my home wifi. It just keeps asking for the password for the wifi.
I wiped my drive and reinstalled F31, and everything works fine until I run a DNF update from the command line. It updates 1300 packages. I reboot, and boom, Im back in the same situation.
I havent a clue to what is causing this. Any ideas would be appreciated. Thanks a million :pray:

Ethernet is a realtek rtl8111/8168/8411 PCI Express gigabet ethernet controller
wifi is Intel 3168ngw (stone peak)

In GRUB there should be an older kernel (wifi may work with the older version).  I’d forget how to get there, possibly by pressing Esc during boot (or Shift?)

Pin or retain a kernel version (or increase the number of kernels retained)
  – to protect a working version.

Thanks, I tried that. It didnt help. Nothing was working even in the old kernel. Im at a loss.

Old, but…
An workaround, in case it is a Network Manager’s bug:
“I went into the Network Manager applet and selected this network, and then the Security tab.  To my surprise, there was no password stored on this tab.  I entered the password here, saved and closed the network details, and went in to edit them again; the password was still saved.  And now I can connect to that network with no problems.”

The problem is I dont get that. It says there is a problem with the network controller, and then settings closes, and when I open it back up, the wifi section in settings is gone. :man_shrugging:

Try wicd (as lspci sees the card)?

Ill try that. thanks

According to Arch Wiki, some of the Intel’s WiFi card’s drivers require a firmware from linux-firmware package (lspci -v shows “Kernel driver in use:”).  Maybe a downgrade of linux-firmware will help, if this isn’t a N. Manager issue?

wicd didnt work. The lspci -v shows both my ehternet and wifi controller. However bother controllers say access denied under capabilities, and it says kernel driver in use with the name of the driver on ethernet as r8169 and wifi driver iwlwifi.

Please see the “Iwlwifi driver still broken in kernel 5-4.8-200” topic.

There was some patch mentioned.  No idea about the etherneth, though.

PSInspired by this topic (askubuntu):
What is a network controller in this computer?  BTW, the error was about it not working…

OH thanks for that topic! Ill take a look now.

The network controller was a Realtek device. I only use the wifi connection or Id have to run a cable clear across the house… and Im not crawling through the attic to do that :upside_down_face:

and thank you so much for taking the time to help.

Well I tried the nm-connection-editor mentioned in another post, did a submask calculator on my other computer, and yet it still doesnt work. So, who knows. Unfortunately, Im not a networking guru. From what I was reading this has been an issue in F31 since its testing phase.

What about this short patch that mentioned in this post?  @dec said that this helps.

I saw that post, but unfortunately, I dont have a clue to what it is talking about and what its trying to accomplish. Is it some type of kernel edit?

There was some change maded in Kernel’s source code.  This change possibly breaks the cards governed by iwlwifi driver.  The post linked above contains the link to the patch file that reverts this change.

@dec’ve had downloaded the sources, applied the patch, compiled the Kernel , and posted that their WiFi is working now.

I think I ran into the same issue a few days ago. I login, and can sometimes use the wifi for a few seconds to minutes before it dies. When it dies, everything hangs for a second or two. Here’s the relevant bit of lspci -k:

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter (rev ff)
	Kernel driver in use: rtw_pci
	Kernel modules: rtwpci

Well, I dont know what the issue was,but I waited about 5 days from when I first dated this post, I ran a full update, and they fixed the bug.

So here is a big hats off and thank you to the Fedora developers who take care of stuff like this.
Thanks for fixing the issue!!!

1 Like

A heads-up for future cases before reinstalling the OS: dnf has an undo function.

1 Like

Thanks. Never knew that. But I was unsure what package updated caused the wifi issue. I assume it could have been the kernel. But Im not 100% sure.
I actually dont mind wiping the drive and starting over. I dont really keep much on it anyway. Its just a home desktop to screw around on when Im bored.