Laptop screen black after nVidia drivers installation

I have recently installed Fedora 32 on my machine -HP Zbook x360- with nouveau drivers working fine on the laptop screen and an external monitor.

As I want to use some python libraries that need to run from the GPU, it was recomended to install the most recent nVidia drivers. After some cumbersome hours (with some rpm -e kernel in the meanwhile as things started to fail – I am almost new to both Linux and Fedora :sweat_smile:), I got nvidia drivers installed and working on the laptop thanks to Howto/NVIDIA - RPM Fusion.

However, the laptop screen is black, not showing anything (although it shows the grub and the previous kernel still works fine with nouveau drivers). Fedora only appears in the second monitor (connected by an HDMI) as if it were the “main” screen.

With the old nouveau drivers, xrandr outputs the following:

(base) [callejonm@localhost ~]$ xrandr  
    Screen 0: minimum 16 x 16, current 3840 x 1080, maximum 32767 x 32767
    XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
        1920x1080     59.96*+
    XWAYLAND1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 510mm x 290mm
    1920x1080     59.96*+
    1440x1080     59.99  

With the new nVidia drivers it outputs the following:

(base) [callejonm@localhost ~]$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080     60.00*+  59.94    50.00  
   1680x1050     59.95  
   1600x1200     60.00  
   1440x900      59.89  
   1280x1024     60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

I assume it has something to do with DP-0 and DP-1 being disconnected…

In the meanwhile, I got to configure it so the monitor was the main screen but the laptop screen was still detected. Tried to change it with nvidia-settings , reboot, and it came back to this state again. I don’t know what to do at all, as I have already tried to modify xorg.config, followed this post External monitor not working on fedora 31 - #7 by xtym, which almost solved the issue.

As I don’t really know what I am doing, I would really appreciate if someone could help me with this issue.

Thank you so much beforehand!

Just in case someone tops with the same issue as me, it was fixed!


  1. Remove nvidia drivers and switch back to nouveau. Delete the libraries completely just in case.
  2. Autoinstaller by t0xic0der (THANK YOU SO MUCH IT WORKS PERFECT :pray: :pray:!!!)
  3. After that, the HDMI monitor was not detected. To solve it, I just followed Step 9 onward from and reboot (thanks again @t0xic0der) .

It works perfect now. Only (minor) issue being that if booted with the HDMI connected, the external monitor is the primary one and to the left of the screen instead of the right… Anyway, it’s not a problem, as I can boot without the HDMI.

1 Like

You just made my day @callejonm.

I am glad to know that the tool and documentation I wrote were able to help you.

Feel free to give stars if you found it helpful. :smile:

For future reference, You might want to head to the official quick docs here that @FranciscoD helped writing - It would be kept updated as soon as any simpler and better way of doing things come up. (You might find a 403 Forbidden error due to the recent datacenter move, but don’t worry - it will be back in no time.

I believe that is configurable in the GNOME settings. You just need to pick the display which would be showing you the panel (primary display - I keep it as my laptop screen) and the one without a panel display (the external monitor).

Stars given! Actually, now that I solved it I can read the docs, but 403 error appeared when installing the drivers :sweat_smile: Relieving to now it doesn’t have to do with my computer.

You are right! It is nicely configured now.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.