Laptop freezes when trying to access bios while booting from usb

I use an Acer Spin 5 Laptop with Fedora Silverblue installed, but I tried installing another os using a ventoy usb (which has previously worked on my machine). Since the stick could reach the installer in a vm I assume it works too.
When I normally boot my machine I can easily reach the bios. When I insert the boot usb my laptop still boots to fedora, but when I try accessing the bios it freezes on the manufacturer’s logo. I tried resetting the bios but that causes my laptop to freeze as well.
Previously, I had a similar problem that could be solved by deleting a partition displayed in the boot order left by my previous os which apparently hasn’t been completely overwritten. But since my bios only displays one option in the boot order (that is marked as second and doesn’t display a descriptive text) this could probably be ruled out.
Is there any way to fix this? Is this even caused by the os?

There is usually a bios boot menu (F10, F11, or F12 depending upon the machine and the bios version) that can be used to select the usb device for booting.

If you are able to display the grub boot menu there is usually an option there to access the bios. You may need to hold down the shift key while booting to display a hidden grub menu.

Setting the USB as first for booting may be prevented in the bios but the bios boot menu should display it.