Laptop and fedora

In the past I’ve had good luck running Fedora Workstation on Lenovo machines. both laptops and desktops. Recently I’ve started a project where I wanted a used laptop I could dedicate to the project. I didn’t want to spend much money on it because the project may come to nothing. I thought I was lucky when I was offered a Lenovo model 100s laptop that still ran windows fine for free. I accepted and set about loading F35. After I set the machine to boot from USB, I booted to a USB install. I was surprised that the machine only had 32Gb of storage but I knew that would be enough for the install and my application. I set the install to recover all the storage space and ran it. The install ran fine with no indications of problems. When I got to the complete the install part (name, password, etc) I quit anaconda and did a restart. The machine would not boot. I found out the the Windows boot loader lives in protected storage and I couldn’t find anyway to delete it. This machine had an empty M.2 socket so I plugged in a 256 Gb SSD and looked in the BIOS/UEFI to see if I could enable it. No luck. I knew it was a long shot, but I rebooted to the USB installer to see if anaconda could see the SSD; it could not see it. I removed my SSD and summarily delivered the laptop to recycling. Two things came out of this experience:

First: Is their a list somewhere where I can see what Lenovo models can be loaded with a new OS? I know they offer new models with Fedora loaded, but I won’t be spending that much money on this project.

Second: A suggestion for the anaconda team. It would be nice if anaconda could detect if a machine had a permanent boot loader or other impediment and provide a warning or refuse to proceed.

Have you tried changing your bootloader from windows bootloader to grub bootlooter i hope you have can what do you mean by permanent bootloader because as far as i know lenovo is first choice when business use linux. So more info required why your 256gb ssd didn’t recognized by your system. What kind of ssd you put because mostly m.2 ssd or nvme because it is not cross supported.
And if it is a normal ssd then sometimes changing sata cable is a solution.
If you want you can provide them feedback

There is a lot to read before making a request on Bugzilla:

You might check also the Topics about secure boot.
Did you give a try at F34 ? Generally with older hardware you can test the older OS version first.

I don’t think secure boot is an issue as it was a older device and secure boot was introduced in the processor dies it was 8th gen intel and amd 2nd gen ryzen maybe.

The BIOS/UEFI didn’t have settings for secure boot ; so I doubt the laptop had secure boot.

What I meant by permanent boot loader is that the only storage in the laptop is soldered on the board. There is no way to delete the boot loader or disable it either on the board or in the BIOS/UEFI. There was a m.2 socket which I tried to use with an NVME SSD I had on hand. Later I found out the reason it wasn’t detected is the laptop is set up for mSATA. Since I have no other use for an mSATA SSD I didn’t spend money on one to try it. Besides I think the real issue was the permanent windows boot loader.

I already disposed of the laptop. Since the windows installation was deleted when I tried to install Fedora and Fedora can’t boot due to the permanent windows boot loader I sent the laptop for recycling.

I still need to find a low cost used laptop for my project. So what I am looking for at this point is a list or some experience advice on what old model Lenovo laptops can be loaded with Fedora without running into this problem.

Yes as i have told old devices don’t have that feature baked into the chipset so bios don’t have that but fastboot is a thing if you have find that.because most brands make drive in such a way that fast boot always gives your error even if you have install windows 7 and for linux it will straight into the windows if windows note present it will show a error.

You don’t need to disable just delete everything in the drive and it will take care of that asfar as i know.

I don’t know is this a thing real

We just discussed this topic: :slight_smile:


I’d look for this general guide here in the release note based on CPU architecture/RAM/disk space, but it does not have to be specific to models.

Coincidentally, I’m using hand-me-down Lenovo laptops side by side. For your info, both have 4GB RAM with no separate GPU; one running Silverblue on GNOME DE (64GB eMMC as the boot disk; Intel Celeron N4000 CPU @ 1.1GHz), the other i3 spin without DE (13 years old Intel Core i7-3612QM 2.1GHz). In the latest standard, it is the under-powered machine, but both are running stable. If I want to run VM for test driving test ISO, I use a different laptop with 8GB RAM.

I used Fedora Media Writer to reclaim all disk spaces (I don’t recall I removed other OS partitions when installing Fedora Linux). I chose the automatic partition option, not the manual configuration. I expected the installation to be simple and it worked.

Found same problem here, please read all the first answer (answered by the same user who create the question).

Look like to be able too boot, he change the boot file to bootia32.efi and if we read his lspci -v result there a part:

00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0f)
      Subsystem: Lenovo Device 390c
      Flags: bus master, fast devsel, latency 0, IRQ 246
      Memory at 90700000 (32-bit, non-prefetchable) [size=1M]
      Memory at 90600000 (32-bit, non-prefetchable) [size=1M]
      Capabilities: <access denied>
      Kernel driver in use: mei_txe

Not sure, but look like the encryption controller only support for 32bit even though the system are support 64bit.

With default installation, Fedora Linux I believe will use shimx64.efi for 64bit system, but since Lenovo 100s use encryption that only support for 32bit, the shimx64.efi will failed.

There other *.efi files available under /boot/efi/EFI/fedora/ directories as bellow, but I’m not sure what will work:

sudo ls -l /boot/efi/EFI/fedora
total 12352
-rwx------. 1 root root     112 Feb  7 14:07 BOOTIA32.CSV
-rwx------. 1 root root     110 Feb  7 14:07 BOOTX64.CSV
-rwx------. 1 root root 1643784 Feb  7 14:07 gcdia32.efi
-rwx------. 1 root root 2602248 Feb  7 14:07 gcdx64.efi
-rwx------. 1 root root     143 Feb  7 14:16 grub.cfg
-rwx------. 1 root root 1643784 Feb  7 14:07 grubia32.efi
-rwx------. 1 root root 2602248 Feb  7 14:07 grubx64.efi
-rwx------. 1 root root  676040 Feb  7 14:07 mmia32.efi
-rwx------. 1 root root  850032 Feb  7 14:07 mmx64.efi
-rwx------. 1 root root  928592 Feb  7 14:07 shim.efi
-rwx------. 1 root root  740344 Feb  7 14:07 shimia32.efi
-rwx------. 1 root root  928592 Feb  7 14:07 shimx64.efi


If you believe your laptop run with UEFI and you can’t see the menu to disable the Secure Boot, big chances that your bios have menu that activate the support for Legacy Bios.

If the Lagacy Bios support/compatibility enabled, the secure boot option will not shown even though the current installed OS are running with UEFI.

For my laptop I need to disable the legacy bios support and use UEFI only. With that the secure boot option will shown.

Thanks, I appreciate all the advice. The reference to the linux hardware page was particularly helpful. Since I had already disposed of the 100S. I dicided to shop for a used T460. I found some rehab’ed ones at reasonable prices from a vendor I trust. So I think I will get one. The price is more than I want to spend for my initial project need incase the project fails, but I have since found an alternative use for it if the project fails. The T420 I bought rehab’ed a few years back is still running F35 just fine.

1 Like