Lag slow work in Fedora 33

Fedora 33, [x86_64, i7 8th, 32ram, 1TB SSD] cause lag on many apps, for example, geany, sublime, builder, gedit, etc.

I am writing as usual, and suddenly, the cursor stops, doesn’t blink, doesn’t react, but doesn’t crash.
To make it work again, I must press ctrl+s or switch windows with Alt+tab to make it react.

At the beginning I was only using sublimetext, I thought that I missed only sublimetext, but no, I changed to builder, then to gedit, and I have the same problem.


hi @ferb, can you please look at your logs to see if anything was noted there when these “hangs” happen?


Thanks, I had already checked previously, but found nothing about it.
I deleted all the previous log, and waited for it to happen again, but there is no information in the log files.

1 Like

Hrm, that’s a hard one then. Any chance of being able to observe system activity during the lag? Disc I/O processor usage?

I also experienced lags on geany and gedit.

I tried to do that, but the detail is, that exactly when I change the window, with alt-tab, or with the cursor, it reacts again.

In this case, i use sublime text for this example monitor status process, it’s normally

Right, so what’s the exact issue here? When you say “lag”, we think that you pressed a key and did not see the effect immediately. Is that correct? Or is it something else? Maybe try recording your screen for a bit so we can see exactly what the issue is. At the moment, the issue isn’t clear, and I have no ideas on how to debug this.

1 Like

Are you using Gnome: Wayland-session or X-Server? I experienced some times ago the same under Debian, but only when using the X-Session, with Wayland no issues. Over the time using Gnome X-Session the system (Debian) decelerate more and more.

Thanks for comment, I already tried both, the effect is the same.

Thanks, I’m going to record a video, and I’ll upload it as soon as I get it.

I upload the vídeo to GD, de second 14-18, occurred the problem, when i pressed alt-tab then react, and the minute 1.24-28 again.

I suspect this is caused by the NVIDIA driver. I have two computers. One of them has this issue while the other one does not. They use different NVIDIA GPUs.

Hello, but my computer not have nvidia GPU.


I observed the same lag in disparate applications like Geary, Eclipse or MySQL Workbench. I also tend to think that is some driver issue. By the way, I use the NVIDIA proprietary driver.


This is the only issue I have encountered since I updated to F33. The other aspects are pretty good.

I was doing tests over the weekend, I removed several packages, including gtk-murrine, which is a package for the window environment etc., and restarted the computer and started in wayland, in this test, I noticed that the problem stopped appearing. However, applications like virtualbox, vokoscreen, vlc, no longer work properly, screen recording is not possible, vlc screen capture function cannot be realized, virtual box no longer works with alt-tab keys inside the virtualized so.

XORG, then it may be causing the problem with the other applications. I will install kernel version 5.9.6, and see if that can solve the problem.

The other problems I found using WAYLAND, are that in applications like workbench, geany, gedit, sublime-text, libreoffice, the cursor disappears completely, but if I press the backspace key, or write something, it does, but the cursor is not seen.

+1 on both of my systems: one with an Nvidia GPU and the propriotary driver and my laptop with an Intel HD GPU.

I’d ask everyone to open new topics. Even if you’re seeing similar symptoms as this one, we don’t have enough data to say if it’s the same issue, so at the moment, it’s just making it harder to diagnose an already hard issue that @ferb is seeing.

Please open fresh topics, and provide the usual info: your hardware, software, graphics etc., and whether the issue is X or Wayland specific, DE specific, kernel version specific and so on.

1 Like

Thank you.

I think it’s just X’s problem, because I installed kernel version 5.9.6 on my fedora 33, x86_64, i7 8th. I logged in in wayland, and I didn’t have the problem of the slow lag, the only problem I had now, is that suddenly the cursor disappears, it still writes everything right, but you can’t see the cursor, to make it appear again, I must close the application and start it again.

In X mode, I no longer have the slow-lag so exaggerated, at least now, with the new kernel version, now it reacts after about 3 or 5 seconds, I no longer need to change windows to work again.