L2tp vpn issues on Fedora 36

Hi, I’ve switched to Fedora 36 and have issues with getting vpn through L2tp\ipsec working. Libreswan and strongswan packages are installed, but there is an error

“unable to load VPN connection editor”

when I’m trying to create one. Adding screenshots for reference. Please help to solve the issue.

1 Like

You mean NetworkManager-libreswan and NetworkManager-strongswan?

NetworkManager-l2tp is installed as well?

Yep, here is the proof @augenauf

and both of these menus showing the same error

Help anyone?

I also noticed the following bug which is connected to a Network Manager issue https://bugzilla.redhat.com/show_bug.cgi?id=2061693

It’s about ssh, not L2TP but anyway, is there any chance this will get fixed by the f36 release? Or maybe there is a workaround currently available?

I’ve switched to Fedora from Manjaro and I desperately need l2tp working for my work. Please help.

The bug report you link seems to be limited to ssh-based VPN, and it was decided that this bug would not block the release of f36 since ssh-based VPN is not very common.

I propose you file a new bug, specific to L2TP-VPN. In my L2TP-VPN should work before F36 is released, so that can be discussed, however you need to the file a bug first.

I can reproduce this bug for strongswan, however not for L2TP. Here’s what I tried.

1.) Installed F36 Workstation in a virtual machine from the current beta iso, then
2.) ran a full update (sudo dnf update --refresh)
3.) installed the relevant network manager plugins (sudo dnf install NetworkManager-l2tp NetworkManager-l2tp-gnome)

Packages installed with that command
Install strongswan-5.9.5-3.fc36.x86_64                 @fedora
Install tpm2-tools-5.2-2.fc36.x86_64                   @fedora
Install xl2tpd-1.3.16-4.fc36.x86_64                    @fedora
Install NetworkManager-l2tp-1.20.2-1.fc36.x86_64       @updates-testing
Install NetworkManager-l2tp-gnome-1.20.2-1.fc36.x86_64 @updates-testing


when I click on Layer 2 Tunneling Protocol (L2TP), I see the dialog to setup the connection:

So far, so good.

Is your system up to date??

If I install the required packages for strongswan-VPN I see the same bug as you do. Appears to be the same problem as in the ssh-VPN bug report

Reproducing the bug:
1.) sudo dnf install NetworkManager-strongswan NetworkManager-strongswan-gnome

Packages installed with that command
Install NetworkManager-strongswan-1.5.2-2.fc36.x86_64       @fedora
Install NetworkManager-strongswan-gnome-1.5.2-2.fc36.x86_64 @fedora
Install strongswan-charon-nm-5.9.5-3.fc36.x86_64            @fedora


Thank you for the response! I’ll try reinstalling the packages and trying again with l2tp only.

1 Like

I filed 2081321 – [NetworkManager-strongswan] Unable to load VPN connection editor for strongswan (GTK4 transition) because I think it’s worth the blocker discussion.

1 Like

Thank you!

So I uninstalled the packages NetworkManager-l2tp NetworkManager-l2tp-gnome, then restarted, ran a full update (the system was up to date btw) and installed the plugins again using sudo dnf install NetworkManager-l2tp NetworkManager-l2tp-gnome

tpm2-tools, xl2tpd, strongswan were already installed on the system. Nothing changed, still getting the error. Not sure where to look at(

related upstream issue to fix the NM- GTK4 problem: GTK 4 support for NetworkManager plug-in · Issue #961 · strongswan/strongswan · GitHub

1 Like