Kwin is broken after upgrading to Fedora 36

Hello everyone,

I upgraded my system to Fedora 36 (from Fedora 35) and encountered an issue. After system rebooted the windows and panel were broken, some parts don’t show completely such as window borders with buttons and system panel icons. The shortcut for switching windows (alt+tab) also doesn’t work.

I suspect this is somehow related to Wayland. I previously used X11. However, I changed it by editing /etc/sddm.conf file:


Still no success.

I will provide any input if needed.

Best regards,

Does this happen if you create a new user account, just to test?

1 Like

Hi Matthew,

Thanks for the reply.

Creating new account doesn’t change anything, so it is not related to my personal settings.

I’ve tried to debug the issue, it turns out the dual monitor produced it. If I disconnect the second monitor from my laptop during boot time, then reconnect it again after the system boots, it works well. But I cannot identify the root of the problem, have looked at the system logs journalctl -b, couldn’t see what causes it. I’d like to make it work without disconnecting on every boot.

This should not have been required.
You could have logged into wayland by selecting the gear icon at the lower right of the screen where you enter the password during login. Selecting ‘gnome’ there would give you the wayland screen and selecting ‘gnome on xorg’ would give you the xorg desktop.

1 Like

How are the two monitors connected?
Directly to the machine? Via a docking station? or ?

Is this a laptop or desktop?

Have you done sudo dnf upgrade --refresh since the version upgrade?

Hey Jeff,

Thank you for your input.

I have a laptop and one external monitor. The external monitor is connected to my laptop via the HDMI cable.

Yes, I have upgraded the system, followed the official system upgrade guide.

So now we need to know if you are using wayland or xorg?
We also need to know what you have for graphics. inxi -Fzxx will tell us that.

That setting controls SDDM’s display server, if you want it to run on wayland, execute sudo dnf swap sddm-x11 sddm-wayland-plasma

Switching your session to wayland is done with greeter, on default theme the switcher is on the left bottom side of login screen.

Not all multi-monitor wayland Kwin issues are already ironed out, so in general for wayland session it’s better to use newer packages, hence (in case of issues) consider upgrading to F37.

1 Like

I use X11, select it on login screen as you suggested. Here is the relevant part of the above command:

Kernel: 6.0.11-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-37.fc36 Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11
    dm: 1: GDM 2: SDDM note: stopped Distro: Fedora release 36 (Thirty Six)
  Device-1: Intel 3rd Gen Core processor Graphics vendor: ASUSTeK N56VZ
    driver: i915 v: kernel arch: Gen-7 ports: active: LVDS-1 empty: VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0166
  Device-2: NVIDIA GK107M [GeForce GT 650M] vendor: ASUSTeK N56VZ
    driver: nouveau v: kernel arch: Kepler pcie: speed: 2.5 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: none bus-ID: 01:00.0 chip-ID: 10de:0fd1
    temp: 74.0 C
  Device-3: Sunplus Innovation Asus Webcam type: USB driver: uvcvideo
    bus-ID: 1-1.3:4 chip-ID: 1bcf:2883
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.5
    compositor: kwin_x11 driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: crocus gpu: i915,nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96
  Monitor-1: HDMI-A-1 mapped: HDMI-1-1 pos: right model: Samsung LF24T35
    res: 1920x1080 dpi: 92 diag: 606mm (23.9")
  Monitor-2: LVDS-1 pos: primary,left model: Seiko Epson 0x314c
    res: 1920x1080 dpi: 142 diag: 395mm (15.5")
  API: OpenGL v: 4.2 Mesa 22.1.7 renderer: Mesa Intel HD Graphics 4000 (IVB
    GT2) direct render: Yes

I also noticed error messages related to qt in system logs:

kwin_x11[2328]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54249, resource id: 37748758, major code: 19 (DeleteProperty), minor code: 0
kwin_x11[2328]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54251, resource id: 37748758, major code: 7 (ReparentWindow), minor code: 0
kwin_x11[2328]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 54254, resource id: 37748758, major code: 10 (UnmapWindow), minor code: 0

Hi ozeszty,

Thanks for the input. As you mentioned there are problems with Wayland (e.g. when sharing a screen during meetings), that’s why I usually switch to X11 after the system upgrade.

I note that you are using nouveau as the driver for your nvidia GT 650M GPU.
There are some issues with nvidia GPUs and wayland, particularly with older GPUs.

Nouveau does not seem to support hardware acceleration.
Nvidia drivers version 470 and older do not support wayland in any form.
Nvidia drivers 495 and newer dropped support for some older GPUs. I seem to recall that the kepler chipsets were among those dropped.

While I do not know specifically where in that timeline the GT 650M falls, it appears that shows the driver for it as 418.113, so I doubt it is supported by anything newer than the 470xx driver on linux.

To me, that implies that you cannot get native hardware acceleration and potentially not even wayland with that GPU (unless nouveau actually enables it for that older card) . The issue with kwin seems also potentially related to the older hardware you have.