Krita install fails due to 32 bit 64 bit opencolour library


Is there a workaround for this? 32bit and 64 bit libraries should coexist without problems.

Please be more specific. What did you do, and what is the error you’re getting?

1 Like

I used DNF-Dragora to install Ktita. I got the error:
“Transaction test error: file /usr/share/ocio/ conflicts between attempted installs of OpenColorO-1.1.1-4.fc31.x86_64 and OpenColorO-1.1.1-4.fc31.i686”
I am running Fedora 31, kernel 5.5.10-200.fc31.x86_64 x86_64, with MATE 1.22.2

@dsnillo What happens if you test it with plain dnf on command line? Like

sudo dnf install krita

If that works out of the box, the error might be in dnf-dragora. If the error is still there, please provide the entire output, maybe we can get more details that way.

Personal note: I’d prefer to install it via Flatpak anyway.

It worked fine at the command line:

[rich@RichLap-L ~]$ sudo dnf install krita
Swipe your finger across the fingerprint reader
Last metadata expiration check: 0:05:11 ago on Thu Apr  2 17:59:28 2020.
Dependencies resolved.
 Package            Architecture  Version                  Repository      Size
 krita              x86_64           updates         58 M
Installing dependencies:
 OpenColorIO        x86_64        1.1.1-4.fc31             updates        385 k
 krita-libs         x86_64           updates         14 M
 quazip-qt5         x86_64        0.7.6-4.fc31             fedora          96 k
 yaml-cpp           x86_64        0.6.3-1.fc31             updates        157 k

Transaction Summary
Install  5 Packages

Total size: 73 M
Total download size: 72 M
Installed size: 205 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] OpenColorIO-1.1.1-4.fc31.x86_64.rpm: Already downloaded              
[SKIPPED] yaml-cpp-0.6.3-1.fc31.x86_64.rpm: Already downloaded                 
[SKIPPED] quazip-qt5-0.7.6-4.fc31.x86_64.rpm: Already downloaded               
(4/5): krita-libs-     1.9 MB/s |  14 MB     00:07    
(5/5): krita-          1.3 MB/s |  58 MB     00:45    
Total                                           1.6 MB/s |  72 MB     00:46     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : quazip-qt5-0.7.6-4.fc31.x86_64                         1/5 
  Installing       : yaml-cpp-0.6.3-1.fc31.x86_64                           2/5 
  Installing       : OpenColorIO-1.1.1-4.fc31.x86_64                        3/5 
  Installing       : krita-libs-                       4/5 
  Installing       : krita-                            5/5 
  Running scriptlet: krita-                            5/5 
  Verifying        : OpenColorIO-1.1.1-4.fc31.x86_64                        1/5 
  Verifying        : krita-                            2/5 
  Verifying        : krita-libs-                       3/5 
  Verifying        : yaml-cpp-0.6.3-1.fc31.x86_64                           4/5 
  Verifying        : quazip-qt5-0.7.6-4.fc31.x86_64                         5/5 

  OpenColorIO-1.1.1-4.fc31.x86_64         krita-          
  krita-libs-        quazip-qt5-0.7.6-4.fc31.x86_64       


I have run into errors with dnfdragora before, but the errors made it clear that the problem was dnfdragora, not the installation process. Thanks.

@dsnillo since your problem was solved, can you please mark the thread as solved (by marking one of the posts), it can help others with similar problems to find answer quicker.

1 Like