Konsole, Kitty prompts are now beam instead of block



During the last week, one of the updates to my Fedora 35 workstation KDE turned the prompt in Kitty into a vertical line, I think it is called a ‘beam’? It used to be a block. I quite liked the block and upon examination Konsole has a beam now too (though I don’t know whether it had in the past since I don’t tend to use it. I don’t think it was a beam).

Both terminal applications however can be configured for block, beam or underline cursor types. Both I’ve now set explicitly to “block”, in the Konsole via a new profile that I made default, then restarted Konsole. In Kitty via the config as ctrl+shft+f2, save and restart Kitty and in both applications the cursor/prompt remains a vertical line. What gives? :slight_smile:

Edit. Hmm, in the Konsole app, the cursor type selection is a radio button and “block” is selected by default. If I click “block” again however the cursor turns into a block, and an underline and a beam. So it seems the default block was somehow lost…

I still can’t make Kitty’s cursor become a block again, though.

Edit2. The Kitty cursor becomes a block temporarily if for instance I initiate an ssh connection and get prompted for a password for a certificate.

Can you take a look at this bug?



I tried applying the patch as per the last comment to that bug

sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-ee8f86925f

and got some Kitty updates which I applied and restarted Kitty - no obvious difference, still a vertical line.

I then removed the file which the bug reporter mentions fixed his kitty’s issue:
/usr/lib64/kitty/shell-integration/bash/kitty.bash and restarted kitty and the block is back.
(I’m not sure what bits of integration with bash I’m missing without that file)

As for the bug reporter source /etc/profile does not produce the errors mentioned once the kitty.bash file is gone

Maybe you want to configure as below:

cursor_shape block
shell_integration enabled no-cursor

Source cursor_shape is being ignored in 0.24.0 · Issue #4438 · kovidgoyal/kitty · GitHub

1 Like

The shell integration is described here

The bug fix was for the overriding of the $PS1 prompt for all the terminals. (what you observed on Konsole)

@oprizal posted the configuration information to go back to the block cursor.

If you want to bring the file back. sudo dnf reinstall kitty

Thanks, sorry if that was confusing.

Hi again,


shell_integration enabled no-cursor
cursor_shape block

in kitty.conf the cursor is still a beam. The same but shell_integration disabled makes no difference to the cursor. The error the creator of the bug you first referred to grumpey persists. The error and beam go away when the kitty.bash file is removed (renamed).

I think I shall reinstall kitty anyway to see what happens to the cursor.

So I did
sudo dnf remove kitty
then removed ~.config/kitty/
then sudo dnf install kitty
then applied

cursor_shape block
shell_integration enabled no-cursor

to kitty.conf (ctrl+shft+f2) and restarted kitty : still beam

After I had dnf remove:d kitty the Konsole’s cursor turned into a beam.
If the settings are entered and the profile edited and cursor type block radio button (that’s already selected) clicked on, the cursor becomes a block. Until I do
source /etc/profile
which gives the same error as kitty, and after that the Konsole cursor becomes a beam.

All which is to say: I’m experiencing the same thing as 2053789 – kitty shell integration partially broken after upgrading to 0.24.2 and the suggested patch doesn’t change anything. I know you mentioned it is for the Konsole issue grumpey but it’s a direct response to the very issue my machine seems to be having. I’ll wait and see if that problem reporter reports back.

I just tested. There a profile that make the no-cursor in kitty.conf become useless.

Maybe you want to try step bellow:

# Backup profile
sudo cp /etc/profile.d/kitty.sh /etc/profile.d/kitty.sh.bak

# Open and edit
sudo vim /etc/profile.d/kitty.sh

# Find part

# Change to 
export KITTY_SHELL_INTEGRATION="enabled no-cursor"

# Save, close kitty and open it again.

1 Like

Thanks ever so much! You win the internet! : )

It fixes the Kitty cursor, it also fixes the Konsole cursor. They both give the error when
source /etc/profile but Konsole doesn’t start with or turn into a vertical line/beam and neither does Kitty. Blocks all around all of the time. (Funny how it affects Konsole, it’s an indication that I don’t know enough about these things)

So this profile file you found overrides kitty.conf shell_integration setting I guess, which would explain why setting it to “disabled” in kitty.conf didn’t appear to do anything.

In Shell integration - kitty I find the “Manual shell integration” a bit confusing* but was interested primarily in “Configuration” which says " Shell integration is controlled by the shell_integration option." Which doesn’t really seem to work at the moment in Fedora 35 (and I don’t think a Kitty config bit should affect the Konsole)

*It says to set kitty.confs shell_integration to disabled, then create much the same lines as in the profile you found including the kitty_shell_integration variable, and

" The value of KITTY_SHELL_INTEGRATION is the same as that for shell_integration , except if you want to disable shell integration completely, in which case simply do not set the KITTY_SHELL_INTEGRATION variable at all." thows me because “is the same as”…not automatically since the instruction is to manually write these lines, and “…except if you want to disable shell integration, in which case you don’t set the variable at all” . They can’t mean that one should set the variable here and the kitty.conf option to the same thing as the first instruction is to set the option to disabled. Anyway…this isn’t really entirely related to the issue at hand and it’s more a query for the Kitty author I guess : )

Edit. Supplemental. Testing some, including with the suggested .bashrc lines for manual integration with the shell, and changing that, kitty.conf and /etc/profile.d/kitty.sh in different combinations, the following was observed:

-kitty.confs shell_integration and .bashrcs kitty_shell_integration variable value are always overridden by /etc/profile.d/kitty.sh’s shell integration variable.
-when the suggested .bashrc lines for manual integration with bash are added both Konsole and Kitty start with the error produced by doing source /etc/profile
-It’s what kitty adds to .bashrc that makes the Konsole display a similar issue. Makes sense that it would also read that file


FYI, https://bodhi.fedoraproject.org/updates/FEDORA-2022-d2c9637537


Thanks, I saw that you reported the issue back when we spoke about it last and a new issue was created recently for the same issue and now it appears a fix is in the work. Great : )