Kinoite not seen in grub

I have garuda arch on one nvme an fedora on another SSD an windows on another.
My issue is fedora is not being seen on garuda’s grub menu i’ve reinstalled an ran sudo update-grub. even mad a copy of the fedora boot efi an stuck it in the boot folder on garuda no luck. i have to go to bios to log into fedora. While fedoras grub does see them both it’s how do i say pretty ugly and i cant use garudas snapshots from btrfs if i use the fedora grub menu that has way to many options in it. So any ideas on how to get fedora to show up in grub? I only have ever had this issue with immutable systems so I’m not so knowledgeable on what steps to take.

I’m not sure if kinoite has a command to get a inxi so i will update the specs below if i find that command.

Any help would be appreciated.

Operating System: Bazzite 39
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.12
Kernel Version: 6.7.6-201.fsync.fc39.x86_64 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 980/PCIe/SSE2

Removed nvidia

I had a similar issue on Arch Linux. An update removed the GRUB_DISABLE_OS_PROBER option and the default is to not run os-prober. Did you check your /etc/default/grub?
https://wiki.archlinux.org/title/GRUB#Detecting_other_operating_systems

Yep, it’s fully working an searches but cant see kinoite sadly.