Kinoite install hangs at "cancel waiting for multipath siblings of nvme0n1"

I have a broken NVME SSD and want to do a fresh Kinoite install on my new one. Crucial P5 1,8TB.

It had some weird Windows partition format on it, but deleting all also didnt change anything.

I use “Impression” Flatpak (using udisks2 under the hood) to burn the latest downloaded Kinoite Image on a USB stick.

I booted, and it always hangs at this step:

I have had this error in the past and no idea what it means, I have no multipath anything, its a single SSD on the entire Laptop, now even with a single partition.

I tried reflashing the image to the stick with no difference.

Removed flatpak

Personally I would use the old tried and true method.

First use a workstation image on the USB and remove ALL partitioning on the nvme device, creating only an empty GPT partition table. I use gdisk for that task.

Then I would boot the usb I intended to use for installation and proceed from that point.

Sometimes there may be lingering bits on a device that need to be totally obliterated and for me it seems this approach has worked well in the past.

New devices and especially reused devices are good candidates for a little prep work.

If supported

nvme id-ctrl /dev/nvme0 -H

sanitizing the device makes a lot of sense

nvme sanitize /dev/nvme0 -a start-crypto-erase

Setting the logical block size to match the physical block size, usually 4096 has been beneficial (check supported lbaf from nvme id-ns -H output)

nvme format --lbaf=1 /dev/nvme0n1

Using a tool, e.g. sgdisk, to put an empty gpt on it is fine but should not be necessary. Using gpt is desired and should be default.

2 Likes

thanks! Found out that nvme-cli is not installed on Kinoite, will create a PR

It has no lbaf support. Will try if it is already fixed after the erase

NVME Identify Controller:
vid       : 0xc0a9
ssvid     : 0xc0a9
sn        : 22343AD9A318        
mn        : CT2000P5PSSD8                           
fr        : P7CR403 
rab       : 0
ieee      : 00a075
cmic      : 0
  [3:3] : 0     ANA not supported
  [2:2] : 0     PCI
  [1:1] : 0     Single Controller
  [0:0] : 0     Single Port

mdts      : 9
cntlid    : 0
ver       : 0x10400
rtd3r     : 0x7a120
rtd3e     : 0x1e8480
oaes      : 0
  [31:31] : 0   Discovery Log Change Notice Not Supported
  [27:27] : 0   Zone Descriptor Changed Notices Not Supported
  [15:15] : 0   Normal NSS Shutdown Event Not Supported
  [14:14] : 0   Endurance Group Event Aggregate Log Page Change Notice Not Supported
  [13:13] : 0   LBA Status Information Notices Not Supported
  [12:12] : 0   Predictable Latency Event Aggregate Log Change Notices Not Supported
  [11:11] : 0   Asymmetric Namespace Access Change Notices Not Supported
  [9:9] : 0     Firmware Activation Notices Not Supported
  [8:8] : 0     Namespace Attribute Changed Event Not Supported

ctratt    : 0x2
  [19:19] : 0   Flexible Data Placement Not Supported
  [15:15] : 0   Extended LBA Formats Not Supported
  [14:14] : 0   Delete NVM Set Not Supported
  [13:13] : 0   Delete Endurance Group Not Supported
  [12:12] : 0   Variable Capacity Management Not Supported
  [11:11] : 0   Fixed Capacity Management Not Supported
  [10:10] : 0   Multi Domain Subsystem Not Supported
  [9:9] : 0     UUID List Not Supported
  [8:8] : 0     SQ Associations Not Supported
  [7:7] : 0     Namespace Granularity Not Supported
  [6:6] : 0     Traffic Based Keep Alive Not Supported
  [5:5] : 0     Predictable Latency Mode Not Supported
  [4:4] : 0     Endurance Groups Not Supported
  [3:3] : 0     Read Recovery Levels Not Supported
  [2:2] : 0     NVM Sets Not Supported
  [1:1] : 0x1   Non-Operational Power State Permissive Supported
  [0:0] : 0     128-bit Host Identifier Not Supported

rrls      : 0
cntrltype : 1
  [7:2] : 0     Reserved
  [1:0] : 0x1   I/O Controller
fguid     : 00000000-0000-0000-0000-000000000000
crdt1     : 0
crdt2     : 0
crdt3     : 0
nvmsr     : 0
  [1:1] : 0     NVM subsystem Not part of an Enclosure
  [0:0] : 0     NVM subsystem Not part of a Storage Device

vwci      : 0
  [7:7] : 0     VPD Write Cycles Remaining field is Not valid.
  [6:0] : 0     VPD Write Cycles Remaining 

mec       : 0
  [1:1] : 0     NVM subsystem Not contains a Management Endpoint on a PCIe port
  [0:0] : 0     NVM subsystem Not contains a Management Endpoint on an SMBus/I2C port

oacs      : 0x17
  [10:10] : 0   Lockdown Command and Feature Not Supported
  [9:9] : 0     Get LBA Status Capability Not Supported
  [8:8] : 0     Doorbell Buffer Config Not Supported
  [7:7] : 0     Virtualization Management Not Supported
  [6:6] : 0     NVMe-MI Send and Receive Not Supported
  [5:5] : 0     Directives Not Supported
  [4:4] : 0x1   Device Self-test Supported
  [3:3] : 0     NS Management and Attachment Not Supported
  [2:2] : 0x1   FW Commit and Download Supported
  [1:1] : 0x1   Format NVM Supported
  [0:0] : 0x1   Security Send and Receive Supported

acl       : 3
aerl      : 7
frmw      : 0x14
  [5:5] : 0     Multiple FW or Boot Update Detection Not Supported
  [4:4] : 0x1   Firmware Activate Without Reset Supported
  [3:1] : 0x2   Number of Firmware Slots
  [0:0] : 0     Firmware Slot 1 Read/Write

lpa       : 0x1b
  [6:6] : 0     Telemetry Log Data Area 4 Not Supported
  [5:5] : 0     LID 0x0, Scope of each command in LID 0x5, 0x12, 0x13 Not Supported
  [4:4] : 0x1   Persistent Event log Supported
  [3:3] : 0x1   Telemetry host/controller initiated log page Supported
  [2:2] : 0     Extended data for Get Log Page Not Supported
  [1:1] : 0x1   Command Effects Log Page Supported
  [0:0] : 0x1   SMART/Health Log Page per NS Supported

elpe      : 255
  [7:0] : 255 (0's based)       Error Log Page Entries (ELPE)

npss      : 4
  [7:0] : 4 (0's based) Number of Power States Support (NPSS)

avscc     : 0x1
  [0:0] : 0x1   Admin Vendor Specific Commands uses NVMe Format

apsta     : 0x1
  [0:0] : 0x1   Autonomous Power State Transitions Supported

wctemp    : 353
 [15:0] : 80 °C (353 K) Warning Composite Temperature Threshold (WCTEMP)

cctemp    : 355
 [15:0] : 82 °C (355 K) Critical Composite Temperature Threshold (CCTEMP)

mtfa      : 50
hmpre     : 0
hmmin     : 0
tnvmcap   : 2.000.398.934.016
[127:0] : 2.000.398.934.016
        Total NVM Capacity (TNVMCAP)

unvmcap   : 0
[127:0] : 0
        Unallocated NVM Capacity (UNVMCAP)

rpmbs     : 0
 [31:24]: 0     Access Size
 [23:16]: 0     Total Size
  [5:3] : 0     Authentication Method
  [2:0] : 0     Number of RPMB Units

edstt     : 30
dsto      : 1
fwug      : 0
kas       : 0
hctma     : 0x1
  [0:0] : 0x1   Host Controlled Thermal Management Supported

mntmt     : 273
 [15:0] : 0 °C (273 K)  Minimum Thermal Management Temperature (MNTMT)

mxtmt     : 353
 [15:0] : 80 °C (353 K) Maximum Thermal Management Temperature (MXTMT)

sanicap   : 0x60000003
  [31:30] : 0x1 Media is not additionally modified after sanitize operation completes successfully
  [29:29] : 0x1 No-Deallocate After Sanitize bit in Sanitize command Not Supported
    [2:2] : 0   Overwrite Sanitize Operation Not Supported
    [1:1] : 0x1 Block Erase Sanitize Operation Supported
    [0:0] : 0x1 Crypto Erase Sanitize Operation Supported

hmminds   : 0
hmmaxd    : 0
nsetidmax : 0
endgidmax : 0
anatt     : 0
anacap    : 0
  [7:7] : 0     Non-zero group ID Not Supported
  [6:6] : 0     Group ID does change
  [4:4] : 0     ANA Change state Not Supported
  [3:3] : 0     ANA Persistent Loss state Not Supported
  [2:2] : 0     ANA Inaccessible state Not Supported
  [1:1] : 0     ANA Non-optimized state Not Supported
  [0:0] : 0     ANA Optimized state Not Supported

anagrpmax : 0
nanagrpid : 0
pels      : 125
domainid  : 0
megcap    : 0
sqes      : 0x66
  [7:4] : 0x6   Max SQ Entry Size (64)
  [3:0] : 0x6   Min SQ Entry Size (64)

cqes      : 0x44
  [7:4] : 0x4   Max CQ Entry Size (16)
  [3:0] : 0x4   Min CQ Entry Size (16)

maxcmd    : 0
nn        : 1
oncs      : 0x57
  [10:10] : 0   All Fast Copy Not Supported
  [9:9] : 0     Copy Single Atomicity Not Supported
  [8:8] : 0     Copy Not Supported
  [7:7] : 0     Verify Not Supported
  [6:6] : 0x1   Timestamp Supported
  [5:5] : 0     Reservations Not Supported
  [4:4] : 0x1   Save and Select Supported
  [3:3] : 0     Write Zeroes Not Supported
  [2:2] : 0x1   Data Set Management Supported
  [1:1] : 0x1   Write Uncorrectable Supported
  [0:0] : 0x1   Compare Supported

fuses     : 0
  [0:0] : 0     Fused Compare and Write Not Supported

fna       : 0x4
  [3:3] : 0     Format NVM Broadcast NSID (FFFFFFFFh) Supported
  [2:2] : 0x1   Crypto Erase Supported as part of Secure Erase
  [1:1] : 0     Crypto Erase Applies to Single Namespace(s)
  [0:0] : 0     Format Applies to Single Namespace(s)

vwc       : 0x7
  [2:1] : 0x3   The Flush command supports NSID set to FFFFFFFFh
  [0:0] : 0x1   Volatile Write Cache Present

awun      : 255
awupf     : 0
icsvscc   : 1
  [0:0] : 0x1   NVM Vendor Specific Commands uses NVMe Format

nwpc      : 0
  [2:2] : 0     Permanent Write Protect Not Supported
  [1:1] : 0     Write Protect Until Power Supply Not Supported
  [0:0] : 0     No Write Protect and Write Protect Namespace Not Supported

acwu      : 0
ocfs      : 0
  [3:3] : 0     Controller Copy Format 3h Not Supported
  [2:2] : 0     Controller Copy Format 2h Not Supported
  [1:1] : 0     Controller Copy Format 1h Not Supported
  [0:0] : 0     Controller Copy Format 0h Not Supported

sgls      : 0
 [15:8] : 0     SGL Descriptor Threshold
 [1:0]  : 0     Scatter-Gather Lists Not Supported

mnan      : 0
maxdna    : 0
maxcna    : 0
oaqd      : 0
subnqn    : nqn.2014-08.com.micron:nvme:nvm-subsystem-sn-22343AD9A318
ioccsz    : 0
iorcsz    : 0
icdoff    : 0
fcatt     : 0
  [0:0] : 0     Dynamic Controller Model

msdbd     : 0
ofcs      : 0
  [0:0] : 0     Disconnect command Not Supported

ps      0 : mp:8.25W operational enlat:0 exlat:0 rrt:0 rrl:0
            rwt:0 rwl:0 idle_power:- active_power:-
            active_power_workload:-
ps      1 : mp:4.00W operational enlat:0 exlat:0 rrt:1 rrl:1
            rwt:1 rwl:1 idle_power:- active_power:-
            active_power_workload:-
ps      2 : mp:2.00W operational enlat:0 exlat:0 rrt:2 rrl:2
            rwt:2 rwl:2 idle_power:- active_power:-
            active_power_workload:-
ps      3 : mp:0.1000W non-operational enlat:5000 exlat:6000 rrt:3 rrl:3
            rwt:3 rwl:3 idle_power:- active_power:-
            active_power_workload:-
ps      4 : mp:0.0050W non-operational enlat:12000 exlat:35000 rrt:4 rrl:4
            rwt:4 rwl:4 idle_power:- active_power:-
            active_power_workload:-

Well it turns out that the id-ctrl subcommand is not the right one to get info on the namespace which is what has an LBA. Use:

nvme id-ns /dev/nvme0n1 -H
1 Like

Hmm

get-namespace-id: Inappropriate ioctl for device

I do not have an nvme ssd to try these commands out on but the process of sanitizing followed by formatting is what I have used before. There are other nvme subcommands that should lead to what is missing.

nvme list
nvme list-ns

From your startup photo I am expecting the controller of interest to be nvme0 (char device) which would contain a single namespace, nvme0n1 (block device). I do not remember if the sanitize operation removes all namespaces and if it does that may require another step (see create-ns subcommand). But I am under the impression that without being an nvme fabric product create-ns would not be applicable. Not sure. Keep updating this post if you would.

1 Like
Node                  Generic               SN                   Model                                    Namespace  Usage                      Format           FW Rev  
--------------------- --------------------- -------------------- ---------------------------------------- ---------- -------------------------- ---------------- --------
/dev/nvme0n1          /dev/ng0n1            22343AD9A318         CT2000P5PSSD8                            0x1          2.00  TB /   2.00  TB    512   B +  0 B   P7CR403 

>> sudo nvme list-ns /dev/nvme0
[   0]:0x1

thanks for the help!

1 Like

That device is exactly like mine that I recently purchased (different serial number of course) and I simply connected it to my mobo and performed an installation onto it. I had to do nothing else to get it working.

Did not do anything except use the F39 live media to perform the installation, though I did not use automatic partitioning but instead chose to use manual config with LVM + ext4 for the root file system.

Okay. It looks like your /dev/nvme0n1 block device is using 512B block size. So running, as root of course

nvme id-ns /dev/nvme0n1 -H

should show what LBA sizes are supported. I think it would be unusual for 4k to not be supported. If “LBA Format 1” is the 4k block size format then use

nvme format --lbaf=1 /dev/nvme0n1

to reformat using 4k logical blocks.

Setting LBA to 4k in Linux should always provide the best performance. I only use Linux so for me the story stops here. But if you use OSs that do not support 4k …

1 Like

I don’t know about @boredsquirrel , but on my system I get

# nvme id-ns /dev/nvme0n1 -H
NVME Identify Namespace 1:
{trim}
LBA Format  0 : Metadata Size: 0   bytes - Data Size: 512 bytes - Relative Performance: 0 Best (in use)

To me it would appear the 512 byte block size is preferred since it says the best is already in use.
I don’t see anything that shows the supported LBA sizes.

1 Like

@computersavvy

As only one LBA Format line was printed it seems your device only supports one. If it supported more there would be multiple LBA Format lines.

As far as I’ve seen the performance difference is slight but the nod goes to 4k LBA. With the difference being slight I understand that manufacturers mark both LBA sizes as Best.

I also like using the 4k LBA as the smallest unit for read or write to any of the filesystems I use is 4k so there is no reason for a smaller LBA. With the nvme devices I’ve used it does not seem that they are advanced format devices so the problem of alignment should never come up. Also I think all the storage related tools in fedora handle alignment well so even with advanced format devices alignment issues should not come up. Still, 4k devices are nice in that they simplify alignment.

In any case using either LBA on a nvme device is so much faster than SATA SSDs even. Cannot really go wrong whatever gets used.

1 Like

I definitely prefer the 4k block size on devices that support it.

Uhm I will try the commands, but are you sure this fixes the problem?

I can mount and view the SSD normally when it was NTFS, I could edit it with kde partitionmanager etc.

That was in an external SATA SSD with Kinoite 40, and the SSD internally.

Only when booting from usb, no sata ssd connected, nvme in internal slot, I always get this error.


I still get the “inappropriate ioctl for this device” error and the format fails due to not being supported.

I tried recreating the GPT partition table and reboot but it didnt change.

I filed a bug for Anaconda.

This does not sound like a problem with the nvme itself. To me it sounds like a problem with the fact you are installing kinoite and possibly the firmware on the mobo.

Have you confirmed that the mobo is at the latest firmware level?
Have you tried booting with a Workstation image?

My assumption is that this error is occurring when booting from the kinoite install image, and ISTR there have been some threads here about problems with installing kinoite/silverblue on certain hardware configs.

Specifically with what setup/config were you able to use the kde partition manager to edit the SSD? I know kinoite is kde and I wonder if it works when usb attached but not when attached directly to the mobo. If that is the case then it would appear the installer may not have the correct driver for nvme on that mobo, or that the mobo firmware does not support the particular nvme device.

1 Like

Hm, it is a Clevo NV41MZ with Novacustom Coreboot firmware but not the latest. I can ask them if that NVME is supported.

Poorly I dont have my usb-m.2 adapter with me…

I was able to see and use the SSD normally when having it still internally inserted but using Kinoite 40 on a sata ssd over a usb adapter that I use as a workaround.

Interesting, clonezilla didnt detect the drive at all, which may be a kernel problem. Not sure if it is stable or unstable. I know that I had “no write permission on /dev/mem” on the unstable edition.

Fedora meanwhile can see the NVME, I am trying to just dd my clonezilla backup (1TB SATA SSD) onto the bigger 2TB NVME SSD. That SATA SSD worked but then wasnt bootable anymore, lets see :nerd_face:

Make sure both devices use the same block size. GPT partitioning is quite different between 512b and 4k block size when it comes to block count.

Out of curiosity, did you sanitize the device with the nvme command? There are multiple benefits in doing so and since your original post indicated weirdness with respect to what was on it to start with…

GUID partition table format